• udaykumar k
  • 0 Points
  • Member since 2015
  • Senior software engineer
  • Techmahindra

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 6
I am developing a Lightning Component based off the tutorial for the Account List Lightning Component. In the Apex Controller, I want to modify the query to only select records related to the currently viewed record. I tried using ApexPages.currentPage().getParameters().get('id') but it didn't work. The user would be viewing the details of a particular Event when this code would run. How can I get the current Event record ID in the Apex Controller of a Lightning Component?

Here is the turotial I am referring to:https://developer.salesforce.com/trailhead/project/slds-lightning-components-workshop/slds-lc-6

I'm using Lightning Design System with a Visualforce page and using <svg> tag to get SLDS Icons on Page header and Buttons. Initially on page load all works fine but when I try to re-render any <apex:outputPanel> that have <svg> icons inside it, on complete of rerendering it vanish my all <svg> icons.
I tried to debbug it by Inspect element in chrome and found after re-rendering any block my <svg> icon tags are not there.

anyone else experiencing this issue?

Any advise or guidance would be greatly appreciated.


This has been driving me insane for the last few hours, and I can't find a solution. I hope someone with more VF experience can help me out.


I have a VF page which uses a template, but in addition to the stylesheets linked in the template,  I link an additional one in the pages with specific css. In the output it's added to the page head correctly, and all page content on the page is styled as should be. Including the content in the repeater. But when rerendering, it's content isn't styled.


The linked css is actually a VF mage with content type txt/css, I tried using a static resource css file, but that made no difference.


<apex:page cache="true" showHeader="false" contentType="text/css">
.. css content


My page displays a list  (using apex:repeater) of sf idea's (but that ofc should not be relevant), and has a prev&next page commandlink on the bottom of the page which uses the nex soql offset to imlement pagination. You get the point, the repeater showing the content is reloaded , works perfectly, all data is there but BAM , none of the additional css styles applied to it whatsoever. However, some of the css linked in the css template are applied. But even when adding the additional styles to the page template, they are not applied either.  Where am I going wrong here ?


the page:


<apex:page id="test_ideahome" showHeader="false" title="{!$Label.site.site_login}" standardStylesheets="false" controller="SW_IdeaHomeController">
     <apex:stylesheet value="{!$Page.SW_IdeaCSS}" />
  <apex:composition template="{!$Site.Template}"> 
    <apex:define name="body" > 
       <div class="button-center-wrap">
         <apex:Outputlink styleclass="button addIdea" value="{!$Page.SW_IdeaNew}">Post your own idea</apex:Outputlink>
       <apex:form >
            <apex:pageblock id="idea_list">
                <apex:outputtext style="padding:20px;" value="The Idea community could not be found !" rendered="{!noCommunity}" />
                  <apex:outputtext style="padding:20px;" value="There are no idea's yet, click the link above to post one yourself!" rendered="{!noideas}" />
                    <section id="ideas">
                       <apex:repeat value="{!Ideas}" var="idea" id="ideaRepeater" rendered="{! noideas==false}">
                                <div class="content-wrap">
                                    <span class="score">
                                        <apex:outputText value="Score: "/>
                                        <apex:outputText styleclass="score-number" value="{! text(idea.VoteTotal) }"/>
                                    <div class="text">
                                            <apex:commandLink action="{!gotopage}" value="{!idea.title}" ><apex:param name="id" value="{!idea.Id}"/></apex:commandLink>
                                            <apex:outputText value="{! idea.body }" escape="false"/>
                                    <strong class="comments"><apex:outputText value="{! text(idea.numcomments)}"/></strong>
                                    <apex:outputText value="comments"/><span>|</span>                  
                                    <apex:outputText value="posted on:"/>
                                        <apex:outputtext value=" {0,date,yyyy.MM.dd}" >
                                            <apex:param value="{! idea.createddate}" />
                                    <apex:outputText value="posted by:"/>
                                    <strong><apex:outputtext value="{! idea.createdby.communitynickname}" /></strong><span>|</span>
                                    <apex:outputText value="lastcomment on:"/>
                                    <strong><apex:outputtext value="{! text(idea.lastcommentdate)}" /></strong><span>|</span>
                                    <apex:outputText value="status:"/>
                                    <strong><apex:outputtext value="{!idea.status}" /></strong>
            <div class="pager">
                <apex:commandlink styleclass="button prevButton" value="Previous page" action="{! prevPage}" rerender="idea_list" rendered="{! page_offset!=0}"/> <apex:commandlink styleclass="button" value="Next page" action="{! nextPage}" rerender="idea_list" rendered="{! noideas==false}"/>
            <hr />
            <div class="button-center-wrap">
                <apex:Outputlink styleclass="button addIdea" value="{!$Page.SW_IdeaNew}">Post your own idea</apex:Outputlink>

 All of this is on Authentication site pages, but I doubt that is relevant, the profile of the user with which i'm testing has access to all pages, including the css page, etc. All is styled fine on pageload, including the content in the repeater. But when rerendering, it's content isn't styled.


It happens in chrome,FF and IE so its not browser related.





When I run the flow in the desktop flow designer it works fine but when i run the same flow from SFDC UI (Flows->run) i get this error

"An unhandled fault has occurred in this flow. An unhandled fault has occurred while processing the flow. Please contact your system administrator for more information."


Has anyone else faced this issue. Can anyone provide some help to overcome this issue.



I am having the enterprise.wsdl file and i am trying to create a jar file using command 


java -classpath wsc-20.jar com.sforce.ws.tools.wsdlc enterprise.wsdl enterprise.jar


but getting an error "Error: Unable to find compiler. Make sure that tools.jar is in your classpath:

java.lang.ClassNotFoundException: com/sun/tools/javac/Main.class"


can anyone help me..............


thank you.......................


I know similar questions on this have been asked before, but jus tin case someone has an answer.

I am making SOAP callouts from asynchrous code and it was all working fine until the certs expired on the server I was calling.


the certs were replaced, but now I get the following error:

Failed to loginSystem.CalloutException: IO Exception: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target


Is it possible that Salesforce is caching the cert somewhere?


I tried deleting the remote site in the security controls and recreating it, but it made no difference.


The guy in charge of the server I am calling has come back with this:

I checked the following link: http://wiki.developerforce.com/index.php/Outbound_Messaging_SSL_CA_Certificates

Our certificate was signed by the following root certificate: COMODO High-Assurance Secure Server CA

Which in turn was signed by AddTrust External CA Root

This I can find in the list: http://wiki.developerforce.com/index.php/Outbound_Messaging_SSL_CA_Certificates#addtrustexternalca


The values seem to match, so the certificate should be recognised fine.