• Shai Fisher
  • 10 Points
  • Member since 2015

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 10
Hello everyone,

I'm trying to deploy a package which contains Custom fields added on Account standard object with History tracking enabled. The deployment fails with the error 
The entity: Account does not have history tracking enabled
I enabled the history tracking on the account object definition and it is not working. 
can someone help me understand what is going on?

  • March 06, 2018
  • Like
  • 0

We are using ANT and other tools to deploy metadata between one org to another. But in one of the sandboxes we a setting called 'Allow WebLink access via the Tooling API' whch is not available in destination org. We would like to know how to set this setting in SF so that we can move meatdata easily.

Intially i got few errors and modfied the wsdl, now i am able to see the prase sucessfull message.
Parse successful: Warnings 0, Errors 0
but when i am clicking on Generate Apex code getting the below error. 
Apex Generation Failed
Unable to find complexType for  (URL) NameIDC_element.

We are experiencing an issue when making a web service callout using a certificate (self-signed). The external system hosting this web service is Microsoft 2012 server with IIS.
The error message from the IIS log is "A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider" with error code 403.16

The error message received as a response to the call in SFDC is "Web service callout failed: Unexpected element. Parser was expecting element 'http://schemas.xmlsoap.org/soap/envelope/:Envelope' but found 'http://www.w3.org/1999/xhtml:html'"

Has anybody come across such issue ?

Hi i was implementing a enhancedList for my custom object called 'Standard__c'. I wanted to hide the 'New Standard' button that automatically appears at the top.


I have tried a similar thing with listViews (which also has the button) and it worked.


In both cases the button is made up from an input element with the name attribute set to 'assign'. The following jQuery worked for listViews, but not enhancedList:




The only difference i can think of, is that the listView buttons are in a span:


<span><input value="New Standard" class="btn" name="new" onclick="navigateToUrl('https://na14.salesforce.com/a09/e?retURL=https%3A%2F%2Fc.na14.visual.force.com%2Fapex%2FlistStandards%3Fcore.apexpages.devmode.url%3D1','LIST_VIEW','new');" title="New Standard" type="button"></span> <span><input value="Change Owner" class="btn" name="assign" onclick="this.form.action = 'https://na14.salesforce.com/_ui/core/customentity/CustomEntityDataTemplateMassAction?retURL=https%3A%2F%2Fc.na14.visual.force.com%2Fapex%2FlistStandards%3Fcore.apexpages.devmode.url%3D1&amp;from=&amp;ent=01Id0000000o09n'" title="Change Owner" type="submit"></span> 


Whereas on the enhancedList, the button is within a list. Do i need to be handling the list elements also?


<div class="listButtons" id="j_id0:j_id5_listButtons">
<ul class="piped">
<li><input value="New Standard" class="btn" name="new" onclick="navigateToUrl('https://na14.salesforce.com/a09/e?retURL=https%3A%2F%2Fc.na14.visual.force.com%2Fapex%2FlistStandards%3Fcore.apexpages.devmode.url%3D1','LIST_VIEW','new');" title="New Standard" type="button"></li>
<li><input value="Change Owner" class="btn" name="assign" onclick="this.form.action = 'https://na14.salesforce.com/_ui/core/customentity/CustomEntityDataTemplateMassAction?retURL=https%3A%2F%2Fc.na14.visual.force.com%2Fapex%2FlistStandards%3Fcore.apexpages.devmode.url%3D1&amp;from=&amp;ent=01Id0000000o09n'" title="Change Owner" type="submit"></li>
<li class="lastItem"><input id="j_id0:j_id5_refresh" src="s.gif" href="javascript&colon;void(0)" onclick="javascript&colon;ListViewport.instances['j_id0:j_id5'].refreshList()" class="btn refreshListButton" title="Refresh" type="button"></li>


Hi All,


I have a code which are getting all the fields name and their properties like api name, label , data type.


Now for deployed the code I am getting this exception :

System.SObjectException: Field Lead.LastViewedDate is inaccessible in this context.


It seems that there is a field "LastViewedDate" , I have checked all fields but I am not able to find this.

Please let me know if any one have any idea.





i want to asked about deploy record type in salesforce.

For example : i created new record type --> RTSample. In "Picklists Available For Editing", i edited Salutation Field (Mr. and Mrs. moved to Selected Values).


After that,i tried to deploy to other instance. In other instance, there are RTSample Record Type but in "Picklists Available For Editing", all value are in "Available Value"


my question --> How to deploy Record type with "Picklists Available For Editing" ???

  • February 18, 2011
  • Like
  • 0
I was wondering if anyone has had experience with this one. Is there a way to set the MIME type of an email sent via APEX? Additionally, I'll want to generate and attach an ICS file with meeting invite details. The ICS file is pretty much a txt file so that shouldn't be that tricky. Has anyone tried this before?
  • June 05, 2009
  • Like
  • 1

Hello community!  I just wanted to start by saying thanks for all your help in previous posts and for posting such handy chunks of knowledge in general.  We've been trying to import what I thought was a straightforward WSDL (see below) with no luck.  The error returned is...


Error: Unable to find complexType for {http://www.hmco.com/EAI/OTS/Customer}customerID_element


I found the definition for that element and noticed it was defined as a simpleType and though I know the simpleTypes are now supported, just in case, I changed all occurences of simpleType to xsd:string as in this thread.  That then got me this error...


Error: Unable to find schema for element; {http://www.w3.org/2001/XMLSchema}string


This last one really stumped me since string is a base type definitely in the W3 schema.  Any ideas?



<?xml version="1.0" encoding="UTF-8"?> <!--Created by TIBCO WSDL--> <wsdl:definitions xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:tns="http://www.hmco.com/EAI/OTS/Customer/createSundryCustomerImpl" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:ns0="http://www.hmco.com/EAI/OTS/Customer" xmlns:ns1="http://www.hmco.com/EAI" xmlns:ns2="http://www.hmco.com/EAI/OTS/Material" name="Untitled" targetNamespace="http://www.hmco.com/EAI/OTS/Customer/createSundryCustomerImpl"> <wsdl:types> <xsd:schema xmlns="http://www.hmco.com/EAI" xmlns:xsd="http://www.w3.org/2001/XMLSchema" targetNamespace="http://www.hmco.com/EAI" elementFormDefault="qualified" attributeFormDefault="unqualified"> <xsd:complexType name="eaiException"> <xsd:sequence> <xsd:element ref="ns1:errorList"/> </xsd:sequence> </xsd:complexType> <xsd:complexType name="error"> <xsd:sequence> <xsd:element name="errorCategory" type="xsd:string"/> <xsd:element name="errorCode" type="xsd:string"/> <xsd:element name="errorMessage" type="xsd:string"/> </xsd:sequence> </xsd:complexType> <xsd:element name="asyncRequestId"> <xsd:complexType> <xsd:sequence> <xsd:element ref="ns1:requestId"/> </xsd:sequence> </xsd:complexType> </xsd:element> <xsd:element name="asyncRequestStatus"> <xsd:complexType> <xsd:sequence> <xsd:element name="isReady" type="xsd:boolean"/> </xsd:sequence> </xsd:complexType> </xsd:element> <xsd:element name="error" type="ns1:error"/> <xsd:element name="errorList"> <xsd:complexType> <xsd:sequence> <xsd:element ref="ns1:error" minOccurs="0" maxOccurs="unbounded"/> </xsd:sequence> </xsd:complexType> </xsd:element> <xsd:element name="requestId" type="xsd:string"/> </xsd:schema>




We have a simple trigger that takes the name of the owning group of a case and assigns that value to a field on the case for easy reporting & view creation. This trigger works fine in tests as well as for regular SFDC users. However, this trigger throws an exception when it is executed during the creation of a case from the customer portal.

The trigger:

Map queues =
new Map([select id, name from Group where type = 'Queue']);

for (Case ca : Trigger.new) {
if(queues.containsKey(ca.ownerId)) {
ca.escalation_group__c = queues.get(ca.ownerId).name;

The Customer Portal Exception:

Apex trigger updateEscalationGroup caused an unexpected exception, contact your administrator: updateEscalationGroup: compiling trigger body caused by: line 3, column 26: sObject type 'Group' is not supported.

From what I've read I thought apex code was not limited by the object access of the executing user. At first glance this does appear to be a permission issue, but I have not been able to find any way to effectively change it.