• David Torres 15
  • NEWBIE
  • 0 Points
  • Member since 2015

  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 1
    Likes Given
  • 3
    Questions
  • 4
    Replies
Hi!

I am creating Knowledge articles through REST API, I have issues cleaning the URL name since it its not clear how Salesforce cleans it, Does anyone form SFDC can share the regex?
I need to get the certificate, I am using :

/services/data/v43.0/tooling/sobjects/Certificate/{objectId}/CertificateChain

Using the REST method above, I do get a body nevertheless I am trying to encode it to have exactly the same content when downloading it from the UI. any suggestions will be apreciaate it.
i fired an apex job inner an InstallHandler, and the behaviour is pretty weird, the status of batch is "processing" but while time is going, the number of processed batches do not increase like whether the process would be paused, suddenly like whether the process awake, it increases the number of batches in few seconds then pause again. the most annoying of this is that each pause takes several time(aprox 1 hour) turning it unacceptable, some ideas? im using sandbox, does it have something related?

Thanks in advance!!
i fired an apex job inner an InstallHandler, and the behaviour is pretty weird, the status of batch is "processing" but while time is going, the number of processed batches do not increase like whether the process would be paused, suddenly like whether the process awake, it increases the number of batches in few seconds then pause again. the most annoying of this is that each pause takes several time(aprox 1 hour) turning it unacceptable, some ideas? im using sandbox, does it have something related?

Thanks in advance!!
Hey everyone,
I am having trouble with a select-box. This problem only occurs on iPhones, not on Android. I am using bootstrap-sf1.
So I have a select-box:
<apex:actionFunction name="filtertime" status="statusfilter" reRender="inadvance" action="{!queryHolidays}">
    <apex:param value="" name="timefilter" assignTo="{!InAdvanceTo}" />
    <apex:param value="true" name="queryinadvance" assignTo="{!QueryDataInAdvance}" />
</apex:actionFunction>

<select id="selectfiltertime" class="form-control" onchange="filtertime(this.options[this.selectedIndex].value);">
    <apex:repeat value="{!InAdvanceToValues}" var="fil">
	<option value="{!fil.Value}">{!fil.Label}</option>
    </apex:repeat>
</select>

Depending where I put this select-box, when I press it on my iPhone, the screen jumps to the top of my page and closes the select-box dialog to pick the values.
If the select-box is below this:
<div class="panel panel-info">
    <div class="panel-heading">Today</div>
    <div class="panel-body">
        "Some content"
    </div>
</div>
then the problem occurs. If I put my select-box above this, there is no problem.
The "Some content" is an outputpanel and within three repeats.

So this works:
.......

<select id="selectfiltertime" class="form-control" onchange="filtertime(this.options[this.selectedIndex].value);">
    <apex:repeat value="{!InAdvanceToValues}" var="fil">
        <option value="{!fil.Value}">{!fil.Label}</option>
    </apex:repeat>
</select>

<div class="panel panel-info">
    <div class="panel-heading">Today</div>
    <div class="panel-body">
        <apex:outputpanel id="now">
            <apex:outputpanel id="ooo1" rendered="{!HasDataNow}">
                <h3>Out Of Office</h3>
            </apex:outputpanel>
            <apex:repeat value="{!DataNow}" var="item">
                <div class="well well-sm">
                    <div class="media">
                        <img width="48px" height="48px" src="{!item.PhotoURL}" class="pull-left" />
                        <div class="media-body">
                            <apex:outpupanel>

                            .......

                            </apex:outputpanel>

                            .......

                        </div>

                        .......

                    </div>
                </div>
            </apex:repeat>

            .......

        </apex:outputpanel>
    </div>
</div>

.......
And this doesn't:
.......

<div class="panel panel-info">
    <div class="panel-heading">Today</div>
    <div class="panel-body">
        <apex:outputpanel id="now">
            <apex:outputpanel id="ooo1" rendered="{!HasDataNow}">
                <h3>Out Of Office</h3>
            </apex:outputpanel>
            <apex:repeat value="{!DataNow}" var="item">
                <div class="well well-sm">
                    <div class="media">
                        <img width="48px" height="48px" src="{!item.PhotoURL}" class="pull-left" />
                        <div class="media-body">
                            <apex:outpupanel>

                            .......

                            </apex:outputpanel>

                            .......

                        </div>

                        .......

                    </div>
                </div>
            </apex:repeat>

            .......

        </apex:outputpanel>
    </div>
</div>

<select id="selectfiltertime" class="form-control" onchange="filtertime(this.options[this.selectedIndex].value);">
    <apex:repeat value="{!InAdvanceToValues}" var="fil">
        <option value="{!fil.Value}">{!fil.Label}</option>
    </apex:repeat>
</select>

.......

I don't know how else to describe this problem.
Do you need more code?

Best regards,
Florian
Hi,

I am executing a batch class from post install script class that implement Installhandler interface, it executes successfully, but no batches are processed even there exists a lot of relavant records.

When I execute this batch class from elsewhere (developer console) rather than post install script class, its working fine and processing all of the records.

Also, note that both apex class are marked as "without sharing".

Any good answer would be greatly appreciated.

Thanks,

Hey folks,

 

I have some Visualforce pages in a managed package that I would like to expose to ALL users in an org (ALL meaning those with a license to my app and those who do not) and based on whether they have a license or not it will act differently.

 

At first glance I thought, hey cool they have a function for exactly that... I can call UserInfo.isCurrentUserLicensed('myApp') to find out and act accordingly.

 

Upon further thought, I realized that no code from the package can ever be run by unlicensed users in the first place, so there is no way to perform such a check... am I missing something?  Or is this method not able to be used from within a managed package?

 

You can use it in your own code to see if a user has a license to something else you've installed... or one partner app could use it to see if you have their competitors product installed (LOL) but nether of those seem all that helpful.  Any idea what this method is good for?

 

In case you are wondering, this is another thread that explains what I am trying to accomplish which lead me to wonder about this method:  http://boards.developerforce.com/t5/Visualforce-Development/Action-Override-to-Managed-VF-page-breaks-other-users/m-p/442317#M50598

Hi,

I am executing a batch class from post install script class that implement Installhandler interface, it executes successfully, but no batches are processed even there exists a lot of relavant records.

When I execute this batch class from elsewhere (developer console) rather than post install script class, its working fine and processing all of the records.

Also, note that both apex class are marked as "without sharing".

Any good answer would be greatly appreciated.

Thanks,