• Bruce Stewart
  • 35 Points
  • Member since 2015

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 4
  • 5
I had trouble today verifying a step in Apex Specialist Super Badge.
I accomplished steps 1-4 before the change in trailhead profiles.
I linked up several DE orgs last week, but hadn't checked any steps or gotten any new badges since.
Today I tried several times to check step 5, and there were various errors.
I also couldn't log into developer.salesforce.com.

I cleared cookies / cache, and then could log into developer.salesforce.org.
The 5th superbadge challenge was then dimmed out - I couldn't attempt to verify.

I then went to my DE orgs in Trailhead profile, and set the one where I was doing Apex Superbadge work as the DEFAULT - there was previously *no* default set.

I then could check the challenge and passed.

I'm just posting this in case others have trouble verifying in an org that they may not have set as DEEFAULT in their Trailhead profile.
I am attempting the "Apex" course offered by Salesforce University via Premier / Online H&T.
During Exercise 9.1 Receiving and Sending EMails through Apex, you're supposed to make use of a Candidate Application Submission Form herokuApp  hosted on a VFP in the training org:

public class posAppFormRedirect_Controller {
    public PageReference doRedirect() {
        String apiUrl = [select id, User_API_URL__c from User where Id = :UserInfo.getUserId()].User_API_URL__c;
        return new PageReference('https://candidateobm.herokuapp.com/email?sid='+UserInfo.getSessionId() + '&url=' + apiUrl + '&uname=' + UserInfo.getUserName());

When I land at that page, I get a static form to fill out, but the Position Control is not populated with any Positions from the org.
<select class="form-control" id="selectList" name="posId" required>
			<option value="" style="display: none;" disabled>Please Select the Position you are Applying for</option>

Since it's a required field on the form, I can't submit to check on the CandidateEmailHandler class I wrote.
I can see the solution files, but it would be nice to demo this.

I have added the 'https://candidateobm.herokuapp.com' as a remote site within the org.

What might be keeping the HerokuApp from obtaining the posIDs (or I presume Position Names) to populate the selectList?
I do have "Open" "Active" Positions that are shared with all internal users ...

Since I can't see the Heroku App's inner workings, it's difficult to troubleshoot why no positions would appear.
I've tried Chrome & Firefox & IE11.

I have tackled 2 of the SuperBadges so far.
I think they are a tremendous value to seeing how deep in the weeds your skills might stick.

That said, the requirements are a little sloppily worded.
I think that is a good thing, as it is quite realistic.

Has anyone used any tools they care to share to distill the actual requirements out of the SuperBadge requirements into some lasting document?  Like if you had to do the challenge over again, would you rather work from your hard-won playbook, or the (slight) mess the task writers handed us?

If you care to share post back.  Thanks!

I received this error today checking Lightning Dashboards (Challenge 3) in a dev org spun up yesterday.

"If you're using a new DE and seeing this error, please post to the developer forums and reference error id: OPJANAEK"

I did not make any prior configurations or coding in this DE org, other than to achieve challenges 1 & 2.

I'm stuck at the first challenge where it always returns me:
Could not find an entry in the ServiceCredentials custom setting named 'BillingServiceCredential' with the specified username and password. Ensure the you have entered the data correctly into the custom settings record.
I think that I did everything right. The unmanaged package came with a custom setting called ServiceCredentials:

User-added image
I clicked manage and added the BillingServiceCredential

User-added image

With following details
User-added image

Still giving me above error!
Any ideas?


I received this error today checking Lightning Dashboards (Challenge 3) in a dev org spun up yesterday.

"If you're using a new DE and seeing this error, please post to the developer forums and reference error id: OPJANAEK"

I did not make any prior configurations or coding in this DE org, other than to achieve challenges 1 & 2.
Can't find apex class with invocable method in Process Builder on production org. On develop org it works fine.
User-added image
I tryed recompile all classes, it did not help. Class successfuly pass test. Please, what can be wrong?
global class SearchObjectWhenCreate {

global class Request {
    public String objectId;
    public String searchType;

public static void searchObject(List<Request> requests) {

    SearchButtonsController searchButtonsCtrl = new SearchButtonsController();
    List<verf__VF_Search__c> listOfSearches = new List<verf__VF_Search__c>();

    if (Schema.sObjectType.VF_Search__c.fields.Id.isAccessible()){
        listOfSearches = [SELECT Id
                        FROM verf__VF_Search__c
                        WHERE Name =: requests[0].searchType
                        LIMIT 1];
        searchButtonsCtrl.vf_searchId = listOfSearches[0].Id;
        searchButtonsCtrl.strObjectId = requests[0].objectId;
        searchButtonsCtrl.isCalledFromProcessBuilder = true;
        request(searchButtonsCtrl.xmlStringxmlRes, searchButtonsCtrl.vf_searchName);

public static void request(String xmlStringxmlRes, String searchName) {
    Http httpProtocol = new Http();
    HttpRequest request = new HttpRequest();
    HttpResponse response = new HttpResponse();
    String body = 'request=' + xmlStringxmlRes;

    String endpoint = 'https://viqzrh5hp3.execute-api.us-east-1.amazonaws.com/verified_first';

    try {
            response = httpProtocol.send(request);
            parseXMLResponce(response.getBody(), searchName);
    } catch(System.CalloutException e) {

Hi All,

I am doing Apex Rest Callouts in Trailhead Apex Integration Service Module.

This is AnimalLocator class.
public class AnimalLocator{
    public static String getAnimalNameById(Integer x){
        Http h = new Http();
        HttpRequest req = new HttpRequest();
        req.setEndpoint('https://th-apex-http-callout.herokuapp.com/animals/' + x);
        HttpResponse res = h.send(req);
        Map<String, Object> results = (Map<String, Object>)JSON.deserializeUntyped(res.getBody());
        Map<String, Object> animal = (Map<String, Object>) results.get('animal');
        return (String)animal.get('name');
However, I was encountered this error when checking challenge.
Challenge Not yet complete... here's what's wrong: 
The Apex class does not appear to be calling the REST endpoint using HttpRequest.
I have no idea what it means, but I have call the REST endpoint.
  • December 24, 2015
  • Like
  • 0
How to resolve this error at Creating a Visualforce Page in Conference Management App? 
I have followed all the steps the said. But still I am getting this error - "There was an unhandled exception. Please reference ID: RVLHBBOZ. Error: Faraday::Error::ResourceNotFound. Message: NOT_FOUND: The requested resource does not exist  Note: you may run into errors if you've skipped previous steps."

Please Help!