• Yahor Volkau
  • 232 Points
  • Member since 2015
  • Senior Developer
  • PARX

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 1
    Likes Given
  • 0
  • 11

We are using ANT and other tools to deploy metadata between one org to another. But in one of the sandboxes we a setting called 'Allow WebLink access via the Tooling API' whch is not available in destination org. We would like to know how to set this setting in SF so that we can move meatdata easily.

Hi all,

I ran into an issue where the Product field was locked on Quote Line Items. We need to be able to change the product field. I made a workaround with a custom field and process builder. The custom fied was a lookup from QLI to Product. When the custom field was changed, the process builder would update the Product field to match the custom field.

This was working well for about two weeks! Now all of a sudden I am getting the below flow error. What changed? I can go back to QLIs that I previously updated with the process outlined, and they are still there with their updated products. How do I get this working again?

INVALID_FIELD_FOR_INSERT_UPDATE: Unable to create/update fields: Product2Id. Please check the security settings of this field and verify that it is read/write for your profile or permission set.
Helo Everyone

I have to create a new trigger to send some data with an API in Mandrill. I started to do it over Eclipse Version: Mars.2 Release (4.5.2). Downloaded all the Force.com elements to work. As soon as I started to work, I connected to salesforce and the Force.com download all the Apex Classes, TRiggers and any one else element, with their Metadata files.

The main problem is that all the xml files has the error Cannot find the declaration of element 'ApexClass'. those errors seems to create conflict when I tried to deploy. Any one knows how to fix the problems with the xml files?
Can't find apex class with invocable method in Process Builder on production org. On develop org it works fine.
User-added image
I tryed recompile all classes, it did not help. Class successfuly pass test. Please, what can be wrong?
global class SearchObjectWhenCreate {

global class Request {
    public String objectId;
    public String searchType;

public static void searchObject(List<Request> requests) {

    SearchButtonsController searchButtonsCtrl = new SearchButtonsController();
    List<verf__VF_Search__c> listOfSearches = new List<verf__VF_Search__c>();

    if (Schema.sObjectType.VF_Search__c.fields.Id.isAccessible()){
        listOfSearches = [SELECT Id
                        FROM verf__VF_Search__c
                        WHERE Name =: requests[0].searchType
                        LIMIT 1];
        searchButtonsCtrl.vf_searchId = listOfSearches[0].Id;
        searchButtonsCtrl.strObjectId = requests[0].objectId;
        searchButtonsCtrl.isCalledFromProcessBuilder = true;
        request(searchButtonsCtrl.xmlStringxmlRes, searchButtonsCtrl.vf_searchName);

public static void request(String xmlStringxmlRes, String searchName) {
    Http httpProtocol = new Http();
    HttpRequest request = new HttpRequest();
    HttpResponse response = new HttpResponse();
    String body = 'request=' + xmlStringxmlRes;

    String endpoint = 'https://viqzrh5hp3.execute-api.us-east-1.amazonaws.com/verified_first';

    try {
            response = httpProtocol.send(request);
            parseXMLResponce(response.getBody(), searchName);
    } catch(System.CalloutException e) {

Hi ,
Please help me answering below questions.
1. What must the Controller for a Visualforce page utilize to override the Standard
Opportunity view button?
A. The StandardSetController to support related lists for pagination.
B. the Opportunity StandardController for pre -built functionality.
C. A callback constructor to reference the StandardController.
D.A constructor that intrializes a private Opportunity variable.
Confused between Answer B and C

2.what is a correct pattern to follow when programming in Apex on a Multi -tenant
A. Apex code is created in a separate environment from schema to reduce deployment
B.DML is performed on one record at a time to avoid possible data concurrency issues.
C. Queries select the fewest fields and records possible to avoid exceeding
governor limits.
D. Apex classes use the ''with sharing" keyword to prevent access from other server
I think Answer is C

3.How can a developer refer to, or instantiate, a PageReference in Apex?
Choose 2 answers
A. By using a PageReference with a partial or full URL.
B. By using the Page object and a Visualforce page name.
C. By using the ApexPages.Page() method with a Visualforce page name.
D. By using the PageReference.Page() method with a partial or full URL.
I think Answer A,B

4.What can the developer do to successfully deploy the new Visualforce page and
A. Create test classes to exercise the Visualforce page markup.
B. Select "Disable Parallel Apex Testing" to run all the tests.
C. Add test methods to existing test classes from previous deployments.
D. Select "Fast Deployment'' to bypass running all the tests.
Answer D

5. When can a developer use a custom Visualforce page in a Force.com application?
Choose 2 answers
A. To create components for dashboards and layouts.
B. To deploy components between two organizations.
C. To generate a PDF document with application data.
D. To modify the page layout settings for a custom object.
Answer A, C

6. Which statement about the Lookup Relationship between a Custom Object and a
Standard Object is correct?
A. The Lookup Relationship on the Custom Object can prevent the deletion of the
Standard Object.
B. The Lookup Relationship cat:That be marked as required on the page layout for the
Custom Object.
C. The Custom Object will be deleted when the referenced Standard Object is
D. The Custom Object inherits security from the referenced Standard Objects
Answer C

Please clarify these questions.
Hi All,

We are getting this error while inserting Case Manual share records through Apex manual sharing.

duplicate value found: <unknown> duplicates value on record with id: <unknown>

We are not able to identify and reproduce this error.

Can someone provide some inputs on cause of this error?

I recently upgraded to Windows 8.1, and am now having issues with the Force.com IDE. When I select Force.com->Add/remove metadata components, I'm not able to see any custom field child component in the Objects-Custom component. Does anyone have any ideas on what is causing the issue?
User-added image
I need to remove the header of the pageblocktable 
<apex:outputpanel id="out1">
                     <div id="target1" style="overflow:scroll; width:100%; height:200px;">
                         <apex:pageBlockTable id="pgtable1" value="{!accounts}" var="account" >
                             <apex:column style="width:350px;">
                             <apex:column style="width:300px">
                             <apex:column style="width:300px">

Hi Guys,


We have two classes System and Datetime in apex. Both provides static now  method. I want to know what is difference between now method from System and Datetime class. I would also like to know broad idea of System class and when to use it?





In my web-to-case form, I want to specify a record type.  See html line below.  However, when I submit the form, the case record type is still set to the default record of the default case owner.  Do I have the correct syntax for the html line?  I checked the Support Settings and it is not set to override the type with the owner's default.

<input type=hidden name="RecordTypeId" value="01280000000G4N7AAK">



I have been using the IDE to merge two SF environments and I am getting validation errors:


cvc-elt.1: Cannot find the declaration of element 'ReportFolder'.

cvc-elt.1: Cannot find the declaration of element 'DashboardFolder'.

cvc-elt.1: Cannot find the declaration of element 'DocumentFolder'.


These happen against all the -meta.xml files in src/reports, src/dashboards, and src/documents, respectively. These files have not themselves been changed.


The errors seem to be significant because one of the changed dashboards complains that its new report cannot be found, even though the path names look OK to me


Our main development has been happening in a Sandbox, but the business have also been making changes in Live, since the sandbox was refreshed. I am trying to get all their changes merged from Live into the Sandbox for final testing before deployment. I created a Force.com project in the IDE for each environment and then compared the projects and copied changes from the Live project to the Sandbox project.


The changes included changes to Dashboards and to Reports, but not to Documents, so it is especially surprising to see the latter amongst these errors!


Does anyone know what these messages mean? And of course, how to fix them?






I need to remove the header of the pageblocktable 
<apex:outputpanel id="out1">
                     <div id="target1" style="overflow:scroll; width:100%; height:200px;">
                         <apex:pageBlockTable id="pgtable1" value="{!accounts}" var="account" >
                             <apex:column style="width:350px;">
                             <apex:column style="width:300px">
                             <apex:column style="width:300px">