• Sanjay Rathore5
  • 55 Points
  • Member since 2015
  • Happy Sharing

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 6
Set up one permission set fro 2fa, assigned it to user.


Challenge Not yet complete... here's what's wrong: 
Could not find just one PermissionSet enabled for 2FA.

The only otehr permission sets were included in trailhead and i can;t delete them or see if they have 2fa set.

PLease help
I am going after the Lightning Experience roll-out specialist badge and I am having issues with challenge #10. Could you give me some pointers on how to finish this challenge?  

Here is my error : The Lightning component named TrailheaDX must open a link to https://developer.salesforce.com/trailheadx/, must open in a new window (using the target attribute of ui:outputurl), and must be included in the Sales app. 

Here is my code 

Component : 

<aura:component implements="flexipage:availableForAllPageTypes" access="global" >
    <aura:attribute name="myURL" type="String" default="https://developer.salesforce.com/trailheadx/"/>
    <ui:outputURL value="{!v.myURL}" label="TrailheaDX" target="_blank"/>

Controller : 

    navigate : function(component, event, helper) {
        var address = component.find("address").get("v.myURL");
        var urlEvent = $A.get("e.force:navigateToURL");
            "url": 'https://developer.salesforce.com/trailheadx/' + address

In addition, i added the app to the utility bar and the homepage of the lightning sales app. 

Could you give me any pointers on how to finish this challenge? 

User-added image

User-added image
I am stuck with the width of modal window pos up when someone clicks on a quick action. I saw there is a option to adjust the height.
But i am not able to adjust the width of modal window at all. Tried all possibilities.

Kindly help me on this.
I have this error and not sure how to resolve.  Since I can't find Sales Path Setting in the playground, so I use Path setting to create a new path.
However, it seems like the challenege doesn't recognize my work.  Can someone help me on how to resolve this?

Hi Expert,

I want to get Account realted list that would be display in Visualforce page. so i am using below query. but when i run the code and store each object value in list then get error "List index  is outbound"

public List<Account> accList{get;set;}
    public List<Opportunity> oppList{get;set;}
    public List<Contact> contList{get;set;}

     List<Account> acc= [SELECT Name, (SELECT Name, Type FROM Opportunities),(SELECT Name, email FROM Contacts) FROM Account where Name = 'Dickenson plc'];
     accList = acc;
     contList = new List<Contact>(acc[0].Contacts);
     oppList = new List<Opportunity>(acc[0].Opportunities);

Please suggest

Hi All,
I am getting an error as  "Could not find just one PermissionSet enabled for 2FA" for Step6 of Security Specialist Super Badge.
Step6 Error Security Super Badge
I had created a permission set which has “Two-Factor Authentication for API Logins” and “Two-Factor Authentication for User Interface Logins” checked , this permission set is assigned to Samantha Cordero. I tested the 2FA with Samantha’s login and it passed since it asked me to authenticate using sales force authenticator app along with username and password.
I also tried changing the API name but still facing the same issue, not  sure what is missing. Any help is really appreciated!!!