• jyothsna reddy 5
  • 354 Points
  • Member since 2015

  • Chatter
  • 8
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 5
  • 62

I am working on the Lead object. I want to create a validation for not allowing the record to be saved when LeadSource is not entered.
Please suggest.
Hi ,
I am new to salesforce can any one explain  what is Rollup summary field .

Thanks in advance
I would like to know how can I insert NULL values for a record through Data Loader in below two scenarios-

Scenario1- In case of Normal API

Scenario2- In case Bulk API

Can you please illustarte it with example. It will be a great help to understand it.

Hello Guys,
                   I need a search list button on vf page.  when we type for any keyword to search it should display all the items related to that word. How to achieve this?
i have one text field so in that want to fill only characters can u tell me the formula
I am calling a REST Api which needs oAuthkey and Password. Here is my Class
public with sharing class DetailButtonController
  public string responseText {get;set;}

  public DetailButtonController() {
     responseText = '';

   public void doSomething() {

    String oauthkey='asdasdasd asd77cf6ef73b77';
    String oauthsecret='asdasdasdasd2195385b9aa2';
    String action='get';

    Http m_http = new Http();
    HttpRequest req = new HttpRequest();

    String content = 'action='+EncodingUtil.urlEncode(action, 'UTF-8')+'&oauth_consumer_key='+EncodingUtil.urlEncode(oauthkey, 'UTF-8')+'&oauth_consumer_secret='+EncodingUtil.urlEncode('oauthsecret', 'UTF-8');


    httpResponse response = m_http.send(req);

    responseText = response.getBody();


Apex Code
<apex:page controller="DetailButtonController">
    <b>Hello World!</b>
    <apex:form >
        <apex:commandButton value="Do something" action="{!doSomething}"/>
        <apex:outputPanel layout="block">

The error i am getting is as below, Does that mean there is some other method to call Rest API using oauth?
<?xml version="1.0" encoding="UTF-8" standalone="yes"?><response success="false" xmlns="http://www.abc.com"><error http-status="401">oauth consumer key and/or signature not included in request parameters or authorization header</error></response>

The code snippets are incomplete in the trail named "Build an Account Geolocation App". I was unable to complete some tasks.Whenever I preview my application, it gives a the error as shown
in the screenshot. Can you please give me an idea where this problem might be? I would be really grateful.​

User-added image
I'm pretty sure I have created a hybrid mobile app - but I still get this message 'Challenge Not yet complete... here's what's wrong: You haven't run and logged in from the 'TrailheadHybridTest' app.' I created a new Dev org and logged in to the app OK but Trailhead won't let me pass this challenge. 
I am trying to do the Admin Beginner Trailhead course and am getting the
message "No feed post was found that linked to the Trailhead URL." when I
do the exercise for Chatter - "Create a link post. Share a link with other
users to http://developer.salesforce.com/trailhead"
Everything works fine until I try to run the app in the emulator: cordova emulate ios The app starts to be deployed in the emulator and an error pops up: Salesforce Error Can't connect to salesforce: An SSL error has occurred and a secure connection to the server cannot be made.
From Setup, enter “Bulk Data Load Jobs” in the Quick Find box, then select Bulk Data Load Jobs." Does not exist in my PE org and I am logged in as the admin.
I am trying to do the Admin Beginner Trailhead course and am getting the
message "No feed post was found that linked to the Trailhead URL." when I
do the exercise for Chatter - "Create a link post. Share a link with other
users to http://developer.salesforce.com/trailhead"
Hi All,

I want to update the few fields of converted leads. So can you guys please help me and let me know how can update it. 

Thanks in advance
how many  type modes in the <apex:page block>components 
Hi Everyone ,

I was developing a functionality where , if the Lead object has a photo ( used custom rich text area field ) , then on Lead Conversion whenever the Contact is created , the photo should flow from Lead to Contact's field ( another custom field in Contact object ) . As this cannot be done via configuration , as Lead conversion mapping doesn't allow rich text area fields to map , i wrote a trigger on Lead Object , and update the related contact . 

Now the problem is , although the photo is updated in the Contact's Custom field , it shows that "Unavailable Photo" . Can anyone help in solving in this ?
In my salesforce org, whenever a lead is saved with LeadSource value as "Automation In Action", it automatically changes the LeadSource to "AE Generated" after about 30 minutes. I can't find from where it is getting changed. I checked the workflows, process and triggers except those in the managed packages. Is there any way to find from where the field update is getting triggered?

what is the Dml operation?
whats is the database.querylocator?
What is the interface?
What is the GovernerLimit in DML?
please can you tell me how to restore deleted app
Hi all,

I have question on Visualforce page embeded in detail page. My content on the VF page is dynamic, so I can't have a fixed height of the frame. What is the proper way to implement auto resize the iframe for VF? It would be great if someone here can point me to the right direction. Thanks.
Hi All,

I have the below requirement.
On registration page we have two picklist fields 'country' and 'Taxes'.By default when page is loaded first time,I want to set country as 'India' and Taxes as 'PAN'.But once user changed the country from India to any other,then I would like to display the Taxes related to that country only(through select list).How it can be achieved through actionfunction?

Thanks in advance.
1.When will use the Before insert and after insert?
2.What is the use of before upadte and after update?
3.what is context variables?
4.what is the difference b/w trigger.new and trigger.old

What is the difference b/w before insert and after insert?
What is the difference b/w action function and action support?
Hi all how to update a field using batchclass.

can any provide a sample code.

thanks in advance.
I completed the steps as instructed.  The workflow rule and Process Builder work in the app. When I click Verify on Trailhead, I get the following error.  

Step Not yet complete... here's what's wrong: 
The validation rule does not appear to have the correct error formula. Make sure Exhaust Port Inspectors have > 150% utilization' 
Note: you may run into errors if you've skipped previous steps.

Here is my validation rule:   AND ( Name = "Exhaust Port Inspector", Utilization__c < 1.5)

I'm very puzzled that it works in the app, but is returning a verify error 

We are facing the issue with soql 101 error while deploying trigger.We have tried to capture the issue in all the ways.please let me know where could be the causing an isssue in below code.its an urgent request.

trigger contactdetails on Contact (before update) {
Map<id,id> cntctOwnerMap = new Map<id,id>();
Map<id,id> accountOwnerMap = new Map<id,id>();
Map<id,id> accountTeamMap = new Map<id,id>();
Map<id,id> accountidMap = new Map<id,id>();
Map<id,id> accountTeamMember = new Map<id,id>();

List<contact> ct1 = new List<Contact>();
set <string> profileids = new set<string>{'00e700000013gAKAAY','00e700000013gPeAAI','00e700000013YgPAAU','00e70000000x3egAAA','00e70000000x8q3AAA','00e70000000xE3lAAE','00e70000000xE7xAAE','00e70000000sR8UAAU','00e70000000xBqJAAU','00e70000000x3XVAAY','00e700000013YIGAA2','00e70000000x3oSAAQ'};
set <id> userIds = new set<id> {'00570000001u6pxAAA','00570000002VUUlAAO','00570000001R8tOAAS'};
List <id> accountids = new List<id>();
String currentprofileid = Userinfo.getprofileid();
map<id,set<id>> a = new map<id,set<id>>();
List<accountteammember> acc = new List<accountteammember>();

ct1 = [select id , ownerid , account.ownerid , accountid from contact where id in : trigger.newMap.keySet()];
for(Integer i = 0 ; i<ct1.size() ; i++)

for(Integer i = 0 ; i<ct1.size() ; i++)

for(Contact ct: ct1)
acc = [select id , accountid , userid from accountteammember where accountid in : accountids];
for(Id ab : accountids)
set <id> aa = new set < id > ();
for(accountteammember at: acc)

for(contact c : trigger.new){

if(userinfo.getuserid()==cntctOwnerMap.get(c.id) || userinfo.getuserid()==accountownermap.get(c.id) || a.get(accountidMap.get(c.id)).contains(userinfo.getuserid()) || profileids.contains(userinfo.getprofileid()) || userIds.contains(userinfo.getuserid()))
c.adderror('You are not authorized to make any change on the Contact.');

How can I merge more than 3 contacts?
Is there any code, open source or method I can use for this thing I need to do?

If someone could provide me some code would be great. 

Thanks in advance.

I am working on the Lead object. I want to create a validation for not allowing the record to be saved when LeadSource is not entered.
Please suggest.
i have three pick list fields 1 country 2 state  3 city  i select country state want to chang also 2&3 but  in a diffrent cuntry same states are there also city s witch validation i use