• Jagadesh Bandaru
  • 0 Points
  • Member since 2017

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 6
  • 0

Can someone help me understand this critical update --


It says "If you have a process with the Do you want to execute the actions only when specified changes are made to the record? option selected, or it uses the ISCHANGED() function in your criteria, this update could cause the process to behave differently." Does this mean we should not use ISCHANGED() in the criteria everywhere and rather split ISNEW() and ISCHANGED() to different decision loops?


I have a requirement to print the results returned on a lightning component (being shown on lightning datatable) . I have tried pulling in the HTML from the div that contains the datatable, but I could not get that done. Any suggestions?

I have to create a validation rule so that it will check the following conditions against:
1. The Length >2
2. Length<=20
3. It can only contain 2 alphabets (in any position).

This is what I wrote:
OR(LEN(abc__c)>20,LEN(abc__c)<3,    Not( REGEX(abc__c,".2[a-zA-Z].2"))), which is not working.

Any help would be appreciated.

Hi All,

I have an issue with updating child records. There is a custom API call from an external systems to update child records (in a MD relation). The issue is that there are more than 5 API calls to update child records belonging to the same Parent. And since the first (or any other) record is still in process, the parent is getting locked. Any ideas on how to solve this?

We tried "For Update" and "System.EnqueJob" but the same issue still exists.

Jagadesh Kumar.
Hi all,

I have added a component to the existing dashboard and this is being accessed by salesforce Platform license users. It is working fine in few of the sandboxes but in other sandboxes including Full copy it is errored out showing this:

User-added image
The error is not showing up if I keep the running user as one of the Platform licensed users but the records should be based on logged in user not some other user. All the profile level permissions are same in all sandboxes

Any help would be appreciated.

Hi , 

I have overriden the new page for a custom object using vf page and populating the parent id in one of the fields, which is working as expected.
However, when the user clicks Save & New button from edit page, the parent id is not getting populated. Any idea on how to populate this?

This is how my controller looks like:

       res = (childobject__c)controller.getRecord();
        if(ApexPages.currentPage().getParameters().get('parentObject__c')!= null)