• junaid_aj
  • 0 Points
  • Member since 2009

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 4
  • 7



I have configured RBAC for the Org.


Let us say John is having access to view admin page and Smith is not having.


If i logged in as Smith and click on Admin Page i will be getting Insufficient Privilege Error.


So i dont want this default error Page of Salesforce to be show.


I have defined my Friendly Exception Page if any exception comes.


If you have faced same issue please reply.



Mohammed Junaid.

I am able to connect to Dev Org and can Create Account Object,but when i try to invoke my Webservice Class i am getting following Error.
I had searched in forums also but no help.

 faultCode: {http://soap.sforce.com/schemas/class/WebserviceActivityData}INVALID_SESSION_ID
 faultString: INVALID_SESSION_ID: Invalid Session ID found in SessionHeader: Illegal Session

The Code for Invoking is:

private boolean login() {
        WebserviceActivityDataService ws = new WebserviceActivityDataServiceLocator();
        SessionHeader sh = new SessionHeader();
        WebserviceActivityDataPortType por = null;
        try {           
            binding = (WebserviceActivityDataBindingStub) new WebserviceActivityDataServiceLocator()
            // Time out after a minute
            loginResult = binding.login(un, pw);

            binding.setHeader(ws.getServiceName().getNamespaceURI(), "SessionHeader", sh);

            por = ws.getWebserviceActivityData();

        } catch (ServiceException ex) {
                    .println("ERROR: creating binding to soap service, error was: \n"
                            + ex.getMessage());
            return false;
        } catch (Exception e) {
        return true;

Please help.

I have generated Java File from WSDL of the Class.

Mohammed Junaid.

We are able to write the @future method and retrive the value.

But if we want to use the result obtained in this method to diaplay in the page.

we are getting the following error


@future call currently not allowed


An unexpected error has occurred. Your development organization has been notified.


Can we get a solution to display the result obtained from @future method in the page.

I have developed an application,prior to Friday when i used to do a build using Ant to any org Build got Successful but now i am facing a wierd situatution saying that Build Failed because of An error occurred on your page.
But Same code if i deploy from other Org it is getting Successful.

Any Help would be Great.

Mohammed Junaid.
It won't work on updated code.  How do I refresh/reset the Deploy Wizard?



I have spent hours trying to deploy my triggers to the production org.

I create a testscript and everything is fine no error.

But when I tried to deploy, I received this error:


Unable to deploy Force.com components.

Reason: ZipException: Zip file must have at least one entry


Can anyone help me to solve this issue?


Also, where can I get a tutorial on deploying using ANT. I think ANT is easier to use than Eclipse.



Hi!  I created a package with some vforce pages and a couple classes in my dev instance of SF.  After is installed the package into the enterprise instance, I could no longer find the url for the vf page in my dev instance.  I then installed the package into a second enterprise instance.  The first enterprise instance than could not find the url of the vf page.  How do I get my stuff to work everywhere independantly?  Thanks!
  • May 12, 2009
  • Like
  • 0

This issue appears to be nearly a year old, but there was never a resolution given at the time it was first posted. I've recently begun experiencing this same issue and I've been unable to identify the root cause. Applications I've been running for more than a year have never experienced this issue and then, rather spontaneously, sessions were suddenly becoming prematurely invalid. Please see this thread posted over a year ago regarding the same issue. I just posted to that thread but noticed that the post didn't actually bump the thread to the top of the general development thread listing.

  • May 06, 2009
  • Like
  • 0

Hello Friends,


I know that there is a limit of 10000 rows for SOQL query.

But I have more than 10000 rows to process, how can I do that in pure VF/Apex approach.






      when i ran the command to generate java api for my wsdl file, Getting errors:


Exception in thread "main" java.lang.NoClassDefFoundError: org.apache.commons.logging.LogFactory
        at org.apache.axis.components.logger.LogFactory.class$(LogFactory.java:45)
        at org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41)
        at org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33)
        at org.apache.axis.i18n.ProjectResourceBundle.<clinit>(ProjectResourceBundle.java:53)
        at org.apache.axis.i18n.MessagesConstants.<clinit>(MessagesConstants.java:32)
        at org.apache.axis.utils.Messages.<clinit>(Messages.java:36)
        at org.apache.axis.wsdl.WSDL2Java.<clinit>(WSDL2Java.java:112)


The command i used is: java org.apache.axis.wsdl.WSDL2Java Student.wsdl


The jar files i included are:







commons-logging-1.0.4 .jar










Can any one please guide me how to generate the API succesfully

Thanks in adv,