• Typo
  • 0 Points
  • Member since 2011

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 0

Since I started using Data Loader v 21.0 I appear to be getting bad error*.csv reports. I believe that the number of errors returned is correct, and that the error messages are probably correct, but Data Loader is not returning the rows that actually generated the errors. It is returning rows, but I have yet to discover the relationship between the rows returned and the rows that actually generated the error (it doesn't appear to be the previous row in the processed csv, nor the row following the row reported). ????


This is very strange--I count on Data Loader to report the erroneous rows. I often can correct the errors in excel and reload them quickly. But, at this point, I don't have any way to identify the bad rows from the data loader error files.


I'm considering reloading v 21.0--maybe there is a bug in my version that has been corrected?

  • May 31, 2011
  • Like
  • 0


This is the DAO I tried to set up. Is there an error for the class? I downloaded the MS JDBC driver (tried both versions 2.0 and 3.0). I added a CLASSPATH to my enviroment variables. Tried moving the sqljdbc.jar to the root and changing the CLASSPATH. Still the bean does not seem to find the jdbc driver. The log is below with the first error bolded.
<bean id="sqlServerDataSource"
    <property name="driverClassName" value="com.microsoft.sqlserver.jdbc.sqlserverdriver"/>
    <property name="url" value="jdbc:sqlserver://paassql01;database=PAAS;"/> 
    <property name="url" value="jdbc:sqlserver://paassql01;database=PAAS;integratedSecurity=true;"/> 






Loading XML bean definitions from file [C:\Program Files\salesforce.com\Apex Data Loader 21.0\bin\..\PAASPORTconf\database-conf.xml]

2011-05-12 20:51:14,891 FATAL [SFuserNamesToSQLtestusers] controller.Controller createDao (Controller.java:172) - Error creating data access object

org.springframework.beans.factory.BeanDefinitionStoreException: Error registering bean with name 'sqlServerDataSource' defined in file [C:\Program Files\salesforce.com\Apex Data Loader 21.0\bin\..\PAASPORTconf\database-conf.xml]: Bean class [com.microsoft.sqlserver.jdbc.SQLServerDataSource] not found; nested exception is java.lang.ClassNotFoundException: com.microsoft.sqlserver.jdbc.SQLServerDataSource

java.lang.ClassNotFoundException: com.microsoft.sqlserver.jdbc.SQLServerDataSource

 at java.net.URLClassLoader$1.run(URLClassLoader.java:200)

 at java.security.AccessController.doPrivileged(Native Method)

 at java.net.URLClassLoader.findClass(URLClassLoader.java:188)

 at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)

 at java.lang.ClassLoader.loadClass(ClassLoader.java:251)

 at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

 at java.lang.Class.forName0(Native Method)

 at java.lang.Class.forName(Class.java:242)

 at org.springframework.util.ClassUtils.forName(ClassUtils.java:108)

 at org.springframework.beans.factory.support.BeanDefinitionReaderUtils.createBeanDefinition(BeanDefinitionReaderUtils.java:65)

 at org.springframework.beans.factory.xml.DefaultXmlBeanDefinitionParser.parseBeanDefinitionElement(DefaultXmlBeanDefinitionParser.java:426)


  • May 13, 2011
  • Like
  • 0