• Aneesha K S
  • 0 Points
  • Member since 2013

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
  • 0

Some of the users of my org,using salesforce for outlook, have came up saying that their calender events are getting deleted on its own. I checked for any triggers/classes that deletes the events but could not find any. 


I checked the recycle bin and found that many events deleted by users as well as by an Integration user. The user says that they did not delete it. Please help me here.



I have a lead record, which I am sharing through the out-of-box S2S functionality. The process is not manual.

Now I have a req in which I need to update the owner of the lead record after sharing it through S2S. I tried running before update trigger but somehow it is not working. The trigger itself is not running once I click on 'Forward to Connections' button.

Why is the trigger not running.?


Given below is my code.


trigger LeadOwnerUpdate on Lead (before update)
    List<PartnerNetworkRecordConnection> recordConns = new List<PartnerNetworkRecordConnection>();
    List<Group> queue = new List<Group>([select Name,Id from Group g where Name = 'abc' limit 1]);
    for(Lead sendRecord : Trigger.new)
        recordConns = [select Id, Status, ConnectionId, LocalRecordId from PartnerNetworkRecordConnection where LocalRecordId =:sendRecord.id];
        System.debug('recordConns '+recordConns);
        for(PartnerNetworkRecordConnection recordConn : recordConns)
             if(recordConn.Status.equalsignorecase('Sent') || recordConn.Status.equalsignorecase('Pending (Sent)') || recordConn.Status.equalsignorecase('Active (Sent)') && sendRecord.Lead_Sub_Source__c != 'abcd')
                 system.debug('inside if clause');
                 sendRecord.ownerid = queue[0].id;    


Please help, I need to update the owner to a queue and I cannot override the 'Forward to Connections' button. Is there any way?



I have a button in Account Object which has a VF page as the content source. In the VF page I only have one action to call a function in the controller.

So on clicking the button, the function in the controller runs and a new custom object record edit page opens with some values as assigned by the controller.

The problem now is that these values are not getting preset when the record edit page shows up. I tried putting some debug statements in the controller and made sure the values are getting preset as expected. But somehow the values are getting changes when the record edit page opens. I am confused here, this functionality was working fine for over a year now and this problem popped up only last week.

I have checked the logs and looked for any possible triggers that is doing this changes. Strangely the values are getting preset and stays that way till the end of the controller fn execution in the first log and right in the beginning of the next log that is in the beginning of the trigger the values change. I cannot  find any other trigger/WF running since nothing is showing up in the log.

Am I missing something? Should I be looking for something more? Please help.