• Ramesh Peetha 4
  • -1 Points
  • Member since 2015

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 4
Hi guys,

I've been trying to use Lightning Open CTI to implement a softphone for Lightning Service Console. Click2dial-related functions work like a charm but screenPop() function keeps throwing this:

This page has an error. You might just need to refresh it. Action failed: c:TestCompo$controller$handleClick [Failed to execute 'postMessage' on 'Window': [object Object] could not be cloned.] Failing descriptor: {c:TestCompo$controller$handleClick}

I've created a Visualforce page and Call Center. The page contains Lightning components. Open CTI is included in page:
​<apex:includeScript value="/support/api/41.0/lightning/opencti_min.js"/>
Even a simple copy pasted code throws the error mentioned above:
    type: sforce.opencti.SCREENPOP_TYPE.SOBJECT,
    params: {
        recordId: '0012F0000089wQuQAI'
I've double checked that account with hardcoded ID exists in the system.

Any idea how to solve this?


I created an apex class that creates a task. Im wondering how I can change that to 'Log a Call'. The reason I want to do this is because in our feed view in cases there is a 'Log a Call' section and a 'Task and Activity' section. I want to populate the Log section rather than the Task section. 

-Julio Hernandez
Hi.  I am taknig a Salesforce Admin class and I'm trying to complete one of the exercises in my LEX development environment.  

-The sales path next and back button froze on step 2......the next and back button does nothing when you click on it

-When I refresh the page I loose all the data I entered and I have to start the new sales path all over from the beginning of step 1. The step 1 next button works but the step 2 next button still does not work.

-Tried clicking setup to start over by clicking on new sales path and everything works until you try to click next on Step 2. 

-Tried this in Safari and had the exact same problem in Chrome.

Have you run into this issue before? How can I fix this?
Hi all. I've been trying to complete the "Handle Actions With Controllers" Lightning Component trailhead for two days now. My code does exactly what the challenge requests, but when I click Check Challenge, I get the error "The campingListItem Lightning Component doesn't contain a button or its attributes are not set correctly when clicked." Is this trailhead buggy?

<aura:component >
    <aura:attribute name='item' type='Camping_Item__c' required='true' default="{'sobjectType': 'Camping_Item__c', 'Name':'Torch', 'Price__c': 10, 'Quantity__c': 1, 'Packed__c': false}"></aura:attribute>

    <ui:outputText value='{!v.item.Name}'></ui:outputText>
    <ui:outputCheckbox value="{!v.item.Packed__c}"></ui:outputCheckbox>
    <ui:outputCurrency value="{!v.item.Price__c}"></ui:outputCurrency>
    <ui:outputNumber value="{!v.item.Quantity__c}"></ui:outputNumber>
    <ui:button press="{!c.packItem}" disabled="false">Packed!</ui:button>

    packItem: function(component, event, helper) {
        component.set("v.item.Packed__c", true);
        event.getSource().set("v.disabled", true);