• Lawrence Coffin (P)
  • 15 Points
  • Member since 2017
  • Technical Architect
  • Accenture

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 4
I have a problem when I try to run the Encrypt.bat file in the data loader using the command prompt. I installed ava 8 Update 202 (64-bit), Java(TM) SE Development Kit 11.0.2 (64-bit). Zulu 11.29 (64-bit) then I installed Data Loader version 45.0.0.
As I want to use command line interface datta loader first i tried to run encrypt.bat. The following problem occurs:
c:\Program Files (x86)\salesforce.com\Data Loader\bin>encrypt.bat -g test
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/salesforce/dataloader/security/EncryptionUtil has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

I tried different versions of java jdk and jre but the result seems the same. Do you have some suggestions? 
thank you

I am currently going through the Lightning trailhead and I am building the expense app. When an expense is marked as reimbursed it's supposed to get a green background thanks to the .slds-theme--success class. However this style looks like it is being overridden by the .slds-card white background. Has anyone experienced this error? I could fix it by adding something like this to the component.
/*.slds-theme--success.THIS {
    background-color: rgb(4, 132, 75)!important;
But that honestly feels like cheating. Has anyone faced this issue. I've copied and pasted the code straight from Trailhead but it's not working as expected. Here is the component code and a screenshot illustrating the problem.
    <aura:handler name="init" value="{!this}" action="{!c.doInit}"/>
    <aura:attribute name="formatdate" type="Date"/>
    <aura:attribute name="expense" type="Expense__c"/>
    <lightning:card title="{!v.expense.Name}" iconName="standard:scan_card"
                    class="{!v.expense.Reimbursed__c ?
                           'slds-theme--success' : ''}">
        <aura:set attribute="footer">
            <p>Date: <lightning:formattedDateTime value="{!v.formatdate}"/></p>
            <p class="slds-text-title"><lightning:relativeDateTime value="{!v.formatdate}"/></p>
        <p class="slds-text-heading--medium slds-p-horizontal--small">
           Amount: <lightning:formattedNumber value="{!v.expense.Amount__c}" style="currency"/>
        <p class="slds-p-horizontal--small">
            Client: {!v.expense.Client__c}
            <lightning:input type="toggle"

User-added image

Thanks in advance!
Hey all,

I'm making some changes to my case feed page, so that the Custom Actions can appear in the Publisher. My custom actions are Visualforce pages that used to accept some values and update the record feed and refresh the page. I followed the documentation and used the interaction Javascript library function:
<apex:actionFunction name="emailSent" oncomplete="sforce.interaction.entityFeed.refreshObject('{!feedCase.id}','true','true','true')"/>
This javascript function refreshes the fields, related lists and feeds all in one go. However, it doesn't appear to work when the Custom Action is being invoked from the Publisher. Simply, nothing happens.

I have found this Javascript function from the Canvas Javascript library which seems to work, but doesn't do what I want it to:
<apex:actionFunction name="emailSent" oncomplete="Sfdc.canvas.publisher.publish({name : 'publisher.refresh', payload : {feed:true}});"/>
This function refreshes the feed, but not the fields or related lists. As a result, the highlights panel at the top of the page doesn't update, either, which my users look to as an indicator that the record has been updated. They shouldn't have to force a refresh of the page to check.

I can't find anything in the documentation that lists the elements I can put into the payload, so I'm not sure what the situation is:
  • The Initial Code sample should have continued to work in the Custom Action Publisher, keep debugging to find out why it didn't.
  • The Initial Code sample doesn't work in the Custom Action Publisher. However, the new code sample can be used to refresh more than the feed.
  • The initial Code sample doesn't work in the Custom Action Publish and the new code sample can only refresh the feed. Find another way to refresh the fields and related lists
Does anybody know?