• Shivankur Naikwade
  • -1 Points
  • Member since 2018

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 7
Not able to use Lightning Component in VF, below is my code

<aura:component implements="force:appHostable,flexipage:availableForAllPageTypes,flexipage:availableForRecordHome,force:hasRecordId,force:lightningQuickAction" access="global" >
	<lightning:button label="GoToRecord" title="Neutral action" onclick="{! c.handleClick }"/>
    handleClick : function(component, event, helper) {
        var navEvt = $A.get("e.force:navigateToSObject");
        navEvt .setParams({
            "recordId": "5006F00001w4IH7QAM",
            "slideDevName": "detail"
Created LightningOut Application as below
<aura:application extends="ltng:outApp" >
    <aura:dependency resource="markup://force:navigateToSObject" type="EVENT"/>
    <aura:dependency resource="c:ComponentForVisualForce"/>
Below is the VisualForce Which I am consuming it
<apex:page >
    <apex:includeLightning />   
    <div id="LcDisplayId"></div>     
    $Lightning.use("c:ApplicationForVisualForce", function() {
    { },
    function(component) { });

Madhusudan Singh

I'm getting the following error on Challenge 7 in the Lightning Experience Rollout Specialist Superbadge:


Challenge Not yet complete... here's what's wrong: 
The Account record page must include the required chart with the correct label. Confirm the Opportunities Pipeline report's unique name includes the word "pipeline".

I verified the following:

  1. Account LEX Page has a Tab labeled "Opps by Stage". That tab has a , even though it displays as "Opps By Stage" (see screenshot 1)
  2. My report's unique name was originally "Opportunities_Pipeline_Tt3". I know that upper/lower case sometimes gums up the badge completion validation checks, so I changed the API name to "Opportunities_pipeline_Tt3, since the error says the Report API name must contain the word 'pipeline' (lowercase). (see Screenshot 2)
What am I missing?

Screenshot 1: 
User-added image

Screenshot 2:
User-added image
I can hear the choirfolk chanting: Visualforce is so stale!  To which I say: Unless you want to actually print your work. (It would be amazing if lightning could print in a useful way.)

I'm working on a Visualforce page that will be included included in a lightning component that will also be used for a printed version of the VF page contents renderd as pdf.   

I've tried every permutation of <apex:slds />, lightningStylesheets="true", applyHtmlTag="false", applyBodyTag="false", renderAs="pdf", and renderAs="advanced_pdf".

I appears that any attempt to render visualforce that includes the SLDS CSS causes Salesforce to puke with "An internal server error has occurred."  I'm not the first to discover this behavior: https://developer.salesforce.com/forums#!/feedtype=SINGLE_QUESTION_SEARCH_RESULT&id=9060G000000Ub1lQAC

I haven't tried embedding the LDS CSS in a static resource because it appears this didn't work for others: https://github.com/salesforce-ux/design-system/issues/341

Does anyone have insight into the best practice to style a Visualforce page to match the SLDS for inclusion in a lightning component and printing?

Thank you,
Hello Experts,

I wanted to know if is it possible to have a custom button to show on record on Lightning list view (Please refer image)?
I searched enough but could not find any option.

I have created an custom action for clone functionality and wishing to have this custom action on list view record.
User-added image

I have problems with creating an own intent model. 
  1. I created a Dataset From a File Asynchronously and uploaded it via cURL. 
  2. I triggered the training with the corresponding cURL command. 
  3. When I query the status I get back this: java.lang.RuntimeException: PythonTrainer process failed to complete
JSON (some ids shortened)
    "datasetId": 1007xxx,
    "datasetVersionId": 4315,
    "name": "xxx Intent Model",
    "status": "FAILED",
    "progress": 0.01,
    "progress": 0.01,
    "createdAt": "2017-07-21T06:26:10.000+0000",
    "updatedAt": "2017-07-21T06:26:18.000+0000",
    "failureMsg": "java.lang.RuntimeException: PythonTrainer process failed to complete",
    "learningRate": 0.0,
    "epochs": 300,
    "object": "training",
    "modelId": "EPKBQ5CEHXE4ZD4T2XCS3Mxxxx",
    "trainParams": null,
    "trainStats": {
        "labels": 14,
        "examples": 26,
        "totalTime": null,
        "transforms": null,
        "trainingTime": null,
        "earlyStopping": true,
        "lastEpochDone": 0,
        "modelSaveTime": null,
        "testSplitSize": 5,
        "trainSplitSize": 21,
        "datasetLoadTime": "00:00:02:347",
        "preProcessStats": null,
        "postProcessStats": null
    "modelType": "text-intent"

What is wrong?
I have a <ul> tag in a component, when I try to reRender the component only is the data not getting updated but my <ul> tags are turning into block quote. I'm not sure what the issue is.. It loads normally, but once the component gets reRendered my <ul> tags turn into <blockquotes>.
<div class="slds-dropdown slds-dropdown--right slds-dropdown--small" role="listbox" style="position:absolute;max-width:200px">
    <ul class="slds-dropdown__list" role="presentation">
        <apex:repeat value="{!c.data}" var="f">
           <apex:outputPanel rendered="{!f.isChecked}">
              <li class="slds-dropdown__item slds-is-selected" role="presentation" onclick="selectItem(event)">
              <span class="slds-lookup__item-action slds-lookup__item-action--label" role="option">
              <span class="slds-truncate">{!f.data} </span>
                 <apex:outputPanel rendered="{!NOT(f.isChecked)}">
                  <li class="slds-dropdown__item" role="presentation" onclick="selectItem(event)">
                  <span class="slds-lookup__item-action slds-lookup__item-action--label" role="option">
                   <span class="slds-truncate">{!f.data}</span>