• Rick Roesler 7
  • 0 Points
  • Member since 2018

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 3
I opened up a new integration in Postman to try and test it, and ran into the following error:
<h1>Bad Message 400</h1>
<pre>reason: Bad HostPort</pre>
I received the same error when I went to an existing integration that had been working last I tested it, and across several environments. My guess would be this is an issue with Postman not using a supported encryption protocol since SSL and TLS 1.0 are now disabled, but could anyone confirm this, or suggest a way to test if it is the issue?
I Use the Metadata API to read, analyze, edit and create/update reports.

I noticed that the field names (when specifying columns, filters, and groupings) which are returned when reading are not always the same names, and seem to depend upon Report Type.

Suppose I create a simple report on accounts, and I only return two columns, Account owner and Account Name.
1. If I chose standard system-generated "Accounts" report types when creating this report, then upon reading it in the metadata API the column names are

2. If I chose custom report type which I created manually, then the column names are (These seem to be the API names)
Account.Name, Account.Owner.Name

3. If I choose a system-generated report type where account is not the main object, for example "Activities with Account" I get the following column names:

This happens with other (not custom) columns as well. Maybe there are even more possible column names for the same column in different report types, I don't know...

How to know when to use which names? Also, Is there a way I read the other (besides API, option 2) column names programmatically? Can't find these names in the describe when using Partner or REST API.

I'm wondering if anyone can tell me why I can't connect to http://localhost from Salesforce to a local rest interface. I've added "http://localhost" as a remote site but I still get an error when connectiong that says the connection failed. The localhost rest uri does work if I use Fiddler or via browser so why doesn't it work from Salesforce?