• Jake Wilson 3
  • 10 Points
  • Member since 2018

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 0
When I created my account on Trailhead, I clicked the Google sign in OAuth button to create my account. I'm going through a lot of modules. I got to a module where I need to learn how to install AppExchange apps in my Sandbox. When I attemp to install any apps, it asks me to authenticate and requires me to provide my login/password for my sandbox.

According to my sandbox my username is <myname>@<sandbox-name>.com

But I do not have a password. Since I signed up for an account using Google login, I was never asked to enter a password anywhere. So therefore I cannot login to authenticate to install any AppExchange apps.

I tried going into the sandbox into my user settings to change my password, but it requires me to type in my old password in order to change my password to something new. But since I never had a password to begin with, I can't do it!

I also tried creating a Salesforce login (complete with username and password). Then I went into the Trailhead settings and merged my two accounts together. This worked. However when I get to the sandbox authentication screen it doesn't appear to accept my Salesforce login for the sandbox. It only appears to want to accept my sandbox username and again, since I don't have a password and can't set one, I can't login.

Help. What do I do here?