• Yamini Machha
  • 0 Points
  • Member since 2021

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 9
Trying to configure permission sets and I cannot get any of them correct. Ada does not have a drop down option for Chatter. I have four options for each person: Force.com APP, Force.com free, Partner App, Salesforce Platform and Work.com. I have tried all of them. I have researched online and everyone seems to have a different view and options than I have. Ulrich the marketing Box is greyed out so I cannot check it and stays grayed out with each permission set I select. I am tried Lightening and Classic, same results. PLEASE HELP!
I am working on thge Challenge 3 and I am getting following error message
"Challenge Not yet complete... here's what's wrong: 
Couldn't find a correctly configured grouping of account types called 'Market' in the 'Accounts by Market' report."

Here are the Requirements: Accounts by Market
First, Gabriela needs a breakdown of the account industry distribution between the utility accounts and the newly imported residential accounts. Create a matrix report (called Accounts by Market) that summarizes account types as rows (called Market) and account ratings as columns. Gabriela wants you to use the following account types (with all other types categorized as "Other"):
Include accounts of types Customer - Direct and Customer - Channel
Include accounts of type Residential
Gabriela also wants a record count for each account type and account rating. Don’t show details.
Here are the Reports:
User-added image

User-added image
Hello! I am struggling with the following error:

Challenge Not yet complete... here's what's wrong:
Couldn't find a correctly configured grouping of account types called 'Market' in the 'Accounts by Market' report.

I have triple checked the requirements and specifics for this report creation. Report below. I cannot understand what the issue is. Any advice would be much appreciated!

User-added image

I am not able to create the user settings for Lincoln Ulrich properly.
When I create a new user for him and try to choose a profile, I can not see the Standard User Profile. I clicked through all the licences, however there is no Standard User Profile available.
The marketing button is also not editable to me.

Thanks in advance!
I'm currently working on Challenge 3 and am dealing with trying to fix this error:
Challenge Not yet complete... here's what's wrong: 
The report 'Open Support Cases' contains records of the incorrect status. Please check the filter.
For the Open Support Cases, I created a Custom Report Type linking Accounts and Cases and have the groupings and fields set up as specified. For the filter, I've tried "Closed equals False" and "Status not equal to Closed" for the Cases, but neither of those worked.

If anyone who has passed this challenge can provide input on what's wrong with this report. It'll be much appreciated.

Open Support Cases Report Screenshot
Challenge Description:
  • Upload a specified zip file as a static resource. The zip will have directories with images and you have to display a specific image on a Visualforce page.The page must be named 'ShowImage'.
  • This file must be uploaded as a Static Resource named 'vfimagetest'.
  • The page must have a Visualforce apex:image tag that displays the 'kitten1.jpg' image from the 'cats' directory of the static resource.

Screenshot of Visualforce Page:
User-added image
Screenshot of Resource Page:
User-added image

Screenshot of page preview:
User-added image

Exact text of error:
Challenge not yet complete... here's what's wrong: 
The page does not include a reference to the specified image

Can't figure out whats wrong, everything looks like its working perfectly and I used the examples in the module as a base for the code.

Project custom object records should only be seen by the owner of the record and users above the owner on the role hierarchy. However, for some Project records, the Training Coordinator must also have Read Only visibility to the Project record.

Create a custom picklist field on the Project object called “Priority” with the following values: High, Medium, and Low. Then create a criteria-based Sharing Rule for Project records where the Priority = High to share those records with the Training Coordinator role.
Create an Apex class that returns an array (or list) of strings: 
Create an Apex class that returns an array (or list) of formatted strings ('Test 0', 'Test 1', ...). The length of the array is determined by an integer parameter.The Apex class must be called 'StringArrayTest' and be in the public scope.
The Apex class must have a public static method called 'generateStringArray'.
The 'generateStringArray' method must return an array (or list) of strings. Each string must have a value in the format 'Test n' where n is the index of the current string in the array. The number of returned strings is specified by the integer parameter to the 'generateStringArray' method.

MyApexClass to above Challenge:

public class StringArrayTest {
    public static List<string> generateStringArray(Integer n)
        List<String> myArray = new List<String>();
        for(Integer i=0;i<n;i++)
        return myArray;

It's compile and execute as per requirement in Developer console. But Traihead showing the below error:

Challenge not yet complete... here's what's wrong: 
Executing the 'generateStringArray' method failed. Either the method does not exist, is not static, or does not return the proper number of strings.

Anyhelp would be greatly appreciated. Thanks.

On the Account object I have created a formula field called Domain_Name__c . The formula I have used is this,


SUBSTITUTE(Website, LEFT(Website, FIND("www.", Website)), NULL)


Where website is a standard field on Account.


If Website is www.xyzdomain.com or https://www.xyzdomain.com


In Domain_Name__c I expected result as xyzdomain.com


Instead i am getting the result either as

.xyzdomain.com or ww.xyzdomain.com depending on whether the Email entered was 'www.xyzdomain.com' or 'https://www.xyzdomain.com'

Any thoughts how I can only get the text after the .   


e.g If, in the field Website  I enter www.salesforce.com  or  https://www.salesforce.com the result in the Domain_Name__c should be salesforce.com