• Mysti, Developer Documentation
  • 4 Points
  • Member since 2005
  • Principle Technical Writer
  • Salesforce

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 22

A customer question I can't answer. Can anyone help?


I'd like to prepopulate some fields when we create new cases. I've come across a few ways to do that for simple standard fields and for custom fields, but one of the fields that I want to work with is a Long Text Area, and those seem to be more difficult. Is there a recommended way to prepopulate a Long Text Area field? Is it possible to do it by pulling in the text from an object somewhere, such as the contents of a Content record, or perhaps a static resource?





The "Getting Started" code examples show how to INSERT and UPDATE individual records using the new REST API.


In my own testing, this seems to take about 100 msec per REST API call.


If I need to INSERT or UPDATE 1,000 records, and I do then one-by-one, that's going to take a long time.


Can anyone point to some documentation or example code, that shows how to many records with a single REST API call?


thanks in advance,

  David Jones, PhD





Its not in the AppExchange.

  • October 27, 2010
  • Like
  • 0

While the API docs have a lot of great examples using cURL, I don't see an example of how to actually obtain the access token. I tried the following with no joy:



curl grant_type=authorization_code \
  client_id=MY-CONSUMER-KEY \
  client_secret=MY-CONSUMER-SECRET \





Jeff Douglas

Appirio, Inc.



Author: The Salesforce Handbook



I have multiple orgs, and am not sure which one I signed up with for the webinar.


In any case, how do I verify if my ORG is REST enabled ?



Salesforce has some great articles at developer.force.com and the Force.com community has chipped in with some excellent content but there is still something missing.  There’s a beginning book for Salesforce users (Salesforce.com for Dummies) and an advanced Force.com development book (Development with the Force.com Platform) but there is no comprehensive guide for analysts and developers just coming on to the platform. This is the niche that Wes and I want to fill with our new book:

The Salesforce Handbook
A newcomer’s guide to building applications on Salesforce.com and the Force.com Platform

We are targeting this book for business owners, analysts and developers  just getting started. Just think of all the new Vmforce Java developers that will be investigating the Force.com platform in the coming months! So if your boss walks into your office and says, “Let’s look at this Salesforce.com thing and see if we can build something”. We want this to be a reference that you can pick up and essentially find out everything you need to know about Salesforce from a high level with links to other articles, sample code, blogs, Salesforce docs, etc. that interest you.

I query data which sometimes exceeds 2000 and that happens I receive an error message from the API stating error message = 2000

Is there a limiter that does not allow me to work with more 2000 records and how can I workaround this?

thank you.

  • December 29, 2009
  • Like
  • 0
I've identified a handful of problems in the documentation for the results of describeSObjects.
  1. The "writeRequiresMasterRead" attribute is listed in the documentation for 14 as part of DescribeSObjectResult, but according to the 14 partner WSDL, it's part of Field.
  2. "relationshipOrder" has the same issue as "writeRequiresMasterRead": it's documented as part of DescribeSObjectResult but the WSDL says it's in Field.
  3. "calculatedFormula" is in the WSDL definition of Field, but not documented.
  4. "externalId" is in the WSDL definition of Field, but not documented.

  • December 20, 2008
  • Like
  • 0
Sharing Rule Limit Exceeded 
Your organization has exceeded the maximum number of sharing rules allowed of this type. Please contact your administrator for more information. 

Can someone please point me to the Help Section where this limit is mentioned? Why can't I create more than 100 sharing rules on an object??? There's nothing in the app Setup limits page...nothing. It's obstructing the current project I am doing, so hope somebody of SF can help me work around this 1!
When using the Sales Force time shortcuts like "THIS_WEEK" and "LAST_WEEK", what day does a week end on?
I am essentially trying to replicate an Opportunity with Products report using one SOQL query. I pulled this query from the API documentation, page 339
http://www.salesforce.com/us/developer/docs/api/index.htm (PDF).

SELECT Amount, Id, Name, (SELECT Quantity, ListPrice,
PriceBookEntry.UnitPrice, PricebookEntry.Name,
PricebookEntry.product2.Family FROM OpportunityLineItems)
FROM Opportunity

To test it out I pasted it in the Data Loader but recieve an "Error in query: Malformed query string".

Any ideas? Much thanks.
  • November 01, 2007
  • Like
  • 0
I'm working on an S-control for updating multiple attributes on one or more cases at a time.  The particular problem I'm having is that while I can successfully change the Department_Assigned__c custom field, the assignment rules specified for cases don't seem to be getting applied, and case owner is remaining unchanged.  If I understand the 9.0 Ajax documentation, I should be able to use something like the following:

        sforce.connection.useDefaultRule = "true";
        sforce.connection.update(recordsToUpdate, callback);

If I manually edit a case and change the Department_Assigned__c custom field, the case owner changes correctly.  I've also tried using sforce.connection.assignmentRuleID = "the_assignment_rule_id", but still no luck.  Any tips would be greatly appreciated.
PLEASE ONLY ONE PERSON HELP ME WITH THIS AT A TIME (unless you don't care about the $25!). I realize I am way over my head with this, but I would really like to see this in action. Again, only one person help at a time, as I only have one $25 Paypal payment to give out! This is where I am at:

1) Installed JDK 1.42
2) Installed Tomcat 4.1 (not sure if this is needed) - verified running on port 8080
3) Installed Apache Axis 1.4 (copied webapp/axis over to Tomcat - again not sure if required)
4) Downloaded Enterprise WSDL from Salesforce and saved to desktop
5) Installed Ant

NOW, I just need to run Java2WSDL and I am STUCK! I realize I probably have to compile this and I am completely lost what to do. I'm not sure if the Enterprise WSDL import is related to this step, but I need help with this too.

Thanks in advance, once I get this running, I will immediately paypal you $25! -Charles

Some questions related to the new 8.0 API. (And thanks for an excellent pre-release!)

1. Does the sforce explorer (using DescribeSObjects, etc) return all the correct metadata for the org when configured to use the 8.0 SOAP endpoint? (https://prerelna1.pre.salesforce.com/services/Soap/u/8.0)

2. If so, then why does it indicate that the ProcessInstance is query-able and retrieve-able, whereas the API Docs indicate that they are more accessible (create, delete, query, retrieve, update, upsert)?

Granted, I could write a quick test to try it and find out, but I thought it would be useful to point out the discrepancy just in case.

Thanks again for some incredibly useful new features. Only problem is that we just spent a few weeks working around limitations in 7.0 that have almost all been resolved with 8.0! :-)
  • January 05, 2007
  • Like
  • 0