• Jester
  • 5 Points
  • Member since 2006

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 16

When I try to perform DML (a simple update) in my controller constructor I get an error.  Why is this not allowed?  Is there any way to perform such an update? 

I am aware of the action parameter in the page tag.  That is not sufficient for me as I am working under an interesting constraint, which unfortunately means no javascript.  (Or at least the type that calls back to the controller).

Since a carriage return signifies the end of a record in a csv file, how do you insert a carriage return as data in a field using the Data Loader?  A good example is the Shipping and Billing Street fields in Accounts which allow carriage returns in Salesforce.
PLEASE ONLY ONE PERSON HELP ME WITH THIS AT A TIME (unless you don't care about the $25!). I realize I am way over my head with this, but I would really like to see this in action. Again, only one person help at a time, as I only have one $25 Paypal payment to give out! This is where I am at:

1) Installed JDK 1.42
2) Installed Tomcat 4.1 (not sure if this is needed) - verified running on port 8080
3) Installed Apache Axis 1.4 (copied webapp/axis over to Tomcat - again not sure if required)
4) Downloaded Enterprise WSDL from Salesforce and saved to desktop
5) Installed Ant

NOW, I just need to run Java2WSDL and I am STUCK! I realize I probably have to compile this and I am completely lost what to do. I'm not sure if the Enterprise WSDL import is related to this step, but I need help with this too.

Thanks in advance, once I get this running, I will immediately paypal you $25! -Charles

Hello all,
We just went live with salesforce and I will be administering the application. We already have requirements for functionality that I believe will require scontrols. Which means I need to quickly learn javascript! Can anyone provide advice on training programs or other resources that I can use?
Hi, I am recieving a " FIELD_INTEGRITY_EXCEPTION CONTACT\LEAD ID: id of incorrect type 0053*********fmAAA" exception when trying to create a task for the person logged in.  I am passing a 18 digit character/number string of the person logged in.
Here's the code:
//create activity on account to record update
var newActivity = new Sforce.Dynabean("Task");
newActivity.set("Subject", "message " + variable);
newActivity.set("WhoId", accId);
newActivity.set("Status", "Completed");
newActivity.set("Priority", "Normal");
newActivity.set("Description", variable);
var today = new Date();
newActivity.set("ActivityDate", today);
// no brackets!! hasnt worked
var saveResult = sforceClient.Create(newActivity)[0];
// no brackets no [0] hasnt worked 
var saveResult = sforceClient.Create(newActivity);
// original code not working
var saveResult = sforceClient.Create([newActivity])[0];
I would really apreciate if someone could help, thanks!!  Anita
We have been usung salesforce for about a month and I keep having troubles with the email-to-case.  It seems that it hits a cap of 70MB of memory usage and then dies.  If there is multiple messages..say over 10-15 it will fail.  I also just found out today that attachments will also cause it to fail.  I have had to restart the service 4 times in the last 5 days :( 
The server I have this running on has a gig of ram.  It does not seem to struggling but when the email-to-case agent hits its 70MB, it dies.
Anyone have any ideas?
Thanks :)
I've been searching the forums for creating objects in batches of 200 but I can't find any examples (C#). the sample code to download doesn't have an example of batch creation. To create opportunities for example, I do this:
sforce.Opportunity newOp = new sforce.Opportunity();

// populate newOp

newOp.AccountId = acct_id;

newOp.StageName = "ClosedWon"

newOp.Name = "John";

sforce.sObject[] records = new sforce.sObject[] {newOp};

sforce.SaveResult[] saveResults = binding.create(records);

this is OK if I need to create a few, but if I need to create thousands of them, it is not OK. I know this is simple question, but I can't find the answer.. I'd like to follow the best practices..

thank you!


I'm just getting started and I am having a problem using the basicSample_cs_p sample code.

I am using .NET, Visual Studios and a Sforce developer account. I generated a partner WSDL file and added this as a web reference to my VStudio project.

The code compiles and runs without error. However the following statement
  loginResult = binding.login(username, password);

generates an exception with the following error message
  "The underlying connection was closed: Unable to connect to the remote server"

I have tried my developer account username and password. I also tried my "team" account username and password. All producing the same error message.

I think the problem is (and everything I have read indicates) that I need at least an Enterprise level account to use the SForce WebServices API and the team account (or a developer account generated from a team account) just isn't good enough.

Additionally ...

The source code had a few different references to the address location for the web service

SforceService. For example:

I assume that I should be using the 6.0 version since the code and .NET use the 6.0 version of the AppExchange API. Still, just to be thorough, I tried different trials with each of these addresses with the exact same result and error message.

Any help or suggestions would be appreciated.

Any thoughts on how to create a PDF page from an scontrol.  The best option I've seen so far is manual - create HTML, save (IE only), and use an online service that generates the PDF.  Checking to see if there is another way...
  • April 17, 2006
  • Like
  • 0
The requirements for AppExchange registration include: "Uses a unique client ID for all service calls", but I can't find any mention of this in the API documentation. How do I supply a client ID? (I'm using PHP and the older PHP toolkit that uses v2.5 of the SOAP API.)


Message Edited by cwood on 04-10-2006 01:51 PM

  • April 10, 2006
  • Like
  • 0
My app uses the SOAP API and I want to create links back to the Salesforce.com application. I understand that I need to get the server name for the link target from the serverUrl field in th LoginResult, but that field contains (for me anyway) "na1-api.salesforce.com". Shouldn't I be building links to na1, not na1-api?

If I use the hostname from the LoginResult, I build a link that looks like https://na1-api.salesforce.com/00Q30000006xrFvEAI, which forces me to (re-)authenticate even if my browser has an active session. (If I pase that link back in the address bar, I'm forced to re-authenticate again.)

If I instead use "na1.salesforce.com", I'm not forced to re-authenticate, which is the desired behavior.

Can I get the hostname from LoginResult and strip "-api" from it? Will this work with EMEA and AP?


Message Edited by cwood on 04-10-2006 01:38 PM

  • April 10, 2006
  • Like
  • 0
As of today, what is the oldest supported Sforce SOAP API version?

Is there any chance that v2 is still supported?
I am currently using a custom external id field in order to upsert external data into Salesforce from my AppExchange application.  Unfortunately, since my application is a partner app, there is no guarantee that the one external id field isn't already being used by a given company.  So either I take the chance that it isn't being used, or I roll my own upsert with creates and updates, which requires more requests and is slower.

I'm guessing that from within the Salesforce database, an external id field has an associated database index (and the resulting tablespace), so perhaps the rationale of having only one external id is to limit the tablespace.  This would be a shame, because the overhead of the additional requests is a drag for both Salesforce and its partners.

Any chance this will be changed in the future?

Are the auto-response rules associated with the lead object visible via the API?  If so, what object are they stored in?

Hi there,
Can  you please  help me in finding  "AppExchange Data Loader" related documentation?
  • April 03, 2006
  • Like
  • 0
I have developed an adapter for a third-party indexing engine that uses the sforce soap service as one of its data sources.  When I test the adapter outside of the indexing engine environement, as a standalone java app, I get all of my data.  However, when the indexing engine executes the adapter, I receive only the first set of data (1000 records).  When the source requests the second recordset, I receive an "INVALID_QUERY_LOCATOR" fault.  Anybody have any idea why?  Originally, the binding timeout was set to 0.  I have modified it to 300000, with no success.  Also, the adapter continues to function after that, querying the salesforce soap service for several other data types successfully.  I query for Accounts, which is where it fails, then Campaigns, Contacts, Events and Opportunities.  I modified the order of querying, and it failed when accessing the Contacts.  There are 43500 Account records.  There are 116,000+ Contact records.  Any help would be appreciated.