• M. J. Kahn
  • 0 Points
  • Member since 2008

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 0
Is there any way in Apex to determine whether the current user has write access to a record?
I know I could try to update the record and if an exception is thrown, I'd know that the current user doesn't have write access to the record, but if an exception isn't thrown, then I'll have updated the record, changing its Modified Date, and I'd rather not do that.
There's a similar question ("Determine whether a user has edit rights through API" - http://community.salesforce.com/sforce/board/message?board.id=apex&message.id=2280&query.id=43418) dated January 2008. The response says, "We're looking into adding this capability," and I'm wondering whether it has been added.

I'm using the "Force.com for Google Maps and Earth" code share project pretty much verbatim. (I'd post the code here, but it would just be a copy of what's in the code share project.) The project includes a trigger on the Account object so that whenever an Account's billing address changes, geocoding information is computed and stored in the Account. This worked just fine yesterday, but today, when I change an Account's billing address, the Google Maps API returns a G_GEO_TOO_MANY_QUERIES error.

According to the Google Maps API documentation, "Requests made in excess of your daily and instantaneous throughput limits may return a 620 (G_GEO_TOO_MANY_QUERIES)." I've tried this in two different developer orgs (which happen to be on two different Salesforce instances), and I get the same error in both places. I'm only updating one Account at a time, using the standard UI, so it seems unlikely that I'm personally exceeding some limit.

What determines whether you've gone over the daily limit? If other Salesforce orgs are on the same instance as me (and thereforce issue requests from the same URL and use the same API key), do their requests contribute to a single daily limit?

Is there anything I can do to reset this error, or do I have to wait a day for it to clear on its own?