• Aviator_07
  • 5 Points
  • Member since 2012

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 4
  • 10



I am trying to capture the account id from the url on clicking the new event button with the following statement:


String str;


str = ApexPages.CurrentPage().getParameters().get('what_id');


but the id isnt getting captured. Any idea why this is happening?







I am trying to set the Opportunity access via the OpportunityShare object. I  have set the OpportunityAccessLevel to 'None' for one of the members in the team.

I get the error:

INVALID_OR_NULL_FOR_RESTRICTED_PICKLIST, Opportunity Access: bad value for restricted picklist field: None: [OpportunityAccessLevel]


Is it not possible to set the access level to 'None' at all??


Can someone tell me how to Delete data from Oracle table using Data loader command line interface? Is it possible?


I found the Sample code for deletion in Apex Data loader Database.xml sample file but I do not know how it is supposed to be called in the Process.conf File and what parameters need to be set.


<bean id="deleteAccountAll"
    <property name="sqlConfig" ref="deleteAccountAllSql"/>
    <property name="dataSource" ref="dbDataSource"/>

<bean id="deleteAccountAllSql"
      class="com.salesforce.dataloader.dao.database.SqlConfig" singleton="true">
    <property name="sqlString">
            DELETE FROM TableOwner.Accounts


Is it not possible to change the Start and End Date/time fields on Events? I used a before insert trigger to set the values of start and end date to a prior date (and future date too) but the values dont seem to change. The trigger is working fine and the updated values are visible in the system log but when I check the event record on the UI the start and end date/time is set to today's date.

I am creating a chart in my visualforce page using morris chart API. The whole page is loadng perfectly including the Chart container but still now able to load the chart. It throws me the following error : 

Graph container not found

From the Github page of Morris, I had got the solution for this error. They've mentioned that one has to include the javascript after the divs. But I have alredy done that. I have included all of my javascripts at the bottom of the page and still getting this error. 

I'd really appreciate some help!


Here's my div for the chart:


<section id="main-content">
        <section class="wrapper">
        <!-- page start-->
            <div class="row">
                <div class="col-sm-12">
                    <section class="panel">
                        <header class="panel-heading">
                            Customize Graph
                        <span class="tools pull-right">
                            <a href="javascript:;" class="fa fa-chevron-down"></a>
                            <a href="javascript:;" class="fa fa-cog"></a>
                            <a href="javascript:;" class="fa fa-times"></a>
                        <div class="panel-body">
                            <div id="graph-area"></div>

And I have included the scripts like this : 
<!--Morris Chart -->

<apex:includeScript value="{!URLFOR($Resource.mythemejs, 'js/morris-chart/morris.js')}"/>
<apex:includeScript value="{!URLFOR($Resource.mythemejs, 'js/morris-chart/raphael-min.js')}"/>
<apex:includeScript value="{!URLFOR($Resource.mythemejs, 'js/morris.init.js')}"/>
 I don't understand why this won't work! 



I am trying to assign a Region value to an Account based on the Shipping Address of the Account. My Case function (sample below) works when it does not go over the 3900 character limit:


"Afghanistan", "EMEA",
"Åland Islands", "EMEA",
"Albania", "EMEA",
"Algeria", "EMEA",
"American Samoa", "APAC",


However, with over 300 different countries, the complete function is over 8000 characters and will not save. How would I optimize this formula to work for all 300 different countries and keep the same functionality?


Please respond with specific formulas to help.





I am trying to capture the account id from the url on clicking the new event button with the following statement:


String str;


str = ApexPages.CurrentPage().getParameters().get('what_id');


but the id isnt getting captured. Any idea why this is happening?




Hello friends,


I was searching for the provision to pass the dynamic parameter in file "process-conf.xml".

For example - Log file locations, Export data file etc.


I am planning to take the complete salesforce data backup wickly with the help of DataLoader and path should automatically change like "Date Name". Every export files should go in different folder organized by date name.




I get the following error during plugin installation. I have ensured Eclipse is not under program files. I tried runninf eclispe as administrator.

Can someone tell me exactly what and how does one configure on windows 7 UAC to ensure this problem goes.



I did try to add my login user to administrator group. I also gave all authenticated users modify permissions in eclipse folder




cannot complete the install because of a conflicting dependency.
  Software being installed: Force.com IDE (com.salesforce.ide.feature.feature.group
  Software currently installed: Eclipse IDE for Java Developers (epp.package.java
  Only one of the following can be installed at once:
    International Components for Unicode for Java (ICU4J) 4.4.2.v20110208 (com.ibm.icu 4.4.2.v20110208)
    International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
  Only one of the following can be installed at once:
    Structured Source Editor 1.1.102.v200910200227 (org.eclipse.wst.sse.ui 1.1.102.v200910200227)
    Structured Source Editor 1.3.0.v201105101529 (org.eclipse.wst.sse.ui 1.3.0.v201105101529)
  Cannot satisfy dependency:
    From: Force.com IDE (com.salesforce.ide.feature.feature.group
    To: org.eclipse.wst.html.ui [1.0.0,2.0.0)
  Cannot satisfy dependency:
    From: Eclipse IDE for Java Developers (epp.package.java
    To: org.eclipse.epp.package.java.feature.feature.group []
  Cannot satisfy dependency:
    From: EPP Java Package (org.eclipse.epp.package.java.feature.feature.group
    To: org.eclipse.rcp.feature.group 3.7.0


I have an event standart edit page and event view page in VF. Nowe when I create a new event and try to redirect after save I use this method:

  public PageReference redirect()
        String recordType = ApexPages.currentPage().getParameters().get('RecordType');
        String what_id = ApexPages.currentPage().getParameters().get('what_id');
        String who_id = ApexPages.currentPage().getParameters().get('who_id');
     String eventId=ApexPages.currentPage().getParameters().get('id');
     System.debug('event id>>>'+eventId);
     if (eventId==null)
     eventId = eventId.replace('newid', 'id');
        if(what_id == null)
            what_id = '';
        if (who_id == null)
            who_id = '';
           String str;
    //Changed on Sept 20/2011 redirecting to the parent object

            str='/00U/e?retURL=%2Fhome%2Fhome.jsp&saveURL=/apex/eventview?'+eventId+'&cancelURL=%2Fhome%2Fhome.jsp&ent=Event&nooverride=1&RecordType='+recordType+'&00N20000001kXCH='+replaceStr(userData.Business_Group__c)+'&00N20000001kXCL='+replaceStr(userData.Business_Unit__c)+'&00N20000001kXCR='+replaceStr(userData.User_Subdivision__c)+'&00N20000001kXCQ='+replaceStr(userData.User_Division__c)+'&what_id='+ what_id+'&who_id='+ who_id;
            //str= str.replace('newid','id');
            // str='/00U/e?retURL='+ ApexPages.currentPage().getParameters().get('what_id')+'&cancelURL=%2Fhome%2Fhome.jsp&ent=Event&nooverride=1&RecordType='+recordType+'&00N20000001kXCH='+replaceStr(userData.Business_Group__c)+'&00N20000001kXCL='+replaceStr(userData.Business_Unit__c)+'&00N20000001kXCR='+replaceStr(userData.User_Subdivision__c)+'&00N20000001kXCQ='+replaceStr(userData.User_Division__c)+'&what_id='+ what_id+'&who_id='+ who_id;


now when I save my event I get the following url



how come the key "newid " instead of Id how can I replace this world with "id"

I tried to use the replace string but irt doesn't work either.

Your help is very much appreciated!


I am using the latest version of the Force.com IDE 64-bit for Windows.  Every time I attempt to edit a page the application locks and will not respond.  Here is a dump of the log file.  This is a vanilla install straight from Force.com.


!ENTRY com.salesforce.ide.core 0 0 2010-06-16 08:00:39.807!MESSAGE DEBUG [2010-06-16 08:00:39,807] (ComponentFactory.java:getCompositeComponentFromFile:1037) - Loaded ApexPage 'pages/StoreFront.page' [unpackaged] from file 'StoreFront.page'

!ENTRY com.salesforce.ide.core 0 0 2010-06-16 08:00:39.808!MESSAGE DEBUG [2010-06-16 08:00:39,808] (BaseComponentMultiPageEditorPart.java:setInput:118) - Set metadata editor input from source file 'StoreFront.page-meta.xml'

!ENTRY com.salesforce.ide.core 0 0 2010-06-16 08:00:39.809!MESSAGE DEBUG [2010-06-16 08:00:39,808] (BaseComponentMultiPageEditorPart.java:setInput:139) - Opening ApexPage 'pages/StoreFront.page' [unpackaged] from file 'StoreFront.page'

!ENTRY org.eclipse.wst.validation 4 0 2010-06-16 08:00:47.603!MESSAGE IWAE0017E Cannot create validator org.eclipse.wst.common.componentcore.internal.ModuleCoreValidator because a Throwable was caught.
!ENTRY org.eclipse.wst.validation 4 0 2010-06-16 08:00:47.603!MESSAGE Plug-in org.eclipse.wst.common.modulecore was unable to load class org.eclipse.wst.common.componentcore.internal.ModuleCoreValidator.
!ENTRY org.eclipse.ui 4 0 2010-06-16 08:00:48.308!MESSAGE Unhandled event loop exception
!ENTRY org.eclipse.core.jobs 4 2 2010-06-16 08:00:49.371!MESSAGE An internal error occurred during: "Processing Dirty Regions".


I'm trying to write a simple trigger that renames a record. I keep getting the error "CallLineItemRename: execution of BeforeInsert caused by: System.SObjectException: DML statment cannot operate on trigger.new or trigger.old: Trigger.CallLineItemRename: line 18, column 9" . What am I missing here?




trigger CallLineItemRename on Call_Line_Item__c (before insert, before update) { // this triger renames the call line item id to be // the specified inventory item name or the product name List<Call_Line_Item__c> callItems = new List<Call_Line_Item__c>(); callItems = Trigger.new; for (Call_Line_Item__c callItem : callItems) { //check if inventory or product was specified if (callItem.Inventory_Item__c <> NULL) { callItem.Name = callItem.Inventory_Item__r.Name; callItem.Name = 'inv item name'; } else if (callItem.Products__c <> NULL) { callItem.Name = callItem.Products__r.Name; } } update callItems; }