• morgan.ma
  • 0 Points
  • Member since 2012

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 2

Hi, everyone


I need your help to understand and fix this problem:

I built an apex text class in a sandbox environment (i'm using eclipse) but when I run this apex test class I'm getting this error: System.QueryException: List has no rows for assignment to SObject. The problem is that the object really has records both in sandbox and in production environment !!!! I run that query in Force.com Explorer, salesforce.shema Explorer, etc. and there I can see the existing records but in the test all the time throws that error... Could anyone please guide me why is it happening and how can it be fixed?

Hi All,


We have a requirement to display user confirmation pop up  on-click of std ‘Save’ button on opportunity page layout.

We have achieved it through JS on home page component. It works neatly for the normal edit page but does not work well on the inline edit page.

The problem is that although the pop up message gets displayed, the "SAVE' thereafter does not happen. Appreciate any help on this.

Below is the code snippet for inline edit page:


function overrideTheSavebtn(){

var URL = document.location.href;

if(URL.indexOf('006') > 0){

var probab = document.getElementById('opp12');

if( probab.value!='90')


document.getElementsByName('inlineEditSave')[0].onclick = function(){

var choice = confirm('All orders will be deleted if you change the probability to less than 90. Do you want to continue?'); return choice;};}


/* add a method onload */

var oldonload = window.onload;

if (typeof window.onload != 'function') {

window.onload = oldonload; }

else { window.onload = function() {

if (oldonload) { oldonload();}