function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Scott Allison 18Scott Allison 18 

Activate Session-Based Permission Sets Without Code Trailhead issue

I'm stuck on this trailhead. "Activate Session-Based Permission Sets Without Code"

I believe I did everything correctly.  I get "Challenge Not yet complete... here's what's wrong: 
Permission Set 'Temporary Account Edit' is not referenced in the flow 'Accounts Temp Access'. Check the instructions"

I can run the flow successfully, and I can confirm via setup audit trail that the permission set activation occured.
Best Answer chosen by Scott Allison 18
Scott Allison 18Scott Allison 18
Figured it out.  I used a "variable" instead of a "constant" in the flow.  Even though my flow works, and had all the correct information, the challenge test is looking for a "constant".  Changed it, and the challenge passed.

All Answers

Scott Allison 18Scott Allison 18
Permission set Temporary Account Edit: activated for the session....
Also permission set API name: Temporary_Account_Edit
Flow: Accounts Temp Access
Unique Name: Accounts_Temp_Access
Activation flow action: Activate Session-Based Permission Set
Input Permission Set Name set to variable TemporaryAccountEdit
Default Value: Temporary_Account_Edit

What am I missing?
Scott Allison 18Scott Allison 18
Figured it out.  I used a "variable" instead of a "constant" in the flow.  Even though my flow works, and had all the correct information, the challenge test is looking for a "constant".  Changed it, and the challenge passed.
This was selected as the best answer
Sébastien PENAUDSébastien PENAUD
Same problem
Jess Burgh 6Jess Burgh 6
User-added image
Hey all. Thought I followed the directions correctly. When I went to check the challenge I get this error message. Help!! Thanks!!
Melanie SturmMelanie Sturm
Same problem here as well. 
Shelly BaldwinShelly Baldwin

Challenge Not yet complete... here's what's wrong: 
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: VXHDKWZW

I have created a new DE twice - still keep getting this error :/

Andy White 43Andy White 43
What's the link to the next trailheads. I've spent an entire day on this one - I still get the error message "Permission Set 'Temporary Account Edit' is not referenced in the flow 'Accounts Temp Access'. Check the instructions"   GRRRRRR
Found the answer in another thread -

you need to change the flow type from Auto launched to Screen Flow
Ben StahlBen Stahl
I am still getting that error message even when I change the flow type from Auto Launched to Screen Flow
Lacey James 8Lacey James 8
I had the same issue, repeatedly. Headdesk. 

Creating a new DE space for this module DEFINTELY helped. 
  1. Whether you've activated "Manage Flows" on the Read Only Clone
  2. Start creating your flow. You want to drag the Activate Session-Based Permission Set to the board
    1. General Setting Name can be anything EXCEPT the same thing as Temporary Account Edit; I added an acryonm at the end to achieve a different API
    2. Inputs, slect "Create New-Constant" as you did in the sample. For the Unique Name, use TemporaryAccountEdit. Leave Data Type set to "Text" and enter the API -- "Temporary_Account_Edit" in the bottom box.
    3. Click the Green Circle Arrow "Set as Start Element"
    4. Save as "Accounts Temp Access"; make sure to select the "Screen Flow" from the drop down instead of the default setting on the pick list-- this is on the save screen. If you have missed this -- DEACTIVATE, DELETE, and START OVER. 
    5. CLOSE.
    6. When you are 100% sure you've done the first 5 steps correctly, click "Activate" (I've tried deactiving and editing, but it only errors out and won't save changes. See note on #4. GRRR.)
Jeff Pekrul 4Jeff Pekrul 4
James Lacey -- your detailed instructions worked perfectly and I passed the challenge. Thank you
jerome devemyjerome devemy
James Lacey,  Thanks for your instruction.   I was missing the  entry of the  permission set name, and using its API name -- "Temporary_Account_Edit"   did the trick
Ranil Goonesekera 5Ranil Goonesekera 5
Thanks James Lacey!  I followed your instructions word-for-word after spending hours trying to figureout on my own.  It worked!!  A side not to others. Like James said, use a brand new DE account (not a Trailhead Playground).  If you are concerned about the new DE account not being linked to the main trailhead account that keeps track of your badgers, it can be easily linked via settings under your MAIN trailhead account.
Christopher  LeClaireChristopher LeClaire
If you are doing everything right but it's still not validating, you probably did what I did and created the flow with the wrong name the first time.  Then on changing the name, the Unique Name did not get updated to Accounts_Temp_Access. 

The validation is checking the Unique Name, not the Name. Delete the flow, recreate the flow with "Accounts Temp Access" and then rebind everythnig in the Lightning App Page and re-activate and it will validate.
James Lacey!!! YOU DA MAN!
Thank you for the detailed instructions - I'd been scratching my head last two days.
Bobby HurdBobby Hurd

I've followed James' instsructions and that helped get me in the ballpark but I'm still have issues. 

The thread referenced at recommends that you first add a "Get Records" from the Permission Set object. I then try and "Filter Permission Set Records" and I create a new resource that references the "Temporary_Account_Edit" permission set as the value. I AM creating this as a CONSTANT.  It then reads "Label equals {!TemporaryAccountEdit}"(this is the API name I gave that value). 

I then try to select variables to store persmission sets and I keep getting the "Enter a valid value" when I reference any of the new resources I created.

I then found this page and tried just adding the Activate Session Based Permission Set action without the "Get Records" element. I follow all the steps and then get to the part where it says to make the Activate action the start of the flow. In my Flow Builder, I do not see the "Green Circle Arrow 'Set as Start Element.' In fact, I don't see the option to make anything the start other than the default "Start" green circle and it cannot be changed. Furthermore, even if I skip that part and follow the direction, I always get notifications that the elements aren't attached to any data. 

I'm super confused and most of the help out there references Designer and so I'm feeling a bit lost. Can anyone help? Longest module of all time. I've seriously spent 4 hours on it today with no luck

Bruce MoschettiBruce Moschetti
I'm having the exact same issue. Spent probably 4 hours on this yesterday as well. It seems the instructions haven't been updated for the new Flow Builder. Any assistance here would be greatly appreciated.
Ivan d'Hotman de VilliersIvan d'Hotman de Villiers
Hi I also follow the instructions but when I get into flow builder the interface does not have  Activate Session-Based Permission Set action on any palette if the 'get record' option is used then that is there but from there nothing makes sense in that no varable names etc can be used with out errors. Any assistance here would be greatly appreciated.
Ivan d'Hotman de VilliersIvan d'Hotman de Villiers
Hi. On the new interface drag core action on the work area then Activate Session-Based Permission Set action is in the pick list. Problem is that when the flow is name Accounts Temp Access the designer say that a flow of that name exists this is off cause not true. Any insights? Thanks
Kathy Isaacs 8Kathy Isaacs 8

OK, Here's how I managed to finally pass this unit.

First, I enabled access to the old Cloud Flow Designer.
Setup > Process Automation Setting > uncheck "Users can access Flow Builder Only"

Screenshot of Process Automation Settings page


Then I followed Lacey James' instructions above.


Assessment Complete screen, with 25 mins crossed out and 25 hours inserted.

muthukumar v 19muthukumar v 19
when i try to run the flow its showing error message like this   please help me it!!!

An unhandled fault has occurred in this flow
An unhandled fault has occurred while processing the flow. Please contact your system administrator for more information.