function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Ronak SFDCRonak SFDC 

Assign Top Leads to Your Sales Rep module - Developer script exception from Honeydew : 'LeadScoreGenerator' for job id

Hi I am doing the Assign Top Leads to Your Sales Rep Trailhead module >> and when clicking on the Verify Step button at the bottom of the page I get an error
Step not yet complete... here's what's wrong:
We can't find criteria and immediate actions for Einstein Scores greater than or equal to 80.

This error message is not accurate as the steps in the process builder are there, however, I suspect the error is actually due to an email that I receive immediately after pressing the Verify Step button, I have copied and pasted the contents of the email below, any advice/help would be appreciated.

Subject: Developer script exception from Honeydew : 'LeadScoreGenerator' for job id '7071t000000V3oh' : Unauthorized endpoint, please check Setup->Security->Remote site settings. endpoint =

ApexApplication <>12:03 (9 minutes ago)
to me
Apex script unhandled exception by user/organization: 0051t000000MOhX/00D1t000000DWM6

Failed to invoke future method 'public static void createScoreAndFactors(List<Id>)' on class 'LeadScoreGenerator' for job id '7071t000000V3oh'

caused by: System.CalloutException: Unauthorized endpoint, please check Setup->Security->Remote site settings. endpoint =

Class.LeadScoreGenerator.sendRequest: line 130, column 1
Class.LeadScoreGenerator.createScoreAndFactors: line 108, column 1
Best Answer chosen by Ronak SFDC
Johan KarlsteenJohan Karlsteen
@Ronak SFDC:
I got the same error (altough I had deployed my domain so the hostname was different).
You should be able to add EU16 under Remote Site Settings. After doing this I passed that step. in Remote Site Settings

All Answers

Matt Morris 24Matt Morris 24

Hi Ronak,

I can't pass the challenge as I get the same "We can't find criteria and immediate actions for Einstein Scores greater than or equal to 80." error despite having completing the process diligently. And I'm getting the same email error message. Have you found a solution?



Ronak SFDCRonak SFDC
No, not yet, but then I only logged the original post earlier today!!! Ronak
Matt Morris 24Matt Morris 24
So you did! Outlook for iOS
Ronak SFDCRonak SFDC
Johan KarlsteenJohan Karlsteen
@Ronak SFDC:
I got the same error (altough I had deployed my domain so the hostname was different).
You should be able to add EU16 under Remote Site Settings. After doing this I passed that step. in Remote Site Settings
This was selected as the best answer
Ronak SFDCRonak SFDC
Thank you @[Johan Karlsteen] that did the trick!
Johan KarlsteenJohan Karlsteen
Happy to hear that @Ronan SFDC, there's a bug in the next step where the apostrophe is incorrect in the description. Spell it like this: "Poe's Pharm"  (' instead of ’) or else it will complain in the end.
Ronak SFDCRonak SFDC
Thank you for the heads up!
Pavlo Shchur 23Pavlo Shchur 23
I had the same problem:
Step not yet complete... here's what's wrong:
We can't find criteria and immediate actions for Einstein Scores greater than or equal to 80.
Assign Top Leads to Your Sales Rep step.
After adding my domain to the Remote Site Settings the problem was solved.
Mike Fisher 9Mike Fisher 9
I have the same problem, but didn't get the email. I've added my domain to the Remote Site Settings and it still doesn't work.
Remote site details
Pavlo Shchur 23Pavlo Shchur 23
Did you configured Lead Scoring correctly? Could you provide the screenshots of your Process Builder?
Larry TrudelleLarry Trudelle
Same problem with me! Tried setting Remote Site, tried rebuilding the process, logged out and back in, tried changing criteria in the process (greater than, less than, etc).... cannot solve this problem!

This is about the 10th time I have not been able to complete a Trail because the verification does not work (and many other people have the same problems with the same trails).....!!!!!!!
Ronak SFDCRonak SFDC
Guys, this question is marked as solved, so you're unlikely to get help for your issue. If you are getting the exact same email that I did, then Johan's solution is the answer. If you have a different issue, or you are not gettin gthe exact same email I did, then I suggest you create a new post, rather than replying to this one. Perhaps it would also help when you create a new question if you include a screen shot of your process, that will help others to help diagnose.
Rose BalgavyRose Balgavy
Had the exact same issue and adding the remote site to the Remote Site Settings solived the issue. Make sure you note the site you are using for the exercise (in my case it was NA57) and that the URL uses this nominclature (using NA57 as the example):
Tigh LoughheadTigh Loughhead
This is incredibly frustrating that this is still not fixed, but Google saves the day! Worked when I added Remote site NA57 for North America!! Thanks [Johan Karlsteen]
Larry TrudelleLarry Trudelle
Thank you to everyone who have made suggestions -  it does not work.  I added the remote site - that did not work.

So I rebuilt the whole thing again using a new trail playground - this time it worked.  ( what a waste of time! )
Nicolas MAURELNicolas MAUREL
Thank you to everyone. After adding EU16 under Remote Site Settings, I passed that step.
Brian KayserBrian Kayser
Has anyone else received the same error without the email?  The Remote Site Details only seems to work if you also receive an error.  I'm still stuck on this.
Hello all,

I work on Team Trailhead and I wnated to let you know that we are aware of this issue and we are currently working on a fix to be deployed soon. In the meantime, I suggest that anyone excountering this, do as the accepted answer suggests and add a remote site name using the site name that should have been sent to you in an email. If you did not recieve the email, then the process probably was not configured correctly and you need to check that first. But, if you do get the email, then use the site name from the email to create a remote site name entry and try to validate again. That should get you past the issue for now. 

Cristian ViverCristian Viver
 [Johan Karlsteen] how did you find this out? thanks so much!
Brian KayserBrian Kayser
Hi SaraHasNoLimits, I didn't receive an email, but I tried several times with new Dev Orgs and followed the Process to a T.  The "Priority Leads with Einstein Lead Scoring" project (Assign Top Leads to Your Sales Rep) is the Step I'm referring to.  No Emails or Apex are a a part of this Project.  Several others on other threads/forums still seem to have this problem without an email.  Hopefully your team is looking into a fix for both instances of this defect.
Ronak SFDCRonak SFDC
All, I will state again, if you are not getting the same error message AND THE EMAIL, your problem is something else. If you have done the steps correctly, you will pass.

This thread is marked as closed / solved.
Bill DodsonBill Dodson
I had same issue, I did NOT get an email, but when I added the Remote Site Setting I passed the challenge.
Brian KayserBrian Kayser
Finally got this to work.  I had to use instead of (which was showing in my browser).  It also failed when I copied and pasted 'Assign Leads by Einstein Score' from the Trailhead.  It passed when I manually entered that string.

A very frustrating experience!

Randy WandellRandy Wandell
Ok, I've got EU10, EU16, NA37, NA53, NA57, NA65 in my remote settings and the challenge still fails!  Attached is my flow diagram and conditions.

User-added image
User-added image
User-added image

User-added image
Randy WandellRandy Wandell
Ok, I passed the challenge.  It seems like there was a theme here.  You have to add your salesforce instance to remote site settings.  In my case that was NA49 so I had to add to remote site settings.
Ronak SFDCRonak SFDC
Not so much a "theme" as a solution!! Glad you got it sorted @randy
shengyu chenshengyu chen
When I do this challenge, all the remote sites have been added and i am still running into this issue. This is what I have in my remote site settings page without actually adding anything as seen below. 

All the remote site settings

The email stating what the APEX error was:
User-added image
shengyu chenshengyu chen
Okay.... Just added a new remote site called na85 by cloning the existing and passed the step.... I just referred to the email that was sent to me and it failed because the na85 remote site access point isn't there in the remote site setting..... Hopefully this would be helpful to people later.
Cheryl Woolsey 5Cheryl Woolsey 5
I have done everything mentioned here and I still can't pass the challenge. I changed my remote setting to both the and submitted still nothing. I've retried the challenge a dozen times and am ready to give up. My process builder steps are identical to Randy Wandell but I still can't pass. So frustrating a 10min module is already at 2+hrs for me.

User-added image
Angelica Veness 12Angelica Veness 12
I'm also stuck on this challenge, tried the remote settings too. No email received, just the error message in the challenge.
Facing the same Issue... There s got to be some missing piece.
Pranav Parakh 4Pranav Parakh 4
Not sure but I guess, Einstein Lead Scoring status is Analyzing lead conversion history...  is the reason process builder fails and you don't recieve emails.
Mark Tough 01Mark Tough 01
Same problem  - no fix as ap4 was already there. Deleted re-tried as Salesforce and Lightning, no luck. @sarahasnolimits any update?
There was some corruption in the org itself ... Trailhead team took care of it.
Issue has been resolved now.
Please try in a new org. Should be fine now
Dhanik L SahniDhanik L Sahni
Add debug information for yourself. It will log error in debug log. Mostly it is related to CORS and Remote Site Setting
I added a new remote site --
and that was all. Though it threw another error which was absurd.
"The process is active"
I deactivated the process and that was it!
Thanks for the solution Johan Karlsteen :)
Rod SchmidRod Schmid
Hi There, I had the same problem but I could fix it adding the remote site,
Thank you all
Vishal Agrawal 35Vishal Agrawal 35
i also got the same issue but it get resolved by adding
i think some of you may adding the url as  as i get this url when click on my browrser url box so remove lightning.force and add salesforce in the place  and it should look something like this
Andrew ClintonAndrew Clinton
This failed for me, thankfully I found this thread. I didn't receive an email like people have mentioned. I looked on Remote Site Settings and EU16 was already added. I manually entered one for the URL my org was loaded on and it worked. The URL was so I created a Remote Site Name of UM4 and entered the URL as and then I passed the exercise. So whatever your URL is, create a remote site for that using this process and try again. Good luck!
Paolo LeonciniPaolo Leoncini
@Andrew Clinton 
Thanks Andrew - this works also to me - more in details:
You need to find the right Remote Site Setting you need for your Org.
It is easy to track for the URL of yoru organization - for my sandbox it is: (or  I believe there is a redirection)
- check what it is for yours 
Then you simply go in:

Settings/Quick FInd/Security/Remote Site Settings and you add ta remote site for your org 
I my case like this:

add remote site
Save and recheck - I didn;t get any error via email and I pass the trailhead 

PS: I suggest also to wait till Einstein makes his background work in scoring leads - in a DEV sandnox it shouldn't take too long  
Francesco Angelini 24Francesco Angelini 24
@Andrew Clinton 
Thanks, this works also to me! Just follow @Paolo Leoncini step by step procedure and all will be ok!
David Noe 8David Noe 8
That worked for me too. It was not recognizing the na132 remote site name. Once I added it, it worked just fine. Thanks evrybody.