function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Peter OgilviePeter Ogilvie 

salesforce sfdx force:org:open

I'm able to create scratch org which I can see in my trail dev hub but I can't open them.   from "Get Ready to Create an App" tailhead
pogilvie:~/Projects/geolocation-> sfdx force:org:create -s -f config/project-scratch-def.json -a GeoAppScratch
pogilvie:~/Projects/geolocation-> sfdx force:org:open
ERROR running force:org:open:  No defaultusername org found. 

I've also tried:

sfdx force:org:create --setdefaultusername -f config/project-scratch-def.json

and I get the same error.   I wished I tried this out yesturday when I was a trailhead dx!    
I got this with trailhead when jumping between different projects, I got it working with:

sfdx force:org:display -u GeoAppScratch

You get a bunch of info including username, copy and paste it into the below

sfdx force:config:set defaultusername=<your org username>