function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

process automation specialist step 6 - Error: Faraday::ClientError. Message: MALFORMED_QUERY

There was an unhandled exception. Please reference ID: KLNTXAZY. Error: Faraday::ClientError. Message: MALFORMED_QUERY: When retrieving results with Metadata or FullName fields, the query qualificatio​ns must specify no more than one row for retrieval. Result size: 2

I have a flow that allows you to choose the product type, then the product, which creates the product, then asks if you want to add more products and goes back to the start. Seems to work perfectly. Not sure what this error is.

Hi Will, can you share me the flow steps or images of the flow you designed.

Overview of flow

  • Overview
    • 1st Screen - Product Type - Radio - Saves the choice as
      • RainbowBot
      • CloudyBot
      • Assembly System
        •  as ProductType
  • 2nd Screen - Product - Dynamic Radio - Pulls products with name contains the result of first screen
    • Saves choice as Product2ID
  • Record Lookup
    • Looks up PBE via Product2ID + Standard Price Book ID
      • Passes as PriceBookEntryID
  • Record Create
    • Creates OpportunityLineItems
      • PriceBookEntryID.UnitPrice*1 as TotalPrice
      • Opportunity ID passed to flow from Lightning Record Page
      • PBEID from 2nd screen.
  • Add more Products - Radio select Yes/No
    • Directs to Decision
  • Decision Directs to Product Type Screen
Stevie Burt 7Stevie Burt 7
@Will when you added the flow to the Lightning Page, I'm assuming you checked the box to pass in the OpportunityID, but how did you then pass that into the flow? I am thinking that is where my issue is. I checked that box and left the other two unchecked/un-populated (PriceBookEntryID and PriceBookEntryID_UnitPrice) and just got those from the flow.
That's exactly right - although I'm curious - how did you get the PricebookID in there? Sent from iOS
Stevie Burt 7Stevie Burt 7
@Will - Actually now that I read your comment, I think that might actually be where I am stuck. I am not passing in the PriceBook just searching all products...oops :(
I'm going to add a radio choice at the start that sets the price Book I think. Not that I think it will help me pass the challenge. The challenge itself is also just showing a list. You need to use a Loop it says - I'm not sure if that's a reference to the choice from the palette or a reference to the overall structure of the flow. Sent from iOS
Stevie Burt 7Stevie Burt 7
@Will. Im gonna try to set the default price book. Also - I dont have a Loop in my flow from the palette. So I am gonna attempt to validate the challenge and check the debug log!
If you get it, please let me know here - I'm so freaking close to having it - I think the instructions are too vague. I don't mean that as a knock on salesforce actually - this is like, the most gritty and realistic trailhead I've ever seen. I'm probably way overbuilding this. I'm not even kidding. They don't even say anything about creating products in the requirements - only listing them. Exact recreation of actual working life. Sent from iOS
Mary TaglerMary Tagler
Following this, I know I'm going to struggle on this one. Thought the instructions were too vague.
Has anyone passed it yet? Sent from iOS
Devin JefferiesDevin Jefferies
I'm to the point of scrapping this and starting again, pretty messy at this point. Would love for someone to add some tips to this thread if they've completed it. Very little experience with flows unfortunately. Learning a lot though!
I completely rebuilt once or twice - in different setups as well. I thought I was overthinking it, trimmed it down to a widget that just shows the list of products, without adding to the opportunity. No luck. They should add more mockup screens to the PPT - not entirely sure what is being asked for. There are just so many possible iterations, but I'm going to try again with Dev console logging. At least I could go specific error by error and figure it out. Sent from iOS
Tony White (BNE)Tony White (BNE)
Up to this one as well, not certain what they are after...
Mickael RaoulMickael Raoul
Hi Everyone, 

I have one quick question : Did you create products by your self on this challenge ? 

I have no Product where product name contains RainbowBot, CloudyBot or Assembly System for now
Stevie Burt 7Stevie Burt 7
@Mickael I did not. I think it is apart of the package you installed. 

User-added image
Stevie Burt 7Stevie Burt 7
@Will Ive been playing around all weekend and still no luck. I attempted to do a loop element in the flow and it is still not liking it. I wish someone from tailhead could assist here. The debug logs are no longer giving me enough information to correct the issue. Not sure what to do next :( Ugh!
Mickael RaoulMickael Raoul
@Stevie The package I have installed only contains Email templates ( and My DE org has been generated on the 27th July... I have then created one Product "RainbowBot Number 1"

And I succeed to pass the challenge even if my flow simulations are wrong and I do not understand why it is wrong

I inspired myself from this video :

1) Screen with 3 choices and store the result in screen choice fields : ProductType
2) Lookup to find records in product2 with contains ProductType and store them as variables (Id + name) // Here the ProductType is the one I have chosen, but result are not right products... I am still wondering why. 
3) Screen to display variables 
4) Activate the flow 
5) Add the flow to the opportunity screen 
6) That's it -> Check Challenge
Mary TaglerMary Tagler
@Mickael - Do you have the Assessment app installed? That's the second one you should have. The link wasn't obvious, if I recall correctly.
Mickael RaoulMickael Raoul
@Mary, I have installed it from the appexchange and it does not create any product :(
Mary TaglerMary Tagler
@Mickael - under the pre-work section, second bullet. It's hard to tell, but where it says Process Automation Superbadge unmanaged package, it's a hyperlink. Here's the direct link:

Here's the link to the associated help article. They were very easy to miss, they don't look hyperlinked:
Chalon Emmons 13Chalon Emmons 13
Hi @Mickael, did you create a new Trailhead Playground for this superbadge? You need to be sure to create a Trailhead Playground through the Create a Trailhead Playground button in Trailhead. A regular Developer Edition org doesn't have the required products.
Stevie Burt 7Stevie Burt 7
@Mickael - Are you saying you successfully passed challenge 6 with just a flow with the following:
  1. Screen with Choice to select Product Type
  2. Lookup to Product2 where Name CONTAINS the option chosen on Screen 1.
  3. A Screen showing the variables found? 
I attempted that and still cannot pass the challenge.
Tony White (BNE)Tony White (BNE)
The data is provided by the playground, not the package.  I saw it in the playground for the last superbadge I finished.
Mickael RaoulMickael Raoul

Thank you all effectively, I did not deploy the playground that's the reason why 

@Stevie here are my screenshots 

User-added image

User-added image

User-added image

User-added image

User-added image

Stevie Burt 7Stevie Burt 7
Thank you, I will compare yours to what mine is and see what I am doing wrong! 
Michele Losch 4Michele Losch 4
Hi All,
I passed the challenge before Trailhead was shut down for maintaince so I don't know if my flow would still pass but all I had was 2 screens, 1 record lookup, and decision. I believe the challenge just checks to see if a flow is on the lightning page more so than if it operates correcly. 
Tony White (BNE)Tony White (BNE)
I passed this challenge!
2 screens only as the lookup is done on the second screen based on the option from the first screen.  (lightning component could do it without second screen)..
Make sure that the list is filtered correctly for the 3 options (cloudybots has none for me), make sure to have the name and id fields.
Arthur ImirzianArthur Imirzian
Hi @Will Craig,

This is a technical error.
Go to Setup > Object Manager > Opportunity > Lightning Record Pages and ensure you have only one lightning record page.

User-added image

@Mickael Raoul
- You don't need a product lookup between the two screens. 
- The Dynamic Record Choice should reference {!ProductType} as a filter value on name field
zhe zhuangzhe zhuang
Hi @Mickael, 
I clear this challenge at developer edition with input the Robot data manually.

Step1 : Click the Products from App Launcher
User-added image

Step2: Manully insert product, with product family as RainbowBots, product name as Large/Medium/Small RainbowBot
User-added image

Hope this can make a difference.

Ankit WaliaAnkit Walia
Thanks. After removing my extra page. The Result is 2 error is gone
Junaya Raika 9Junaya Raika 9
Removing the extra lightning page also solved the ugly error message for me (as per the originating thread), so the thread from Arthur Imirzian should be selected as the correct answer (thanks Arthur!!!). The correct build to implement the flow is documented in this link >
Matt BrandtMatt Brandt
Funny thing is, I tested it and knew the flow wouldn't work, but I just wanted to see if the challenge would verify, and it did. Basically, if you have a flow with two screen components and a Record Lookup component, and have that flow installed on a Lightning Record Page, it'll verify. Doesn't matter if the flow actually works.

That being said, my next challenge, personally, is to figure out how to make the flow work. Flows are not my strong suite. I followed much of the advice in this post and another one on Step 6, and while they got me in the right direction, the flow still won't work - it shows another, single product that doesn't include any of the keywords defined in the requirements. Frustrating, indeed!
Robert AllenRobert Allen
I was able to pass the challenge today and get the flow to work properly. I attempted to replicate what others did on this board, but had no such luck so I decided to take a different route. I am pretty sure the above flows would pass the challenge, but I wanted to go with the spirit of these badges and have a properly functioning flow as well.

Here is my basic flow design:

Process Automation Flow Design

I did deviate from the what others had done and added the Product Family to each of the related products (Product Family picklist: Rainbowbot, CloudyBot, Assembly System). I decided to do this since I felt it (1) simplified the flow and (2) provided a more real world solution to the request as using a standard picklist field aligns better with best practices. I also decided to use a picklist in the flow instead of radio buttons.

User-added image

The Fast Lookup basically looks up the product family, but I saved the Family, Name, and Id in the Variable. I used a Loop Palette to gather all of the Products in the selected family, and used the Assignment Palette to compile all of the products for the final screen (note: I am not 100% sure this palette is necessary, but I am not going to chance breaking my flow to find out!). The final Screen Palette is another picklist that spits out the Products in the specified Product Family. Here are my results: 

User-added image

User-added image
The picklist view kept going back to the selection, but all three options are available. 

I hope this helps!
juni kumarijuni kumari
Hi All , 
If you are still stuck Please find the detailed step by step solution in the below link:
Danny KnowltonDanny Knowlton
Arthur Imirzian, you are the man!!  Thanks bro. I don't know how you figured that out. I wasted so many hours on this stupid error.  I must've saved a draft of changes to my Opportunity page at one point. Grrr...

Setup -> Object Manager -> Opportunity -> check for more than one record!!
David HuddlestonDavid Huddleston
Ok now I'm stumped, I got the screen flow to display the products when you tick the boxes but I'm getting an error from the system stating MalformedQuery.  Not sure what I need to do to fix this any ideas?

Here is the Error:

There was an unhandled exception. Please reference ID: DWUENIEI. Error: Restforce::ErrorCode::MalformedQuery. Message: MALFORMED_QUERY: When retrieving results with Metadata or FullName fields, the query qualificatio​ns must specify no more than one row for retrieval. Result size: 2
Close errors

Here is my Results

User-added image

Every time I tick one of the boxes, save the record and refresh the screen the products change.  I'm lost, the flow is working great but the error I don't understand what to fix.  Any thoughts?
David HuddlestonDavid Huddleston
Nevermind, I found a link.  I had two lightning pages on my org.  If you are getting this error try deleting the second opportunity lightning page.  Well that took 2 hours to figure out.  thank you Kahn, you were spot on.

here is a link to the fix by Kahn Anas