function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Patrick McClellanPatrick McClellan 

Superbadge: Process Automation Step 5

We're instructed to send an email to the finance group -- that's pretty vague. I'm going to create a Finance group, made up of the CFO and subordinates. Am I missing something in the instructions?
Best Answer chosen by Patrick McClellan
Devin JefferiesDevin Jefferies
It's mainly about using the email template in your email alert and firing that off from an invocable process from what I could tell. I just had them sending to me and it worked fine.

All Answers

Devin JefferiesDevin Jefferies
It's mainly about using the email template in your email alert and firing that off from an invocable process from what I could tell. I just had them sending to me and it worked fine.
This was selected as the best answer
Patrick McClellanPatrick McClellan
He Devin, thanks for the response. I understand that these superbadge modules are deliberately vague so we'll have to scramble to problem-solve.

I created a Finance Group, created a new email template (cloned from the Sales email), set up an email alert, which I'll call from the process.
Devin JefferiesDevin Jefferies
You shouldn't need to create a new email template. Up in the superbadge instructions at the top there's a package you install that includes two email templates to use for the updates and approvals.
Patrick McClellanPatrick McClellan
Yeah, I saw those, but I thought we might be using those later, elsewhere. All I did was clone one of those and change the text from "needs your approval" to "has been created". I wonder if the validation will ding me for using a different template? (I can't check now because I'm getting that system error that many others have been experiencing. Trailhead contacted me and they're working on debugging it.)
Devin JefferiesDevin Jefferies
I got that error briefly early on but fixed it by separating out some validation rules. I think it was the same thing they're talking about in this thread:
Patrick McClellanPatrick McClellan
Hey Devin, I'm a little confused on the 5th step, specifically the approvals submission and stages. Wondered if you understand it better than I do.
When and opportunity is in Negotiations (stage = Negotiation/Review) and amount > $100k, automatically submit it for approval.

So the process criteria is:
  • Record is changed
  • stage = negotiation/review
  • amount > $100k
Submitting locks the record and updates stage = awaiting approval.
If approved, record unlocks and stage is updated to Closed Won.
If rejected, record unlocks and stage is updated to... ?  The video script says it should go back to negotiation/review, record unlocked. Won't this trigger a loop of automatic re-submission because our process criteria is true again?
Patrick McClellanPatrick McClellan
RE: the error -- that thread is talking about the first challenge, validating state/country. The fixes they discuss are valid for fixing bad logic, but not this unknown system error. That thread seems to be convoluting the two different types of error.

I had already passed that first challenge with no error. I'm stuck on step 2 validation, which is just the new fields, with lookups and master detail relationship. 
Devin JefferiesDevin Jefferies
Step 5: Yup, I thought that was weird too but it passed so I didn't complain too much.

Step 2: Pretty sure I made five account validation rules on that one. Shipping/billing country and state made four then one for the account type.
Claire JonesClaire Jones
Patrick - step 2 validation fails seem to be mainly on the Call for Service formula. For some reason it expects you to check 2 years in the future as well as 2 years in the past...
Patrick McClellanPatrick McClellan
@Claire, thanks for the tip. I added that line to the formula, but I still get the same error.
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: POKAJRAH

Looking through the logs for the test, it's not getting as far as the test on the new fields. It appears to be running the validation tests on shipping state and account name change, succeeding and failing as appropriate for each test. During the last test completed, it fails at the attempt to change the name on an account that is Customer - Direct.
Shukla YogeshShukla Yogesh
Hi All

Have anyone completed step 5? I am in a weird situation and getting below error:

Challenge Not yet complete... here's what's wrong: 
There was an unexpected error in your org which is preventing this assessment check from completing: System.DmlException: Insert failed. First exception on row 0; first error: CANNOT_EXECUTE_FLOW_TRIGGER, The record couldn’t be saved because it failed to trigger a flow. A flow trigger failed to execute the flow with version ID 3017F000000PVPG. Flow error messages: An unhandled fault has occurred in this flow
An unhandled fault has occurred while processing the flow. Please contact your system administrator for more information. Contact your administrator for help.: []

In debug logs I could see it tries to insert null in account id which turns into exception in process builder. I could excute the anonymous block after deactivating the process.
I have applied the TypeofAccount ISNULL as FALSE in all the nodes of process.

13:25:23.52 (54315503)|FLOW_VALUE_ASSIGNMENT|9536aaff64d4994a9f26c5a386915d9a51c31b-7811|myVariable_current|{Id=0067F000003kvTsQAI, IsDeleted=false, AccountId=null, RecordTypeId=0127F000000PmBfQAK, IsPrivate=false, Name=Sell some chicken salad, Description=null, StageName=Negotiation/Review, Amount=101000.00, Probability=90, ExpectedRevenue=90900.00, TotalOpportunityQuantity=null, CloseDate=2017-07-31 00:00:00, Type=null, NextStep=null, LeadSource=null, IsClosed=false, IsWon=false, ForecastCategory=Pipeline, ForecastCategoryName=Pipeline, CampaignId=null, HasOpportunityLineItem=false, Pricebook2Id=null, OwnerId=0057F000000VrJhQAK, CreatedDate=2017-07-31 20:25:23, CreatedById=0057F000000VrJhQAK, LastModifiedDate=2017-07-31 20:25:23, LastModifiedById=0057F000000VrJhQAK, SystemModstamp=2017-07-31 20:25:23, LastActivityDate=null, FiscalYear=null, FiscalQuarter=null, LastViewedDate=null, LastReferencedDate=null, ContractId=null, HasOpenActivity=false, HasOverdueTask=false, DeliveryInstallationStatus__c=null, TrackingNumber__c=null, OrderNumber__c=null, CurrentGenerators__c=null, MainCompetitors__c=null, Approved__c=false}

13:49:34.58 (117503000)|FLOW_ELEMENT_ERROR|The flow failed to access the value for myVariable_current.Account.Type because it hasn't been set or assigned.||
13:49:34.58 (117519916)|FLOW_START_INTERVIEW_END|1298ca92748c9c92d23468569ff415d9a44ef09-3a55|Opportunity Automation Process

Please let me know how to avoid this.

Shukla YogeshShukla Yogesh
Hi All

I was not handling the scenario where an opportunity is inserted without an account. I was able to clear STEP 5 after handling the ISNULL for Account Type and Account id fields in flow.

Amit Khanduri.Amit Khanduri.
Hi Yogesh I had the same issue then i realise my public group has no user assign and it failed to send email. Here am completed Step 5.
Patrick McClellanPatrick McClellan
They appear to have fixed the system bug, so I've cleared validation on steps 2, 3, and 4. I'm hanging up on step 5, where it says the opportunity was not successfully submitted for approval. I have things set up with an Approval process, but I'm wondering if it wants us to use Process Builder instead. Have any of you passed the validation using just an Approval process?
Faiza Naz 10Faiza Naz 10
Check this blog for complete solution of superbadge
raj n 34raj n 34
Hi Shukla Yogesh,

How exactly did you fix the CANNOT_EXECUTE_FLOW_TRIGGER issue? I add conditions in each node to check for (Opportunity.AccountId is not null and Opp.Account.AccountType is not null) but still getting the same exception. Nothing in the debug log I could find that would help. Please help
James Allen 23James Allen 23
I'm having an issue where, "An Opportunity with the Stage 'Negotiation/Review' and the Amount greater than $100,000 was not successfully submitted for approval upon creation".  However, I can manually create an opportunity that meets the criteria and it does submit for approval.  I even looked over Faiza's post step-by-step and I feel I'm not missing anything.  Anyone else having these issues? 
Faiza Naz 10Faiza Naz 10
Make sure that you assigned Manager field a value on your user record because approval process will fail if manger field is not defind on opportunity owner record which is you in your dev org.
James Allen 23James Allen 23

Thank you!  Here is where I went wrong: 

Entry Criteria for an Opportunity in Stage "Negotiation/Review", I had also included that the Account Type to be "Prospect".  I must've had a long day yesterday as I thought that was part of the requirements!  Once I removed the Account Type criteria everything went through OK. 

Thanks everyone! 

Deepali Gokhru 23Deepali Gokhru 23
Hi @Devin Jefferies

As you have already completed the challenge, can you please help me understand the significance of Prospect Accounts here. My undestanding says  it is the Opportunity with related Account Type as either Customer - Direct or Customer - Channel. And same goes with Customer and Prospect Accounts. (including Account Type as Prospect to the list) Please correct me if I am wrong.

@Deepali Gokhru
Yes,Opportunities  with related account type Customer(Customer - Direct or Customer - Channel) And prospect
manoj krishnamanoj krishna
Even i am stuck in same step, but error code is as below
Challenge Not yet complete... here's what's wrong: 
A new Opportunity with a 'Prospecting' stage for a 'Prospect' Account did not successfully create a Task for the Account owner with the Subject 'Send Marketing Materials'.

Though It is creating task for the account owner. any insights on this error?
manoj krishnamanoj krishna
I got the solution, i had missed Related to ID in task creation
Randy Imler 18Randy Imler 18
I can't, for the life of me, install the extra report package.  No matter how I go about it, I always end up with the following error:

This app can't be upgraded.
There are problems that prevent this package from being installed.
Unable to install.The unmanaged package "Process Automation Specialist Email Templates" is already installed in your organization. You will need to uninstall it before installing a new version.


Abhinav PaulAbhinav Paul
Hi All,
I am getting an error-

An Opportunity with the Stage 'Negotiation/Review' and the Amount greater than $100,000 was not rejected successfully by your manager or the Opportunity Stage was not updated to 'Negotiation/Review'.

I tested it and it working completely fine. Don;t know why it keep throwing this error. Kindly help.
Abhinav, open the Dev Console before you do the validation check, so that you can access the logs from the validation (sometimes they're hidden; I can't remember on this challenge.) It's a bit tedious, but when the logs are available, you can look for the specific transactions that they're testing. That may give you a clue to changes you need to make.
ksarer Vanita Vanitaksarer Vanita Vanita
Hi Everyone, 
I am stuck with step 5 
keep on getting thsi error 
Challenge Not yet complete... here's what's wrong:
A new Opportunity with a 'Prospecting' stage for a 'Prospect' Account did not successfully create a Task for the Account owner with the Subject 'Send Marketing Materials

Pls help
Tim KriegerTim Krieger

Hi everyone, 

I'm pretty far into the Process Automation Superbadge, step 5.

I created the approval process, the email alerts and I set up the processes in Process Builder. 

However, when I try to verify my steps, I get this cryptic error message:

Challenge Not yet complete... here's what's wrong:
There was an unexpected error in your org which is preventing this assessment check from completing: System.DmlException: Insert failed. First exception on row 0; first error: FIELD_CUSTOM_VALIDATION_EXCEPTION, Pickvals must be the correct ones.: []

I'm really struggeling to figure out what that is supposed to mean. 

Has anyone ever seen this? 


Thanks a lot!



Tim KriegerTim Krieger
Found the solution to my problem with the "FIELD_CUSTOM_VALIDATION_EXCEPTION"
It turns out, I had to de-activate some of the validation rules on the account object that I created for an earlier step of the badge. No idea why, but de-activating them solved the issue for me.