function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Sam AmarSam Amar 

Check Challenge Button greyed out.

I'm not able to check my challenge for one of my modules even though I have logged into my trailhead account.

Check Challenge button is greyd out. Need suggestions.User-added image

I was able to gain badges for the other modules also I have finished 100 pts questions within this same module.  
1 exercise away from earning a badge and its not allowing me to check challenge. 
NagendraNagendra (Salesforce Developers) 
Hi Sam,

What I've found works is going to your profile settings and reconnecting your org.  

Click the "connect an org" button, and connect the one you've been using.  That seems to do the trick.  You'll have to do it after you've been inactive for a while.  almost like you would have to sign back into SF after a period of not using it.
User-added image

Hope this should resolve the issue.

Mark this as solved if it's resolved so that it gets removed from the unanswered queue which results in helping others who are encountering a similar issue.

Surabhi Rohilla 15Surabhi Rohilla 15
Hi Nagendra, I am facing the same issue and I tried the workaround you suggested but this has not solved my issue as yet. Did you face this situation of the check Quiz button locked and tried any other trick?