function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Jonathan Steel 1Jonathan Steel 1 


I have an integration that a customer is using and they are getting this error when trying to create a record:
"Unable to create/update fields: app__Status__c, app__ReferenceNum__c. 
 Please check the security settings of this field and verify that it is read/write 
 for your profile or permission set.\",\

I cannot reproduce this error no matter how I change my permissions and settings. None of the posts about INVALID_FIELD_FOR_INSERT_UPDATE seem to be related to this issue.

I'm creating it with the ruby gem as follows
client.create('app__Idea__c', Name: xxx, 
        app__ReferenceNum__c: xxx, app__Status__c: xxx)
What is causing this error and or how can I recreate it?

Hi Jonathan,

There could be two issue:

1. You just check field level security for these fields and make sure the profile used by your integration has edit and read access check box checked.

User-added image

2. There could be a record type issue, i mean certain field will be visible to certain record type only so please test by putting certain record type as well.

Pawan Kumar
Jonathan Steel 1Jonathan Steel 1
Thank's for your reply Pawan. I'm not actually trying to fix the problem, I'm trying to reproduce it. I don't have access to the customers account, so I have to find a way to reproduce whatever situation they are in. I have tried removing permissions to the object fields, the objects, changed permission sets, changed profiles, just about everything I can think of. Nothing yields the INVALID_FIELD_FOR_INSERT_UPDATE error. At most I can get a NOT_FOUND or CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY error when the user does not have the correct permissions.

Given that I have tried all manner of permission settings to reproduce this error and cannot, I feel that looking at the users account will not help me because I'm probably missing some other type of permission it could be.
Mustafa JhabuawalaMustafa Jhabuawala
From the error it seems that the field is not accessible to the logged in user profile.

Try to replicate the permission sets and also the FLS (field level security) by comparing it in both orgs and then try to run your code.