function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Error while importing data using Informatica on Demand

This is the first time I am using Informatica on Demand.


I have a custom object 'Mileage__c'. The custom fields in that are Approval_Status__c(picklist), Contact__c(lookup relationship with Contact object), Date__c, Miles__c, Kilometers__c.


I created a table MILEAGE in my oracle DB and fields are Approval_status, Contact, Process_Date, Miles, Kilometers


I inserted a record in MILEAGE table of oracle DB and tried to insert that record into Salesforce using informatica on Demand tool it give me the below error.


"0 success rows, 1 error rows. Error loading into target [Mileage__c] : Error received from Fields [Contact__c]. Status code [MALFORMED_ID]. Message [Contact: id value of incorrect type: Tim Barr]."



please help me in solving this issue.



Thanks in advance.



Message Edited by sfdeveloper9 on 09-23-2009 10:31 PM

Hello sfdeveloper9, thanks for trying Informatica On Demand Services.    It looks like the problem you are having is because you had mapped the name from your Oracle table into the ID of the Contact.    For Insert opertion, the ID field in the Contact mapping needs to be left empty because will create an ID there for you on insert.    Let me know if you have any further questions.


InformaticaOnDemand - IOD Community site


I am also having the same error Error loading into salesforce target [ECIS_Company__c] : Error received from  Fields [Group_Name__c].  Status code [MALFORMED_ID].  Message [Group Name: id value of incorrect type: 5374].

I have a custom object with cis_id and parent_id and Ultimate_parent_id and Group_c(group_c will have cis_id if Cis_id <> ultimate_parent_id,So only for company level objects will have this column populated).cis_id is extenal id also which i will be inserting.I have type group and company.If cis_id = ultimate_parent then its group else its company.So now my question is i need to upsert all these into salesforce usng informatica on demand.

1.Since group is top i will first load group and get the salesforce generated id back and copy it to a SFDC_ID column in oracle next to company level objects.

2.Now when i am upserting these company objects its throwing the above error.Group_c is lookup datatype.Please help me