function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

eclipse deploy not picking up all classes

I'm using the Eclipse toolkit to deploy to another SF account.  Not all my classes are being picked up in the list of items to deploy?  Three are missing.   They compile OK.  They all pass the tests with sufficient code coverage for classes and triggers.  What else might make them missing from the deploy list?
Note the new account has no code installed - but does have all required custom objects etc.
I used Ant instead and that worked fine.  Eclipse still misses classes.  The only thing I can see in common with the ones missing are that they are all big.  Is there a low restriction on class size deply via Eclipse?  Might not be that of course.
glen martinglen martin
In your first post, this was the first deploy from Eclipse into an org, right?  How did the classes get into this Eclipse project in the first place?
Now that you've used Ant to load them into the new org, if you create a new Eclipse project from the org, change the files (eg add a whitepace) and resave from within Eclipse, what happens?
Yes.  I was moving the code from one project to another.  About 15 classes and 15 triggers.   I got them into Eclipse from a fresh "replace all files in local project" from my SF developer account.  I tried refreshing this again with no effect.  Changing the code "adding a space" and saving puts it back into the developer account.  Works fine between Eclipse and the original account.
When I then use the deploy tool to get it into the new account (with all my custom objects but no code or triggers).  Eclipse misses out 4 of the class files for no reason I can see.  It isn't the length either since one is small.  The deploy then fails since the classes are needed for the ones it leaves behind.
The Ant deploy worked with these exact same files.  I then went back to see if Eclipse would update - but it was still missing those classes in those it wanted to delete and replace.
Hey cic.

Few questions:
- Each time you deploy, is it the same 4 classes that are left behind?
- In the pre-deployment view of the deployment wizard, what action is shown for those classes?
- Can you try creating a new project from scratch, and then re-try deployment?  Result?
- Can you send me the toolkit's log containing your deployment transaction?  You can find the log here: $workspace/.metadata/.plugins/com.appexchange.toolkit/salesforce-toolkit.log.

1. yes
2. They are missing from the list entirely
3. Same result
4. Will do - it will have to be tomorrow.