function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Tabs not visible in production environment

Hi all,


I have deployed  my App included all objects and tabs from SandBox to production. But problem is I am not able to see the tabs under particular App.

I chekecd with the Create -> tabs option , all tabs are available there, But not visible in Accessioning app. Is ther anything wrong in deploymenyt, I cheked the result fo deployment also there is no error, Please help ASAp




Save Time with ForceSave Time with Force


Please make sure you enable the tabs under setup preferences which you can see under editting your account information. This could happen if the profile donot have tabs enabled for your login as well. If this solved your problem, please click like or solved.



Thanks for the reply Buyan!!


Can you please be more specific about the "Enabling the tabs under setup preferences  under editting account information", I am new with SalesForce







First make sure that the tab settings on your profiles were applied to your production environment, Setup > Manage Users > Profiles > {PROFILE} > Tab Settings. If the tabs you expect to be displayed are set to "Default On" then it may be a user setting overriding the profile setting. To edit user settings (logged in as the user): Setup > My Personal Information > Change My Display > Customize My Tabs.



Took me a while to find what Kristy was referin to as "Tab Settings"... On my version of Salesforce, I encountered same problem: deployed Tab and Page Layout via an Outbound/Inbound Changeset, and there was no link to the tab I wanted from the All tabs screen.
I resolved this by going to Setup > Manage Users > Profiles > {PROFILE}  (substitute for some name of a Profile in your org)... then I get a list of other links, and the "magic" one for me was "Object Settings" ("Permissions to access objects and fields, and settings that specify which record types, page layouts, and tabs are visible"). Once I clicked on that I got to a list of all Objects. I found the one I wanted and then there was a section titled "Tab Settings"! Once I clicked on Edit there, I changed it from "Tab Hidden" to "Default On" and voila, that's when the tab appeared.
David Huddleston 1David Huddleston 1
Well I tried all of the above and found first I did not bring over my Tab in the Change Set.  I went back and pulled in the Tab in the Change Set, then followed the recomendations above and my tabs are now visible.

Thanks for the help everyone!