function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Apex Data Loader 11.0 ( embedded commas in csv data file)

I have been using the data loader to populate our dev area and have found that when trying to load data that had been exported from our database  has the ',' ( comma character ) in some of the text fields.
Is there a way for Data Loader to ignore the ',' if it is embedded in the text data ( surrounded by quotes )?
If Data Loader will not allow for this, do you have another means of migrating this data to SF?
Thanks in advance,
Did you get a work around for this???  I just hit this same problem and found your message....
I'm having the same problem.  i'm finding the documentation to be more and more ridiculously sparse.  Which is very disappointing given how much Saleforce costs. Anyone tried the standard escape char "\" in front of the comma?

Nevermind...just tried it...didn't work.

Related to this thread but i'm going to put text here too so one can google the answer:

The proper way to escape commas and other risky or invalid characters in the data loader is to surround them with double-quotes:

change all , to ","

I'm sure it would be wise to first change all double-quotes to single-quotes and THEN do the comma search&replace.

3,645 success.  Zero errors.

Message Edited by jduhls on 07-10-2008 07:33 AM