function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Want to upload data in china language

I am facing an issue while uploading data in china language .It is uploading data but not in proper format .It is uploading with some spacial character .

Please help me on this .

Thanks ,
Follow the procedure explained in the below article

And the below post
Hi Manoj, 

Once you export the data from salesforce in .csv format and you don't need to modify the files, Then you better not to open the csv file and you can just import that file into other salesforce org.

But other case, If you want to modify that .csv file before you import it, Follow the steps below to view the CSV file

1.     Open Microsoft Excel 2010.
2.     Click on the Data menu bar option.
3.     Click on the From Text icon.
4.     Navigate to the location of the file that you want to import.  Click on the filename and then click on the Import button.  TheText Import Wizard - Step 1 or 3 window will now appear on the screen.
5.     Choose the file type that best describes your data - Delimited or Fixed Width.
6.     Choose 65001: Unicode (UTF-8) from the drop-down list that appears next to File origin.
7.     Click on the Next button to display the Text Import Wizard - Step 2 or 3 window.
8.     Place a checkmark next to the delimiter(comma) that was used in the file you wish to import into Microsoft Excel 2010.  The Data preview window will show you how your data will appear based on the delimiter that you chose.
9.     Click on the Next button to display the Text Import Wizard - Step 3 of 3.
10.   Choose the appropriate data format for each column of data that you want to import.  You also have the option to not import one or more columns of data if you want.
11.   Click on the Finish button to finish importing your data into Microsoft Excel 2010.

You can also read this important article

It will help to solve your problem, 

Also See the threads below,

Abi DuthuAbi Duthu

Even we faced the same problem. We resolved this issue by using Import wizard for Data upload .

Kindly refer this:

How to upload data in different languages in Salesforce

Recently while working on a project, I had the requirement of uploading data containing Chinese, Thai, Vietnamese etc. characters in Salesforce. The data to be uploaded was available in Microsoft Excel format. However from Excel, when I tried to save the data in CSV format a lot characters where converted to ‘ ? ‘ (question mark) resulting into loss of characters. Excel does not allow you to specify the the encoding of the CSV file, which might have solved the problem.
After spending quite some time in looking for the solution (it wasn’t as straight forward as I had imagined) I came across a solution on Salesforce’s help site. The title of the article is ” How to import Asian characters from a CSV file into Salesforce ” and the Knowledge Article Number is ” 000004092 “, which worked quite nicely. So here is the solution given in this article
1. Once you have the data in Excel format, save the file as ‘Unicode Text’ (this option is available in Excel)
2. Open the file in notepad
3. In Notepad, go to File, Save As …, then see if it has an option that says “File Encoding”. If it does, change the encoding to UTF-8. If it doesn’t have an option that says UTF-8, then you have an older version of Notepad that doesn’t support this option. Here you would end up saving as UTF-16 which Salesforce can also import.
4. Ensure the filename has .csv for an extension in its name and the “Save as Type” has “All Files” in the dropdown box. Save the file.
5. Start the Import Wizard in Salesforce and select your file to Import and the Encoding in the drop down list . This could be either in UTF-8 or UTF-16 format, depending on the selection you used when saving the CSV files.
6. Import the file and check the results. This should work just fine.
Even though the CSV file was not actually comma delimited (it was saved as tab delimited in step 1 where it was saved as ‘Unicode Text’) Salesforce was able to import it properly. So this works ….