+ Start a Discussion
Deepika kmDeepika km 

Visual work flow - Activate button is missing


I just created a visual workflow and tried to activate but couldn't get the "Activate" button anywhere.
Could some one please guide me.

Thank YouActivate button missing in Visual Workflow
SonamSonam (Salesforce Developers) 
When you click on the name of the flow - you should get the activate option as defined here:https://developer.salesforce.com/docs/atlas.en-us.salesforce_vpm_guide.meta/salesforce_vpm_guide/vpm_admin_activate.htm
Pls check
Deepika kmDeepika km
Hi Sonam,

Thanks for reply,
But even on click of the name also not found that activate button.
Please find the below screenshot for reference.
User-added image
Thank You
subrata sahoosubrata sahoo
Did you find a solution for this. I am also having the same problem. I don't see any activate button to active the flow.
SonamSonam (Salesforce Developers) 
Thats because your flow is still in draft stage(as seen in the status) - open the flow to see if it has any steps - remove the steps as a flow cannot be activated if it has steps.

Once you remove the steps - you will see the activate link for the flow.
I had the same issue when I started using Flow and it was because I had not set a start element (option at top right hand corner of each element next to edit and bin).
Febrian Tarigan 9Febrian Tarigan 9
I got the same issue but already solve it. Check it in your visual flow, hover your mouse to your flow and then you can see pencil, trash bin, and green circle icon. Click the green circle icon if you want to make it start step. It will change Draft to Inactive then you can active your visual flow in visual flow list. Hope it helps. Thanks
User-added image 
The error message you get is quite self-explanatory.

When you attempt to save your flow, there should be a warning sign saying for example "you did not set a start element" as such below :

User-added image
Michael Bobee 4Michael Bobee 4
My flow designer won't let me set a start element.
Tharanga pereraTharanga perera
I also had same problem when i was doing my Trailhead challanges, go to flow designer section and explore your all the component, then check with your error message. Ex: if there any invalid formula this error message can be displayed, fix the formula erro, once you fixed it, your status will be changed to Inactive.
Jerad MeidingerJerad Meidinger
My error occurred because ONE of the Record Updates had been typo'd to tray assigning the BillingCity to two different screen input fields. False alarm. Deleting my old post. After fixing the error/warning, Activate is now an available option.
Aaron BishopAaron Bishop
I'm not seeing the Activate button, and my flow for sure has a starting element. Any ideas?

User-added image

User-added image

Scott McClungScott McClung
I ran into this issue because I had duplicate input/output attributes selected on one of the nodes.  As @victomg8 mentions, there should be an activation warning displayed when saving the version. 
namarata voranamarata vora
Hi @Aaron Bishop,

You are possibly not getting to activate your flow is because, there is a duplicate operation/assignment you might be doing in the same component. For eg. in my case I was trying to create a record and in that node, i was trying to assign same field twice, with different values.
User-added image
Pete Offerman 3Pete Offerman 3
Hi all!

I realize this is a somewhat old thread, but I just ran into the same problem while working thru a Trailhead with slightly incomplete instructions.  Fortunately, there's a very simple solution.  First, here are the incomplete steps for "Activate Your Flow" from Trailhead:

Trailhead Steps

Apparently with updates to the interface, Step 3 in Trailhead should now read, "Find the approprate version of the flow and click on the Flow Label link."  See below screenshot:

Missing step

After clicking on the flow label link, you get the "Activate" option in the Action column.

Erica PerezErica Perez
Hi Pete, 

Are you in Lightning or Classic?  I created the flow while in Classic and was unable to activate.  Once I clicked into the Lightning UI I was able to complete the trailhead.
Pete Offerman 3Pete Offerman 3

I was in Lightning Experience at the time...  In general, for any given unit, whenever you see an "Attention" box that indicates which interface to use, I'd recommend staying in that interface for the rest of the module (unless otherwise instructed in a subsequent unit).  If you double-back to the "Choose the Right Automation Tool" unit of that module, it indicates the that the module is designed for Lightning Experience (see screenshot)...  Make sense?

User-added image

Yuvaraj s 25Yuvaraj s 25
Hey guys I finally found it . Its because of your org button and actions are rolled out . 
TO recover
in setup , Lightning transition assistant in optimize phase there's a option to scan for javascript button and action , run both scan , It takes 30 mins to complete the scan . After completion ,all buttons and actions are recovered and activate works.