function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Art SmorodinArt Smorodin 

Error while creating custom Task field.

Hi All, 

looking to see if anyone else had this problem before. I am trying to crate some new custom activity fields. We were somewhat close to the limit, so before creating new custom formula type fields I removed a few unused/redundant fields from the Activity object. Now, we have more than enough fields available but every time I try to create a new formula field i am receiving and error message: 
Unable to Access Page
The value of a parameter contains a character that is not allowed or the value exceeds the maximum allowed length. Remove the character from the parameter value or reduce the value length and resubmit. If the error still persists, report it to our Customer Support team. Provide the URL of the page you were requesting as well as any other related information.
Any idea what might be cuasing this? 

I saw some post saying that it might be due to Roll-up Summary feilds, but it has been more than 72 hours, surly by now they should have completed re-calculating. SF support has not responded yet so I an asking you guys. 

Please help. 

James WooleyJames Wooley
Have you completley erased the deleted activity fields? Go to the list of activity fields, scroll to the bottom, and click on deleted fields. Then erase the ones you no longer need.

If this doesn't work, could you show me the name you are trying to give your new field, along with the formula expression you are trying to set?

Art SmorodinArt Smorodin
HI James, 

Yes I have erased those fields from the Activity Custom fields section.

As far as the name goes, it does not matter, I tried calling it simply "Test" and it still fails. I do Formula of type Text: Account__r.Emergency_Contact__c (we have Lookup(Account) field on the Activities).

James WooleyJames Wooley
Hi Art,

I wasn't aware that you could have custom lookup fields on Activity, but it looks like you can through a beta program:

As this is in beta, I suggest you wait for a response from Salesforce as it may be an issue with this new functionality.

Does a formula field without cross-object functions work? If so, I'm sure the issue must be due to the custom lookup field.

Mike ArthurMike Arthur
Hi Art,

Did you get this resolved?

I just had the same error message when attempting to create a custom formula field on Activity and assumed it was to do with the owner cross object lookup but as I too was at the limit of 100 custom fields I guess it's that.

I was at 100 custom fields, deleted 13 and erased 1 to allow me to create the one that I am trying to create.

Any update much appreciated!

Art SmorodinArt Smorodin
Hi Mike, 

in the end nothing worked. After Deleting a field and then erazing it from the Bin I was still getting that error messege. 

I ended up opening up a case with support and I think they has to Hard Delete the field form our DB. Only after that I was able to add ned fileds to the object. So, it almost looks like a bug to me. 

Mike ArthurMike Arthur
Thanks Art, you just saved me from a ton of poking around and frustration. Much appreciated 😊 Mike. Sent from my Windows Phone
Hi. Hopefully this helps some else that may have this issue.

I have just experienced this same issue in my Sandbox and worked with Salesforce support to figure out the reason. 

We have hit the 100 custom field limit in our org for events. So when I deleted a field, emptied it out from the recycle bin and tried to load a new one, I got this same message. 

According to Salesforce Support, even though you delete it from your recycle bin and you can't see it, those fields aren't immediately removed from the backend of their system (and still count against your limit).  Clean up processes  wil eventually move them from Production, but in Sandbox, those cleanup process do not run on a regular basis. 

When support finally cleared them out manually I was able to add the new fields.

Stéphane RaviartStéphane Raviart
Dear Salesforce colleagues,

I actually do train in trainhead website and I'm in step where I have to work with Schea Builder ( I have the same error when I create object. I tested with many combination of name, label parameters. Here, my screen :

User-added image

User-added image

Is someone can help me about this error ?

Hello, this is an old post but wanted to throw some new information I've learned to the community. I've run into this exact error on the Activities object in 3 different orgs, but this time when it was resolved I asked a few more questions from SFDC support that gave me some answers I haven't seen anyone posted or blogged about on this issue.

The issue:

On the Activities object when you hit the field limit you can no longer add new fields. When you delete and then completely erase fields, on your side, it appears that you have the capacity for more fields, but you get the error telling you you are at capacity. 

The solution:

Log a case with Salesforce support to do a physical delete of the deleted fields on the Activities object. Depending on the size of the org and whether or not you've paid for premier support this could take a couple of days to a month. This last case for my org took about 3 weeks for Tier 3 Support to finally do it.

What I learned this time:

I asked Tier 1 Support at Salesforce to explain to me why this was such an issue with the Activities object specifically. Many of you know that there are a number of quirks with the Activities object and I figured this was just one of them, so I was trying to learn how to avoid it in the future.

What I learned was that this is not an issue related specifically to the Activities object and it is not a quirk at all, this is the standard protocol when an admin hits the field limit on any object, Standard or Custom. I believe, the reason why there are multiple community posts about this issue specifically on the Activities object and not any other object is because the field amount limits are lower (100 vs. 500) and more people have hit their limit on Activities than anything else.

Basically, if you exceed the field amount limit on any object, you cross a threshold on the back-end that requires a physical delete of fields by Salesforce support, otherwise, you're stuck. If you never hit that field amount limit, you won't run into this issue.

I have never hit more than 500 fields on any object, so I cannot speak to the validity of the explanation. But I was assured by Salesforce that this is the case. 

When I started my Salesforce case I had a capacity of 4 fields because I deleted them to make room, but couldn't add any more. My concern was that if I, from an amount of 96 fields, deleted 5 more fields, but added 5 more after, I would run into the same error. I have now tested and found this is not the case. So, if you ensure you never hit that max limit on fields, (makes sense to think this applies to all other limits for objects), you won't see this issue happening.