• Xifier
  • 0 Points
  • Member since 2007

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 11
We are running a relationship SOQL query (Account and Contact) which both have a FAX field.  We have tried to alias the field names to distinguish the two fields without success.  In the queryresult set, we can correctly reference one field through the "FAX" field name.  Question:  How do we reference the other FAX field?
Also, if there is a good SOQL reference, could you please point us in the right direction. 
Thank you.

Hi There-

I’m trying to use the Case Detachifier application.

I want to back up to an FTP site, but that option isn’t working. I’m on Windows XP SP2. I’m certain the FTP login credentials I’m using are correct.

Below is the complete text from this error dialog:

This happens no matter what FTP server I try to connect to, and, as shown in the other screenshot, it just endlessly tries to test my FTP connection.

I’ve confirmed that my firewall program (Windows Live OneCare) IS allowing the salesforce.com Case Detachifier. I’ve tried rebooting my machine a couple times, but continue to get the same error.

What’s wrong here? Any suggestions?


Gabe Anderson
Director of Customer Support
- The Global Leader in Rapid E-Learning

See what the experts are saying about Articulate:



See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.


************** Exception Text **************

System.UriFormatException: Invalid URI: The format of the URI could not be determined.

   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)

   at System.Net.WebRequest.Create(String requestUriString)

   at Detachifier.SalesforceData.TestFtpServer()

   at Detachifier.SaveScreen.btnNext_Click(Object sender, EventArgs e)

   at System.Windows.Forms.Control.OnClick(EventArgs e)

   at System.Windows.Forms.Button.OnClick(EventArgs e)

   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)

   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

   at System.Windows.Forms.Control.WndProc(Message& m)

   at System.Windows.Forms.ButtonBase.WndProc(Message& m)

   at System.Windows.Forms.Button.WndProc(Message& m)

   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)



************** Loaded Assemblies **************


    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll



    Assembly Version:

    Win32 Version:

    CodeBase: file:///C:/Program%20Files/salesforce.com/Case%20Detachifier/Detachifier.exe



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Deployment/



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Web.Services/



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/



    Assembly Version:

    Win32 Version: 2.0.50727.42 (RTM.050727-4200)

    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/



************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging



For example:



    <system.windows.forms jitDebugging="true" />



When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.


  • February 16, 2007
  • Like
  • 0
Errors include:

Error    105    'Id' is not a member of 'basicSample_vb.sforce.Account'.    C:\Salesforce\Samples\AppExchange Developer Network\Visual Basic .Net\basicSample_vb_2005\Samples.vb    290    13    basicSample_vb

Error    110    Type 'sforce.sObject' is not defined.    C:\Salesforce\Samples\AppExchange Developer Network\Visual Basic .Net\basicSample_vb_2005\Samples.vb    362    58    basicSample_vb

Warnings include:

Warning    1    Type 'urn:enterprise.soap.sforce.com:ID' is not declared.    C:\Salesforce\Samples\AppExchange Developer Network\Visual Basic .Net\basicSample_vb_2005\Web References\sforce\enterprise.wsdl    9    12    basicSample_vb

Warning    102    Custom tool warning: Schema validation error: Schema item 'simpleType' named 'FaultCode' from namespace 'urn:fault.enterprise.soap.sforce.com' is invalid. The Enumeration constraining facet is invalid - 'fns' is an undeclared namespace.    C:\Salesforce\Samples\AppExchange Developer Network\Visual Basic .Net\basicSample_vb_2005\Web References\sforce\Reference.map    1    1    basicSample_vb

VS doesn't like the reference.map file at all:

<?xml version="1.0" encoding="utf-8"?>
<DiscoveryClientResultsFile xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <DiscoveryClientResult referenceType="System.Web.Services.Discovery.ContractReference" url="file:///C:/Salesforce/WSDL/enterprise.wsdl" filename="enterprise.wsdl" />

The problem appears to be in the definitions section of the wsdl.


    <xsd:schema xmlns="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified" targetNamespace="urn:sobject.enterprise.soap.sforce.com">
      <xsd:import namespace="urn:enterprise.soap.sforce.com" />
      <xsd:complexType name="sObject">
          <xsd:element minOccurs="0" maxOccurs="unbounded" name="fieldsToNull" nillable="true" type="xsd:string" />
          <xsd:element minOccurs="0" maxOccurs="1" name="Id" nillable="true" type="tns:ID" />

If I change the highlighted lines to the following,  the green line above becomes valid and the errors go away. All I get is a message saying that
"Warning    1    The 'http://www.w3.org/2001/XMLSchema:definitions' element is not declared. "

<definitions targetNamespace="urn:enterprise.soap.sforce.com"

I don't know a whole lot about wsdl files and namespace declarations, but something funny is going on here. Would VS 2005 be requiring different references ? I downloaded the sample applications including related wsdl, which had the same problems as my generated one.

Has anyone had any success with CTI (Computer Telephony Integration). If would be extremely beneficial to users to have call center features such as bringing up a contact from a phone call. However, reading the Skype App reviews it seems that it is only for opportunities and got a fully developed solution. Another option I found is this:
However, the .de url and the fact that I could not find a mention of mirage of the salesforce appexchange very sceptical.
Please let me know of my option regarding CTI.