• pandu yadav
  • 0 Points
  • Member since 2014

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 1

I would like to know, what is the solution for this?

Does the support team have no time to look at it or it can not be solved?
I tried to call the salesforce support team but couldn't get the help due to having no premier account.

Is there any other solutions for this?

Please help me...

Insert failed. First exception on row 0; first error: STORAGE_LIMIT_EXCEEDED, storage limit exceeded: in salesforce,this error while i am inserting record ,this is inserting code is working in enterprise edition,this code i have moved to Developer edition,but this is not working in developer edition

So, I believe i have found what appears to be a bug with the new Dynamic Visualforce Binding. I created a case with all the information, but unfortunately since i don't have 'premier' status, Salesforce will not even take a look at the issue. Therefore, I am reaching out to my awesome force.com developers out there to see if anyone else has encountered something similar. Maybe i will get lucky and find someone with 'premier' status to help out.

Here's the situation: I have built a Visualforce page with a component that contains an apex:datatable. As part of the datatable definition, I have a set of dynamically defined columns. In each column i have an apex:outputField that uses Dynamic Visualforce Binding to specify the value:

<apex:outputField value="{!pos.Obj[col.FieldName]}" />
    where 'pos.Obj' represents the row object and
    'col.FieldName' represents the API name for the associated field.

If the FieldName is a field directly on the object (example: FirstName), everything works fine in all situations.

If the FieldName is a field from a referenced field on the object (example: Owner.FirstName or ReportsTo.Email), then salesforce will throw an 'Insufficient Privileges' error if there are records in the list where the referenced item is null. If all records in the list have a value in the referenced field, then the list displays correctly.

To illustrate: if the FieldName is 'ReportsTo.Email', then if all Contacts in the results list have a value in the ReportsTo field, the page displays correctly.

If any one of the Contacts in the results list has a null value in the ReportsTo field, then the page displays an 'Insufficient Privileges' error.

Seems to me they have an issue binding to field values on a referenced object when that referenced object happens to be null for a particular record.

Thanks in advance for any help/assistance you can provide.

  • July 14, 2012
  • Like
  • 0