• Janette Mosher 6
  • 0 Points
  • Member since 2015

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 1
Relevent part of the flow error is below.

RECORD UPDATE: UpdateAsset_Owner
Find all Asset records where:
Original_Order_Number__c Equals {!varOriginalOrder} (VTM00581)
Original_Order_Number__c Is null false
Update the records’ field values.
AccountId = {!varAccountId} (0010W00002JWImS)
ContactId = {!varContactId} (0030W00003UFi1K)
Failed to update records that meet the filter criteria.
Error Occurred: This error occurred when the flow tried to update records: An unexpected error occurred. Please include this ErrorId if you contact support: 2123312155-27997 (-548403183). For details, see API Exceptions.

Support was no help as we do not pay for premium support. Any suggestions would be appreciated.
I want to replace the New button on a related list in Console. Opening the new record in edit mode as a subtab. I am populating some fields on the child record. See code below.
The new record is created fine with the fields populated correctly, however the new record replaces the existing primary tab and does not open in edit mode. Suggestions?


var pl = new sforce.SObject("Proposed_Labor_Line_Item__c");

pl.Proposed_Work_Order__c= "{!Proposed_Work_Order__c.Id}"

var result = sforce.connection.create([pl]);
if (typeof(srcup) == 'function') 
{srcup(window.location = "/" + result[0].id);
} else {
window.location = "/" + result[0].id;

alert('Could not create record '+result);
I have a flow with "GetRecords" where I use a custom field to query the Account records. When I run the flow, it returns me Flow failed to fetch records even though there are records available with the custom field value.

I tried the SOQL with the same custom field and the results are coming.

I updated the flow to read using the record ID field and the flow ran successfully, but not working with the custom field.

Here is my flow

User-added image

User-added image

Here is the debug log
User-added image

Note: The same flow works on my other orgs, but it is failing for this org.