• Oleg Rebenko
  • 5 Points
  • Member since 2015

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 2
Hi guys,

Any idea how to enable Individual object ("Make data protection details available in records" checkbox in Data Protection and Privacy) for Scratch Org Definition File? I didn't find any appropriate value for "orgPreference" attribute in Salesforce documentation.

Thank you in advance!
Hi all!

I want to use SLDS styles in component without uploading from static resources and as I know it is possible if I use extends="ltng:outApp" in app where component exposed as dependency:
<aura:application access="GLOBAL" extends="ltng:outApp"> 
    <aura:dependency resource="c:myAppComponent"/>

But when I removed styles="{!$Resource.SLDS + '/assets/styles/salesforce-lightning-design-system-ltng.css'} from my component I found that styles not applied.

How can apply SLDS styles in component using ltng:outApp?

Thank you,
I am trying to deploy the xml package for Customer_Interaction__b.object using the workbench for this unit. However I deploy and get success message in workbench but cannot see any big object.
  • I did see on the unit page it says that the examples are written for api unit 41.0 but my workbench doesnt allow me to go beyond 40. Does this matter?
  • My trailhead playground is on winter 18.
  • Does it matter what the file name for the object and permission set? (I do have the package.xml)
  • I have tried with and without having 'Single package' selected in workbench deploy
  • I have double checked the workbench is logged into the correct org
User-added image
User-added image


I wish to include :-
<script src="http://maps.google.com/maps/api/js?sensor=false" type="text/javascript"></script>
extenal library for Google maps in a lightning component.

It doesnt allow me to do so , it gives me the following error:-
Content Security Policy: The page's settings blocked the loading of a resource at http://maps.google.com/maps/api/js?sensor=false ("script-src https://ap1.lightning.force.com https://ssl.gstatic.com chrome-extension: 'unsafe-eval' 'unsafe-inline'").

I tried loading this script asynchronously as well , by creating dynamic <script> tag and loading the src. Still doesnt work.

Kindly let me know how I can get Google Maps to work in a Lightning Component.

Thanks in advance