• Sumeet_Force
  • 595 Points
  • Member since 2014
  • Salesforce Specialist

  • Chatter
  • 17
    Best Answers
  • 3
    Likes Received
  • 2
    Likes Given
  • 15
  • 182
Did anyone experienced this error on Build an Account Reassignment Wizard? I cheched everything 100 times...thx!

Send Email element 'Send New Account Notification' isn't properly configured. Check the instructions."
Hi All

I am getting the below error while doing the below challenege

Challenge Not yet complete... here's what's wrong: 
The validation rule name 'Close_Date_Alert' was not found.

Please help me to slove it ?

I simply look at the release notes. But the release notes has 300+ pages, so complex!
Every version provides some new features or modifies some features, for example add a new field for account object.
My questions are:
1. why let administrator modify the page layout to enable a new field or button, why not been enabled by default?
2. what changes are enabled by default, what changes depend the administrator's configuration?
I need to test API using tial account. To get consumerKey & consumerSercret I need to create a Connected App. Spent whole morning reading tutorials and forum, but I can never see "New" button. Feeling very frustrated. Hope I can get the answer today.

Thank you.

Hi all,
I am trying to know how to convert text to number but from the 5th value.
I know that "value(Text__c)" converts it to number
Text__c: 00101100
If a use the formula "value(Text__c)" this will deploy 101.100
but I would like to deploy 100

how can I do that? any example would be realy nice

Please don't answer this question with code. I can find code online. What I need help with is more basic than that.

The "Implementing Global Actions with Visualforce Pages" challenge asks you to create a page with your user info on it, then add a field to enter an email address so that you can click a "Send" button to send the page to that email address.

Assuming I need to write APEX to send the actual email, what do you think I should send in the email? Is there actually a way to embed the page in the email, or do you think they're just asking for the same content (my user info)? Has anyone actually completed this challenge? It seems really vague to me.

I have entered 5-6 email Id  randomly in to address. 
How to send mail to above email id. 

Sample code plss
Hi everyone,
I want to know if it is possible that an object can only have a record created by day depending on some criteria

Object: "OD__c"            Custome Field: Date__c, Suc__c.

this Object has already a record created today called
Name: OD-001     02/Feb/2016         Suc: Central

so if I try to create another one with the same values I would like to get an error
Name: OD-002   02/Feb/2016          Suc: Central

can this object be validated if it meet the criteria 
If (Date__c==Today() && Suc__c == "Central")

Hello Community, 
I'm working on the "Setting up Lightning Connect - Pb with API Trailhead Module and after submitting the Check Challenge I've received this error below:

"Challenge Not yet complete... here's what's wrong:
There was an unexpected error in your org which is preventing this assessment check from completing: System.ExternalObjectException: data.api.DataSourceException: This data is no longer available. The "Phone" table in the external data source is currently unavailable. Try again later or contact your administrator for help."

Has anyone come across this error, or have any ideas on what the issue is or on how to proceed to complete the challenge. Thanks.
I see that there is a similar question here: https://developer.salesforce.com/forums?state=id#!/feedtype=SINGLE_QUESTION_SEARCH_RESULT&id=906F0000000ArVTIA0
But it doesn't look like it was ever properly addressed.
It also looks like the interface for the back-end has changed a decent amount since then.

I found a good guide for starting PHP development:

But I can't figure out how to enable the API on my account nor how to retrieve the security token.
I have a requirement to implement short polling using JS Remoting.  I've looked into long polliing using the streaming API but it does not seem like a reliable solution for my use case.  I would like to poll the server every X minutes.  Is there a limit to the number of SOQL queries that can be executed?

I have an acticity which is not getting reflected in the Report for some people.
This activity has "Name" field missing.

Is it possible that this could be reason ?
  • February 01, 2016
  • Like
  • 0
Hi I want to add bulk apex classes and vf pages to new permission set. There are more than 500 apex classes, and vf pages to be added to permission sets. there are 10 permission sets. it takes lot of time for adding them to PS manually. Is there any automatic process to them to PS

Hello All
I am trying the exercise "Implementing Global Actions with Visualforce Pages" in the trailhead module module.  
The exercise mentioned "Your users have asked for a quick way to share information about themselves with their clients from their mobile phone. Create a global action in Salesforce1 to display information similar to a user's business card (first and last name, email, phone, and title).
The global action must be labeled 'My Business Card'.
The global action must reference a Visualforce page named 'BusinessCard'.

I have created the global action and named with the label correctly as "My Business Card".  However, I am now getting an error as below
"Challenge Not yet complete... here's what's wrong: 
The 'My Business Card' global action wasn't found."

We cannot create an action with the name having spaces as in "My Business Card".   

What am I doing incorrectly.  Please suggest.

I have Standard objects Accounts in relation to Contacts.
Account has 4 record types. I want to seperate one of them to new object.

I want to create new object AccountX which is duplicate of Account and also link AccountX to contacts.

What are best steps (or process) and loopholes I will have in the process

Thank you for suggestions.
  • January 19, 2016
  • Like
  • 0

We are trying to retrieve custom app setting using SOQL via Partner API and able to retrieve all information except default selected app for particular profile. We have googled it but didn't find any info around this.

Below objects have been used to retrieve custom app setting:
  + AppMenuItems: To retrieve app name
  + SetupEntityAccess & PermissionSet: To find out whether an app is visible to a profile 
We didn't find any field that has this info whether an app is a default app for a particular profile or not .
Query: Any idea which object would have this info?
Any pointer around this would be helpful. 

Thanks in advance ! 
How to enable Enable Salesforce IoT Explorer Edition when its not appearing in Set up in Winter 18 release ? I tried in trailhead playground which are usually on the later version and also by getting latest instance from salesforce which had all other IOT services enabled  or accessible except IOT explorer. Pls suggest.
I am trying to install and run Salesforce Identity on a Windows Server. The setup.sh file is running file. However the startup.sh is unable to find the launcher.jar file and even if we modify the sh file to point to correct jar file, it then results in below error:

Exception in thread "main" java.lang.NoClassDefFoundError: org/osgi/framework/Bu
        at org.forgerock.commons.launcher.Main.main(Main.java:44)
Caused by: java.lang.ClassNotFoundException: org.osgi.framework.Bundle
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 1 more

Since forgerock is a seperate product, not very issue if this needs to be taken up with Salesforce or separately with forgerock for resolution. Any suggestions truly appreciated to help me move further on this.
Below is code snippet of C# for getting signed key for authentication to AWS:

static byte[] HmacSHA256(String data, byte[] key)
    String algorithm = "HmacSHA256";
    KeyedHashAlgorithm kha = KeyedHashAlgorithm.Create(algorithm);
    kha.Key = key;

    return kha.ComputeHash(Encoding.UTF8.GetBytes(data));

static byte[] getSignatureKey(String key, String dateStamp, String regionName, String serviceName)
    byte[] kSecret = Encoding.UTF8.GetBytes(("AWS4" + key).ToCharArray());
    byte[] kDate = HmacSHA256(dateStamp, kSecret);
    byte[] kRegion = HmacSHA256(regionName, kDate);
    byte[] kService = HmacSHA256(serviceName, kRegion);
    byte[] kSigning = HmacSHA256("aws4_request", kService);

    return kSigning;

Could someone please provide corresponding code in Salesforce using SFDC Security class like Crypto etc ?

The signed key needs to be the same be it run via the .Net C# code or the SFDC Code.

Thanks !
I am trying to run amazon SQS service via apex. However the signature validation at aws doesn't work and results in following error.
The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details.
I have verified the credentials and they are good. Not sure whats causing the issue. I have reference the code from this post.

Please assist.

I am trying to delete classes from Production and facing an odd issue. The workbench post deployment shows success however the class is still there in Production. I tried multiple attempts but no success.I am passing my zip file along with a test class name in the deployment settings page in workbench. Has anyone faced this issue ? If yes, please assist.

Are the winners of the Salesforce trailhead contest announced that was supposed to end on 9  Feb 2017 ? Not sure if prizes are actually distributed. So asking this one. If announced, please share the winners list.
URL: https://trailhead.salesforce.com/project/flow_reassign/flow_reassign_implement

Project: Build an Account Reassignment Wizard
Unit: Implement the Flow with Visualforce

As per the challenge, assigned 2 users with Salesforce license and third user with Salesforce Platform license. However with Salesforce Platform license the only available profile is Standard Platform User which gets applied. I believe that is also the reason I am unable to validate this challenge.
I have a VF page and some apex code in related controller. The VF is ran by a user having limited access based on his profile. However the code tries to update a contact which results in a privilege error and says [Update access denied for Contact] which seems an issue for currently runnign user. This is fine as user profile doesnt allow him to edit/update Contacts. However if I have not used [with sharing], then ideally it should run in System mode which is somehow not happening. Can someone pls help by pointing out issue  or some direction pls ?
I am working through steps mentioned in Salesforce1 Mobile Developer Guide and stuck at a point where I need to host and run the canvas app in chatter.
All config steps are done and I am getting an error within chatter when trying to run the app.

The error (displayed in pop up) is:

First make HTTP POST to "/" w/ Salesforce signed-request. HTTP GET to "/" is not allowed.

I was able to find 1 post on the internet relating to this problem but the solution was domain enabling which I already have done long back. So that is not the solution. Looking up possible solutions to this problem.
I have some issue with performance in Salesforce1 app and so tried reinstalling it. I removed it first. However when I try to download it again from playstore it exactly gets stuck at 20.50 MB i.e it downloads 20.50 MB out of 22.19 MB and doesnt proceed ahead. I have ensured its nothing to do with disk space Any suggestions on what might be the cause and how to resolve it?
The trailhead project is title is something that I have completed and even data is correctly updated as provided in the module. Still the module doesnt show up as complete and results in error:

Step Not yet complete... here's what's wrong: 
The 'Tim Barr' contact record was not updated correctly in Salesforce. Please check your Heroku Connect setup. 
Note: you may run into errors if you've skipped previous steps.

I could clearly see that my change in updated heroku app traversed to SF Org and updated the required fields. But still I see below error.

Moulde URL:
Below code results in an error in the console [Uncaught ReferenceError: Visualforce is not defined]:
<apex:page >
<script type="text/javascript">
    Visualforce.remoting.timeout = 120000; // Set timeout at page level

Please help. I have tried this in namespace or namespace free org both. But error prevails.
I am checking on the Canvas functionality for integratin external apps. However , on loading the initial page of the application, I observed that no headers /property like signed_request is found within the response of the pages. I have checked all possible responses via Fiddler to try identifying the signed_request. It however was not found. Anything that I am missing ? Or anything that needs to be done additionally to find the signed_request in the responses ?
When will the winners for August 2015 trailhead be announced? Its been more than a week and so not very sure if winners are going to be announced or not...
Can someone pls answer from SF team?
I got this error while performing this challenge:

Challenge not yet complete... here's what's wrong: 
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: TDRLLFFO

The challenge looks simple and I dont see any mistakes from my end. There was custom configured pre-existing link which I deleted to avoid any conflicts. However still the error exists.

Switching to a new DE will not carry my other trailhead points over and hence looking for assisting in this Dev Org itself.
Are the winners of the Salesforce trailhead contest announced that was supposed to end on 9  Feb 2017 ? Not sure if prizes are actually distributed. So asking this one. If announced, please share the winners list.
When will the winners for August 2015 trailhead be announced? Its been more than a week and so not very sure if winners are going to be announced or not...
Can someone pls answer from SF team?
Hi All,
           I am unable to trace out how the field was shown on the chatter feed tracking, eventhough we don't havethat  field on the opportunity. We don't have Net Revenue field on the opportunity but the chatter feed tracking shows field update value on opportunity record detail page whenever updating the record. Any one suggest me the reason why it is happen? How do we trace out the cause?
Hi Friends,

Please help on below Trigger. I am trying to insert Quote when the attachment is added to Opporunity and the file name contains PDF.

trigger oppattachment on Attachment (after insert, after update) {
    Set <Id> oppIds = new Set <Id>();    
    for(Attachment attach : Trigger.new) {
        if(attach.ParentId.getSobjectType() == Opportunity.SobjectType) {
            if(string.valueOf(attach.Name).contains('.pdf')) {
    List <Quote> quoteList = [SELECT id, name, opportunityid FROM Quote WHERE Id IN: oppIds];
    for(Attachment attach : Trigger.new) {
        if(quoteList !=null && quoteList.size()>0){
            for(quote q : quotelist){    
                q.name = attach.name;       
            insert quoteList;

I am having the developer console fail on me often enough (as described in Salesforce Help) that I got tired of using Workbench to fix it, and I wrote a Visualforce page that uses https://jsforce.github.io and the Tooling API to do the trick.

My source code is here: https://gist.github.com/bolaurent/65e3f59ac81ee2587a7d67a2d372996e

There's one issue that is bugging me. When you press the "Delete my IDEWorkspace" button, the delete operation works correctly, but the page refreshes, and it complains that it cannot find the user's IDEWorkspace (because it has been deleted).

Why is this refresh happening? How can I prevent it?

Hi Guys,

We have reuirement to get the picklist values in a custom field usinf APIs.

I have tried this

 /services/data/v41.0/tooling/query?q=Select+MetaData+From+FieldDefinition+where+EntityDefinition.DeveloperName='Lead'+AND+FieldDefinition.QualifiedApiName='customfield Name'

But this is giving me a massive response to parse.

Is there any other easier way to do this?

Every time I create an Account object, within a few days all the data associated with that Account's Membership fields gets erased. I added tracking of Activity History for Account objects, and I can see that the Membership data supposedly gets erased by one of my coworkers. However, this coworker is not actually entering Salesforce and editing any data. I think the problem is an Apex trigger that was created by said coworker. The only Apex trigger we have is indeed created by this coworker, but I don't know how to delete the trigger. The only option I seem to have is to uninstall the package associated with this Apex trigger. That package is the "Nonprofit Success Pack," which I am hesitant to uninstall because it seems like it might be an important package. Also, I am sure there must be an easier way to remove or edit the trigger without removing the package. Any suggestions? 

Thanks in advance!
"Challenge Not yet complete... here's what's wrong: 
There was an unexpected error in your org which is preventing this assessment check from completing: System.DmlException: Insert failed. First exception on row 0; first error: STORAGE_LIMIT_EXCEEDED, storage limit exceeded: []"

Getting this error message when trying to check challenge. This is Automate Basic Business Processes with Process Builder module in Trailhead. I followed the steps suggested by people to check storage from system overview area. I checked that and found I have lots of storage available. Only 350 KB out of total possible of 5MB, which is only 6% of total availa storage. so 94% is free.

When I click on 350 KB and check storage usage, everything looks okay except File storage which is 112% used. Content bodies have used 99% of available storage.

Can somebody please advise what should I do. and if I have to reduce file storage how can i do that.

Thanks in advance.
Hi, I have no prior experience in coding so I'm wondering if it's possible to execute a Visual Flow after deleting a record from a trigger? If so how can I do this?
Hi All,

I need to write trigger on contact object.
My problem is whenever i change the account name from in existing contact record then all account name should be changed related to contact object record like case and task. Example Case record and Task record account name should be changed whenever i change account name on contact record.

Can I hide a Date field based on selection of picklist value in a different field.
Dear All,

I need some help in making a Rest Api Call Out.
When I execute the below code in Execute Anonymous Window, it works fine.

Http http = new Http();
HttpRequest request = new HttpRequest();
request.setHeader('Content-Type', 'application/json;charset=UTF-8');
// Set the body as a JSON object
request.setBody('{ "company_reg": "06587726"}');

HttpResponse response = http.send(request);

if (response.getStatusCode() != 201) {
    System.debug('The status code returned was not expected: ' +
        response.getStatusCode() + ' ' + response.getStatus());
    System.debug('Response ' + response.getBody());
} else {

But when the tried to put this in a Apex class, its not working. (status code == 500)

public with sharing class ProvenirCsCallout {
    @future (callout=true)
    public static void sendRequest(Id accid, String comp_reg){
        Http http = new Http();
        HttpRequest request = new HttpRequest();
            request.setHeader('Content-Type', 'application/json;charset=UTF-8');
// Set the body as a JSON object
            JSONGenerator gen = JSON.createGenerator(true);   
                gen.writeStringField('company_reg ', comp_reg);
                String jsonS = gen.getAsString();
           // request.setBody('company_reg='+EncodingUtil.urlEncode(comp_reg, 'UTF-8'));

            HttpResponse response = http.send(request);
            if(response.getstatusCode() == 200 && response.getbody() != null){
               String strResponse = Response.getBody();
                } else {

What I am missing ???

Apex / Visualforce
SubjectCannot see an active flow in the Set Up Flows section, need to deactivate that flow
DescriptionWe are getting an error while adding new contacts or editing the existing contacts.

The reason for this error is the flow with this ID – 301390000004YNI.
I cannot see this flow in the Flows section of Set Up

However, if I open the link for Flow Designer with this Flow ID - 301390000004YNI, I can see the entire Flow process.https://sitespect.my.salesforce.com/designer/designer.apexp#Id=301390000004YNl

This flow is currently active, so I’m not able to make any changes to this flow.
I just want to Deactivate this flow, which is only possible if I can see it in the flows section of Set Up.
Severity LevelLevel 2 - Urgent
Business ImpactWhat functionality are you unable to perform?
Create/update New/existing Contacts
How many users are impacted?
Sales and Customer success team
Are the impacted users internal/external?
Is there currently a workaround in place?
Is there a pending deployment / go live?
I have a kind of URL hack in a formula field that Im using to present a button on a page.  In this forumula, i'm calling a flow that will simply update a status, then return the user to the original record and update the field so that it no longer shows the button.  This is built out in the sandbox and was working perfectly up until last week and I have not made any changes to the fields so i have no idea whats happening.  As it is now, when the user clicks the button, the flow will complete successfully but i'm not being redirected back to the original record.  I just remain on the 'Your flow finished' page.  Below is the formula field, and it appears there are issues with the return URL portion of it.  Any assistance would be apprecaited.

Here's the formula (this is firing on a custom object 'Request')

F (ISPICKVAL ( Status__c , "Draft"), 
HYPERLINK("/flow/SubmitButtonUpdate?RequestID="&Id&"&retURL=%2F"&Id,IMAGE("/resource/SubmitImage", "Submit to GSE Team"),"_self"), null)

I'm trying to find a way to trigger an automatic action (changing stage) with process builder when a new Opportunity (customer) is created and this Opportunity contains an existing email address in my Salesforce. This way I can control when a customer is visiting again our website asking for a quotation (when a customer asks for a quotation on the website, the info is sent from our CMS to Salesforce to create a new Opportunity with a customer email address associated to it). How can I do this process or workflow rule? I don't know how to tell the system to check for an existing email address. Is there a standard place in my Salesforce where this info is stored and you can check it with a workflow rule? Thank you for in advance for your help!
How i can insert record from vf page without using controller?

I want to updateto date field based on another object value.If my Case object having a picklist field value ABCD then in policy object i wnat to update two date fields.I will match Policy no from my case object so that it will update that exact policy start date and end date. Please help

I am a registered user and have my developer org for development purpose. When I trailhead without login to salesforce, I see two link on the pages namely "... Badges" and "... Points" where "..." is a number.  When I click on these links without login to salesforce, I am redirected to "Discussion forum"page. Is this correct behavior?

Shouldn't these information be hidden when I am not logged into salesforce? Alternatively, if these informations are coming from cookies and I am still not logged in then clicking these links should take me to login page instead of discussion forum?

I am looking forward to hear from you.


When I am not logged-in I can see the badges earned. When I click on that, I am taken to Discussion forum. Similar is the case with Points Earned link. Is this intended behavior?

When someone takes the time/effort to repspond to your question, you should take the time/effort to either mark the question as "Solved", or post a Follow-Up with addtional information.  


That way people with a similar question can find the Solution without having to re-post the same question again and again. And the people who reply to your post know that the issue has been resolved and they can stop working on it.