• el hadri oussama
  • 10 Points
  • Member since 2014

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
  • 0
Hello ,
I need help to be build a join query for a junction object , I had a junction object  StudentCourse__c that join Member__c and Course__c  Objetcs , I want to be able to select a list of studentCourse based on a list of members and courses .

the list of members : 
students= [select id, Name,FirstName__c from Member__c where 
                   id  in(select Student__C from StudentCourse__c where Course__r.Year__c= : schoolYear ) 
                   and School__c=: school and  Grade__c= :gradeclasse];

the list of courses: 
courses= [select id ,Name ,Scale__c ,Subject_Name__c from Course__c where Grade__c= : gradeclasse and School__c= :school];
to retrive one record it's easy you just call the query below but the problem is I am exceeding the limits when
I loop membres or courses  so I need a way to retrieve all the StudentCourses  whitout using a loop.
StudentCourse__c  studentCourse = [select id   from StudentCourse__c where Course__c= :course.ID and Student__c= :student.ID];

Thank you in advance
I am a JAVA | JEE & webMethods EAI software engineer with one year of experience , i am a self-taught Salesforce developer looking for my first experience in Salesforce ,i earned more than 22 badges in Salesforce Trailhead.
Please Let me know if there is any SFDC opportunities .i am very interested to work remotely on a Salesforce Development project.
Thank you ..
Contact :oussama.elhadri@gmail.com
Languages: Arab , French , English.
i have a developer edition account  and i am not able to connect to salesforce using eclipse i did  google the problem and i tried all the solution but none of them worked for me.
Note :
My User is already active and the user have an System administrator Profile and i dit force the ip range in Network Access.

so when i try to connect to Production/Developer Edition i get the error below :
User-added image
and when i try to connect to the sandbox environment i get the error below :
User-added image
i tried to access to test.salesforce.com directly from the navigateur and i get "username or password invalid"
and when i try to reset my password by clicking password forgoten i get nothing in my mail.
Could you please help me ??
Thank you in advance.