• Andrew B. Davis
  • 134 Points
  • Member since 2014
  • Developer, Consultant
  • Appirio, Inc.

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 25
I keep getting the "Challenge Not yet Complete......... Here's whats wrong"
Lightning page named 'New Account Page' does not appear to have the correct components on it.

The new record page must use the 'Header and Two Columns' template, be called 'New Account Page', and be assigned to the Account object. (Check this is done)
The page must have the Highlights Panel and Twitter components, and a Tabs component with these tabs containing these components: (Check this is done)
Activity Tab contains the Activities Component - Complete
Collaborate Tab contains the Feed Component - Complete
Related Tab contains the Related Lists Component - Complete
Details Tab contains the Record Detail Component - Compelte

Here is a screen shot, I believe I have all the items I am supposed to as well as what goes inside the components.
User-added image
Hi Guys,

I'm trying to build a lightning component which will be used on Opportunity lightning UI. The component is placed in the right panel. The component loads pretty well on any Opportunity record view.

The problem here is when I try to update the opportunity record (which comes as popup block) the component in the right panel is not getting refreshed. By this the updated values are not showing up on the lightint component.

Need to find a way to refresh the lightning component on record save.

Any help would be appreciated!! 

Lightning component consists of HTML part and JavaScript part. I can debug and test Lightning app running on browser but I don't find the way to unit test JS part of Lightning component such as controller and helper.  I think it best to test that using popular js testing tool like QUnit or Jasmine. Does someone know how Lightning developer team test their own component(ltng:xx) to enhance it's quality?

Hi guys have a
page :.
<apex:commandButton value="First" onclick="getscore('First')" />
<apex:actionFunction action="{!score}" name="getscore"  reRender="content">
 <apex:param name="myParam" value=""/>

Extension  method:

public void score() {
        string passedParam1 = Apexpages.currentPage().getParameters().get('myParam');

The method is not being called at all any help here would be appreciated
I am trying to migrate profile settings using Ant and seeing this error "Unknown user permission: CreateCustomizeDashboards". I am using API 31.0 and it seems like this is a new issue.

It almost seems like the only way around is to remove this permission and then migrate without it.

Anybody else running into this?
  • October 06, 2014
  • Like
  • 0



I have 'message'  variable in my controller.  onComplete event of actionFucntion,I want  updated value of message  variable.


Could you please tell me how to do this?


Thanks in advance.




I am trying to use the new feature in Winter Release 13 (Test.LoadData) but I keep receiving this error:

System.UnexpectedException: Salesforce System Error: 1705006492-5272 (-1190835780) (-1190835780)


All I did is added a CSV as a Static Resource and below is the CSV:

0,,FALSE,67.29559748,2328286.04,318,711881.56,32.70440252,10/04/2012,,,101242.08,0,16/04/2012,1312958.76,0.0591,,0,18.44434874,67467.41,729.6864676,0,730,0,0,0,4.203527258,318,a0AS0000004uGsTMAU,16/04/2012,-0.1957,0,303445.72,20/04/2012,2294511.37,,Stage 1: Review,46,5.417701104,6.315508869,FALSE,2024840.32,0,-0.102136164,318


And here is my code:


static testMethod void testFullCycle() {
List<sObject> ls = Test.loadData(Tranche__c.sObjectType, 'TestData_01_01_Tranche');
insert ls;



The error is reported in the first line of the function. I don't know what exactly is the problem, so if anyone can help?

From within my apex controller, how do set PageReference to redirect to an object's list view page?


The only documented way of doing this is through visualforce:


<apex:page action="{!URLFOR($Action.Account.List, $ObjectType.Account)}"/>

 However, I want to be able to do this from the controller instead:

public PageReference confirm()
	// Do prep data
	PageReference ref = new PageReference();
	// ??? redirect to object's list view

	return ref;


Hi Salesforce experts,



I have implemented Federated SSO in salesforce. i have tested login from sso login url using my ADS user  id and password and i am successful.


I tried to logging in from login.salesforce.com using my salesforce user id and password. i am successful to login from this too.


if a user is able to login throug login.salesforce.com after implementing federated sso in salesforce, there is no meaning at all for this implementation.  because SSO gives company admin to control access to all applications but here admin can not control salesforce user even after sso implementation.


I tried emplyoing a trigger on user account which changes the password everytime time user record is being updated as below so that users will not be known what is their salesforce password as shown below


trigger testtrigger on User ( before update )
       Double ran=Math.random();
       system.debug(' forgot   '+'asdfqwer'+ran);



This trigger is getting executed when ever the user record changes but the problem is when user clicks on forgot password and he reset the password , this trigger is not getting called.


at this moment, i dont have any option to enforce the users to login from sso login page.


Can anybody solve this problem.



  • June 23, 2012
  • Like
  • 0

Hi All,


when I am loading a visualforce page, I want the local system IP address to be printed on the screen .Is there any way  to do this?.


If any example with code will much appriciated.





I want to access controller getter-setter variable inside javascript. How could I do this.


Thanks in advance.







  • April 24, 2012
  • Like
  • 1

All of a sudden this afternoon, I am getting this message (as are 2 other developers) trying to save an APEX Class in Eclipse.  Has anyone encountered this before?  Any work-around?

I'm trying to verify that my code is permanently deleting objects.  For some reason, the test still finds the newly inserted tasks when I query ALL ROWS -even though I just purged it from the recycle bin.  Any ideas how I can test that a record was purged from the recycle bin successfully?


Any help is appreciated,




Here's my test code:


	static testMethod void testPermanentDelete()
		Task t = new Task(
			Subject = 'subject',
			Priority = 'Normal',
			Status = 'Completed',
			ActivityDate = Date.today());
		insert t;
		Id taskId = t.Id;
		//Verify the task was inserted
		List<Task> foundTasks = [Select Id From Task Where Id = :taskId ALL ROWS];
		System.assertEquals(1, foundTasks.size());
		Database.DeleteResult[] deleteResults = Database.delete(foundTasks, false);
		Database.EmptyRecycleBinResult[] emptyRecycleBinResults = Database.emptyRecycleBin(foundTasks);
		//Verify the task was permanently deleted
		foundTasks = [Select Id From Task Where Id = :taskId ALL ROWS];
		System.assertEquals(0, foundTasks.size());


While trying to deploy code using Ant I receive the error "...not available for deploy for this organization." So I tried to deploy my code using Eclipse but the Classes I want to deploy are not showing up as being able to deploy. Does anyone know what is causing this problem or how to fix it?


  • October 04, 2010
  • Like
  • 0

I am working at a very large client and we are currently required to create a new sandbox each time we are ready for our next release to be tested.  For example we have DEVR1 that needs to be recreated into another sandbox named DEVRTEST1.  We have a developer who is using ANT to push the meta data from one org to another, but numerous elements are being missed such as:




Some aspects of Profiles



Field History Tracking

Lead Field Mapping

Approval Processes



Needless to say it takes considerable time manually recreate the above items in each new sandbox.  Is there anyway to clone a SBX into a new Sandbox?

hi  i created a site where the guest users can edit their personal information. the operation should be on lead object.so i created a custom controller submitt which will save the edited info by user. it worked fine in the develoepr mode. when i put that page in sites its not updating the information on the lead record. when i went to public access settings and checked there are no modify permission for leads on sites. how can i achieve this task through sites. 


A client of one of our web service written in Apex reported an error.  It turns out there was an error --


Insert failed. First exception on row 9; first error: UNABLE_TO_LOCK_ROW, unable to obtain exclusie access to this record: []


I'm trying to think of what would cause an lock problem on an insert.  The method does to a start transaction and then inserts a row in Opportunity and then several in OpportunityLineItem. 


I don't see how the problem could be with the row being inserted.  Could it be with something locked a parent record like account?  Could something have already read the Opportunity record while the OpportunityLineItem records where being written?


We've been struggling with getting a zipped static resource to work for weeks now. We got Salesforce Support involved from the beginning, but they've gotten us nowhere. If we can't get a resolution to this issue soon, we might just find a platform that wastes less of our time...


Here is the situation - we are trying to upload a portion of the YUI library as a static resource, but no matter what we try, we can't get the files to render in our VisualForce pages. Salesforce Support can get it to work (sometimes), but we can't. The difference seems to be around the MIME Type that is set when the file is uploaded. When we upload the file, it gets set to a MIME Type of 'application/zip', but when SFDC Support uploads the file, it gets set to a MIME Type of 'application/x-zip-compressed' or 'application/octet-stream'. Salesforce can't explain to us exactly why or how these different MIME Types get set. They're looking into why our uploads don't work, but I'm not expecting much from them at this point.


To reproduce our steps:


Download the file from here after clicking the radio button labeled "Full developer kit":

  1. Download "Full developer kit"
  2. Open zip and remov the documentation and examples folders (to reduce size)
  3. Change file name from "yui_3.0.0.zip" to "yui.zip"
  4. Upload as a static resource named "testyui"
  5. In component "header" (where all other JS files are included) add:
    • <apex:includeScript value="{!URLFOR($Resource.testyui, 'yui/build/yui/yui-min.js')}" />
  6. If we refresh the page we get a 404 error for this resource.
If anyone has experienced a similar issue, any help you could provide would be greatly appreciated.

I am looking for the most reliable way to know the IP address of the client machine visiting my Sites page.  Looking at all the available headers on the page using ApexPages.currentPage().getHeaders(), I see several options like "True-Client-IP", "X-Forwarded-For" and "X-Salesforce-SIP"


"True-Client-IP" seems to be accurate all the time, but isn't always present.


"X-Forwarded-For" has a couple IP addresses in thereso I need to parse the list of IPs.  According to Wikipedia, this is somewhat of a standard header.  However, I always thought anything with "X-" is custom and not standard.


"X-Salesforce-SIP" is another that seems to be accurate on some pages, but on others it's not.


What's the most reliable?  In what situations are these header values populated?  Are there other values I should look for?


My code may look for all possible headers, but I want to start with the most reliable and try to understand the situations in which that are populated.



Message Edited by hemm on 07-15-2009 12:43 AM
  • July 15, 2009
  • Like
  • 0