• Adam Cimino 3
  • 0 Points
  • Member since 2015

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 4
  • 0
I am looking for a solution (salesforce app or cloud service) that i can call from my salesforce instance to have auto files (mp3) transcribed to a text file. I obtain audio recording from my telephone provider on calls and i store them as attachments on records in salesforce. I would like to pass that audio file to a service that would generate a text file that i would also attach to this record.

anyone have suggestions or experience with this?

I have a requirement to create a publicly accessible web service.
This is what I did
1)      Set up a Site on my org called publicWebService
2)      I create a class to handle a post http request
3)      I grated access to this class  in the sites profile
I set it up in my sandbox first and it works perfectly
Access as follows
When i moved my implementation into my production org. I did the same thing.
Site = https://production.force.com/publicWebService/
But i can’t access it like i did in my sandbox
https:// production.force.com/publicWebService/services/apexrest/logcall/v1?parm1=blabla&parm2=haha
Am I missing something or have to do something differently
Much appreciated
I am making a callout to a 3rd party to retrieve an mp3 file
The endpoint is a HTTP GET (https://api.ubity.com/recording?key=HV5nPTLk98UPeTLxqwA8&callid=ABC12345)
The response is the actual MP3 file, with a Content-Type: audio/mpeg header.

I am having trouble retrieving the audio file from the response body. The body is empty. Using my browser and rest clients I do see that the endpoint works and the mp3 file is returned
When I perform the callout it returns successfully with STATUS:OK and STATUS_CODE:200 so the actual call works
I assume that either I am trying to access the file from the http response incorrectly or salesforce is dropping the mp3 file 
I have tried other HTTP GET services from the same provider and they do in fact return content in the body.  It seems to be only in the case for the mp3 file
Here is my code. 

@future (callout=true)
public  static void getCallLogRecording(Id callLogId, String callid){
    try {
        CallLogSettings__c callLogSettings = CallLogSettings__c.getOrgDefaults();
        HttpRequest req = new HttpRequest(); 
        req.setEndpoint(callLogSettings.record_end_point__c+'?key=' + callLogSettings.key__c+'&callid='+ callid);
        req.setHeader('content-type', 'audio/mpeg');
        Http http = new Http();
        HTTPResponse res = http.send(req);    
    } catch(Exception e) {
For the past 3 months i have been  using the eclipse forece.com IDE and MavensMate plugin for sublime text to work with costume apex classes on my sandbox (cs14.salesforce.com)
I can't connect using either of these IDEs to saleforce. 
I get a connection time out error
I have not changed any configuration on my sandbox form what i am aware of 
Both IDE's use the tooling API so i assume the issue is connecting with the tooling API
I have tried the following
1) 2 different networks form different service providers. So its not the network
2) 2 different laptops. So its not the local computer and any setting on it
3) 2 different IDES, force.com IDe and mavensMate. So its not the IDE or their configuration
4) 2 different sandbox instances  (cs14 and cs15). So its not the sandbox
After all this the only constant and clear suspect is the tooling API
I opened a case with sale force and as usual they say everything seems fine on there end and they can't help