• AmitSahu
  • 1686 Points
  • Member since 2010

  • Chatter
  • 64
    Best Answers
  • 0
    Likes Received
  • 1
    Likes Given
  • 7
  • 765

When using apex data-loader , I have the error message as below.


Error message : Error logging in to Salesforce. Please check your username and password.


I tried to do it with the following information.
Is there any required settings ? I need your help.


setting - Server host : https://na15.salesforce.com
Username : my username for Developer edition
Password : my password for Developer edition

Hi all,


I am having a bit of bother. Hoping someone that has come across this can help.


I used to have a lead convert trigger and test class that worked fine.


Because of the usual (adding required fields) my test class needs updating.


It passes in Sandbox without any problems but I get an error when validating in production.


The error is:


Failure Message: "System.DmlException: ConvertLead failed. First exception on row 0; first error: UNKNOWN_EXCEPTION, System.DmlException: Update failed. First exception on row 0 with id 00Qa0000014MjCuEAK; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, LeadConvert2: execution of AfterUpdate caused by: System.DmlException: I...



Line 71 is " Database.LeadConvertResult lcr = Database.convertLead(lc);  "


Can anyone help?



Private Class LeadConvert2{
static TestMethod void TestLeadConvert2(){

    Lead ld = new Lead(
    Company = 'TestCompany',
    OwnerId = '00530000005dI0c',
    LastName = 'Test',
    Phone = '07856656565',
    Email = 'test@test.com',
    Preferred_to_be_contacted_by__c = 'Email Only',
    Util_Eyes__c = True,
    LeadSource = 'Other',
    Linked_Basket__c  = '00130000015Cxwt',     
    Linked_Affiliate_1__c = 'a0N30000005aRCu',
    Aff_1_Profit_Share__c = 0,
    ME_rep_that_nurtured_this_lead__c = '00530000004WakH',
    industry = 'Finance',
    Initial_Email_Sent__c = True,
    Elec_AQ_Guestimation__c = 1000000000,
    Relationship_Status_New__c = 'Green [All good]',
    Client_Potential__c = 'Diamond [More than 100k]',
    Sales_Team__c = 'a0P300000053ps9',
    Sales_ME1__c = '00530000004WakH',
    Sales_ME2__c= '00530000005dI0c',
    Sales_DTR__c = System.Today(),
    Sales_Division__c = 'Util-Eyes',
    Sales_Utility__c = 'Gas',
    Sales_Acquisition__c = 'Acquisition',

    CR_ME1__c = '00530000004WakH',
    CR_ME2__c = '00530000005dI0c',
    CR_DTR__c = System.Today()
    insert ld;
    Database.LeadConvert lc = new database.LeadConvert();
    LeadStatus convertStatus = [SELECT Id, MasterLabel FROM LeadStatus WHERE IsConverted=true LIMIT 1];
    Database.LeadConvertResult lcr = Database.convertLead(lc);
    system.debug('errors=' + lcr.getErrors());

    Account accts = new Account(
    Name = 'TestCompany',
    OwnerId = '00530000004WakH',
    ParentId = '00130000015Cxwt',
    Team_s_Dept_s__c = 'a0P300000053ps9',
    ME1__c = '00530000004WakH',
    ME2__c = '00530000005dI0c',
    Account_Status__c = 'Live',
    Local_Network_Folder__c = 'Test',
    Relationship_Status__c = 'Green [All good]',
    Client_Potential__c = 'Diamond [More than 100k]',
    Linked_Affiliate_1__c = 'a0N30000005aRCu',
    Aff_1_Profit_Split__c = 0
    insert accts;
    //insert a Contact
    Contact con1 = new Contact (
    AccountId = accts.Id,
    FirstName = 'Contact',
    LastName = 'One',
    Email = 'contact1@test.com',
    Phone = '08445715544',
    MobilePhone = '07966565985',
    Title = 'Manager'
    insert con1;
    Line_del__c salesLine = new Line_del__c(
    Name = 'Test insert new Monitor Line',
    Team_s_Dept_s_del__c = 'a0P300000053ps9',
    ME1__c = '00530000004WakH',
    ME2__c = '00530000005dI0c',  
    DTR3__c = System.Today(),
    Stage__c ='Closed Off',
    Division__c = 'Util-Eyes',
    Utility__c = 'Gas',
    Renewal_Acquisition__c = 'Acquisition',
    Linked_Account__c = accts.Id

    Line_del__c CRLine = new Line_del__c (
    Name = 'Test insert new Monitor Line',
    Team_s_Dept_s_del__c = 'a0P300000053prk',
    ME1__c = '00530000004WakH',
    ME2__c = '00530000005dI0c',      
    DTR3__c = System.Today(),
    Stage__c ='Closed Off',
    Division__c = 'Dept',
    Utility__c = 'n/a',
    Renewal_Acquisition__c = 'n/a',
    Linked_Account__c = accts.Id   
    insert salesLine;
    insert CRLine;



I have a custom setting that includes five picklist values. This custom setting is referred  in a trigger. The trigger  will not allow user to delete once a value is selected. I want to add another picklist value to the existing custom setting. Can I just do it by going into Custom Setting and click on the new button and add the pick list value. I want even this picklist value to be referred in the trigger. Should I be making any changes in the trigger, after I update the picklist value in the custom setting.




Thank You in advance for the help.




  • February 11, 2013
  • Like
  • 0

I have a requirement for parsing an email subject which is sent from a different portal .


Can anybody plz help me to resolve this.

Any help appreciated.

  • September 22, 2012
  • Like
  • 0



My scenarion: There is a field f1 in Account page which user's of Profile say P1 can not edit(Field is not read-only) because we have used validation rule to stop them from editing. What bussiness wants is that there are some users of P1 profile which have permission set. If any user with this permissin set is changing the record of field f1 then validation should not trigger. I can not find any permission sets in insert field option for a validation. Is there any way I can use permission sets in validation rule.


Any help will be appreciated. Thank in advance.


With Regards,

Mayank Pant


Checkbox                 user                        fieldnames  fieldname2  fieldname3           Total


     checked             test@test.com              1                     2                     3                        5


    checked              test1@gmail.com        1                     1                     1                        3


                                                                                                                                         total =8



this type of formate i want please Help me.it's very urgent requirement


if i'm click checkbox assign leads individually 

I am getting the named error on the following code. I am not sure what I am missing.


The structure is that the Trial__c is the parent of Trial_Data__c and I am simply trying to query all the Trial Data related to one trial.


Here is my Code:

for(Trial_Data__c td : [Select Id, Channel_Volume__c, Channel_Flow__c, Trial__c From Trial_Data__c WHERE Trial__c =: Trial__c.Id ORDER BY Id ASC])
            GoogleViz.row r = new GoogleViz.row();
            r.cells.add ( new GoogleViz.cell( interval));//interval
            r.cells.add ( new GoogleViz.cell( td.Channel_Volume__c));//X-Axis
            gv.addRow( r ); 
            interval = interval + .01;

 The error is on the first row query. I need to make sure I am not pulling ALL Trial_Data__c records to display.


Thank you for any help you can provide.



Despite creating S-Controls for our organization for several years we just started to create our first Apex Triggers and immediatly run into the "Test Classes"-problem. We created the following simple trigger which is working in the Sandbox but cannot transfer it to Production Environment without a Test Class.


When a user tries to set the Opportunity Stage to "Won", the trigger checks if there is a quotation file among opportunity attachments and if not, prevents saving the record with an error message. Here is the code:


trigger CheckOppAttachments on Opportunity (before update) 
    if (trigger.new[0].StageName == 'Closed Won')
        Boolean pdf = false;
        Boolean pdfloop = false;
        Opportunity opp = trigger.new[0];
        Attachment[] atts = [SELECT Name FROM Attachment WHERE ParentId =: opp.Id];
        for (Integer i = 0; i < atts.size(); i++) 
            pdfloop = atts[i].Name.contains(opp.Quotation_No__c);
            if (pdfloop)
	if (pdf)
	     opp.addError('The Stage can not be set to "Won" as long Quotation is not attached');


Any example of a test class for such a trigger would be appreciated.





  • July 29, 2012
  • Like
  • 0

Can any one tell me that how can i add  a Edit column on Account default landing page, like how we got under App setup->Customize->Accounts->Page layouts...!!

Hi Guys,


1. I have a record type and page layout called "locked Opportunity"

2. I just created a new opportunity record type "BellTel Opportunity"  and a new page layout also called "BellTel Opportunity" 

3. We have a separate system called FIS integrated with Salesforce to update some opportunity field. This system is designed to verify if the facility for the created opportunity is available.

4. We have a custom button that will send the opportunity details to FIS.

5. Exchange of information from SFDC and FIS is thru WSDL.




Now, I created a new opportunity with thisrecord type "BellTel Opportunity", when i send the details to FIS the opportunity record and layout is still "BellTel Opportunity". But when FIS returns the details to salesforce, it does not only update the fields but i also changed the record type and layout to "locked Opportunity". I am struggling all day to find out why it was changing the record type. Could someone help me or give me a clue.



Im totally clueless.:(







Can someone please explain what is the process of Save to Server and Deploy to Server

And to which env should I do what?  


 - I have both Sandbox and Production env


 - Do I need to first deploy to DEV - than when i need to update, can I just save?


Or is there another workflow requirement?

I am not understanding what is the use of newMap,oldMap and how it used.

please give me explanation with example

Excuse me for the NOOB Q


I am using the X.IDE


My first project included an email processor, which works perfectly, and is deployed to the server.


Now that I want to create a new trigger (which has nothing to do with the emailProcessor) 


 - Should I create a new project for that?

 - Is there a rule of thumb to when to create a new project?  (to all triggers? all classes? all related objects?)





I've a visualforce page that embedded with flow using <flow:interview> tag. My flow running correctly on salesforce.com environment. In this flow there is Record Create element. This flow can create Contact and Custom Object named Registration.

I've also set up Site so that visitor can running this flow. I've also set the public access setting for this site that allow user to read and create standard and custom object.

The problem is when visitor have reached step 6 / 7 and hit Next button there is error message about authentication. From what I've seen is that the error occurs when Custom Object is created from Record Create element in the flow. But what makes it bizzare is the flow running smoothly on salesforce.com Flow manager

Below is my site link so that you guys can help me troubleshoot this issue.




Thanks & Regards


Can any one explain what is 'ap1' in 'https://ap1.salesforce.com' Note: I am accessing from India. Thanks in advance, Kiran.

Hi ,


Salesforce is augmenting the current NA1 instance with an additional instance – NA13 , and we are using the apex wsdl which has the absolute url.can i use the relative url in the apex wsdl instead of using the absolute url?


  • July 11, 2012
  • Like
  • 0


I'm new to Force.com.
I have a custom object: percentage__c with the following custom fields:

I need to create an after insert, after update, after delete trigger to update the allocation__c field if there are more than one Team__c for the same Account, Province__c, and City__c.

Here are some sample data:
Account1 ON Toronto  Team1 100
Account2 ON Niagara Falls  Team1  100

when Account3 comes in,
Account3 ON Toronto Team2 100

the trigger should update both Account1 and Account3 to 50, the total should always be 100.
Account1 ON Toronto Team1 50
Account3 ON Toronto Team2 50

I need help on how to get the same Province__c and City__c from the existing records based on triggers.new in a set of Id.

Any help is appreciated.



I want to customize  system wherein emails are send to all our current and prospest customers about our new products and track their responses . 

Being new to this Salesforce , need some guidelines .





Hi guys


I've been working on a prototype project - and here are some requirements that I have from a client.  Rather than putting them all into one question, I am going to split them up into three questions, as they cover different aspects of Salesforce's features (or limitations rather, until I have a solution).


This is about a system that tracks some Work Orders.


When the user is creating a new work order, I only want to show fields 1 to 10, and they are all editable, and some are required and some are not.


Once saved, and when the user wants to edit it, now fields 1 to 8 are read-only, and I'll also need to start showing fields 11 to 20.


So basically, my question is, I need to show a form and the form will look different when the user is creating a work order versus when the user is updating an existing work order - some fields are no longer editable, and some fields only show in edit mode not in insert mode.


Is it possible, and if so, how?  


Thank you so much.


I hope I'm missing a fundamental salesforce coding knowledge. 


After putting together my code and testClass and deploying (with 100% coverage), I realized it didn't quite do what I wanted it to do, so I tweaked it in sandbox. got it to work and then deployed. went along my way until the client came back and told me that it was still using the old functionality. I looked and saw that the update failed. 


I tried

- deactivating the trigger and class

- deactivating each individually

- making whitespace changes

- from eclipse

- from sandbox


All of which fail. 


The error codes states: The Apex job named "Merge Job" is already scheduled for execution.


It points to another trigger that it claims is having the issue. However if the code is validated and deployed, how come I can't make whitespace changes?


Thanks anyone that can help.

Hi Guys,


Any one can have any thoughts on this issue please?


I have a schedule to run everyday at 12:00 AM. So It runs everyday.


The problem is, if the schedule updates the records one day it does not do that the other day.


My code was running properly until the scheduling user was changed.


What does the code do ?

The code queries on an object and gets records created today and creates the same records in another object.


Example: The Cases are queried and cases created today are fetched and stored in another object.


The same code was working perfectly fine since recent past. The user who scheduled this initially is inactive now. So it schedule was put in back using other user (System Admin).


Since then the schedule runs daily. But, one day it does what it supposed to and on the other day it just runs till the query and does not create the records in the target object.



Hi Guys,


Please can any one parse the JSON returned from http://api.crunchbase.com/v/1/company/google.js .


I need to get the list of products from this result.


Thanks in advance....

Hi All,


Can any one point me to a direction where I can prevent user from moving away from a record/pagelayout without filling a description field ?


Thanks in advance for your valueable input...



Hi All,


I would need help on a solution to delete the record on which I am operating.


Example : If I am inserting a record in Case object (Using triggers here) . Once the case is inserted I need to delete that.


Any thoughts ?

Hi Devs',


How can I change the parameters in this line below so that it will run every 15 min. It seems to me that at the minimum we can run the job every 1 hours. Please let me know if I am correct ....


System.schedule('Stock Price Update', '0 0 1-23 * * ?', new getStockPrice());





Hi All,


Thanks in advance for any help on this topic.


Here is my code : 


String emailsubject = 'test1,test2,test3';
String emailbody= '100\n200\n300';
String[] emailSubjectIteams = emailsubject.split(',');
String[]  emailBodyMulti = emailbody.split('\n');
 List<Expense__c> expelement= new List<Expense__c>();
   Expense__c expItems = new Expense__c();
        for(integer i=0; i < emailSubjectIteams.size();i++)
    expItems.ExpName__c = emailSubjectIteams[i];
  expItems.Price__c = integer.valueOf(emailBodyMulti[i].substring(0));     
      System.debug('expItems object'+expItems);
   System.debug('Expelement list values : '+expelement );     


I am running the above code in System log to check my issue.  The Last system.debug line to print expelement shows a confusing result to me.


Please let me know if any one has any clue about this issue.







I have just started and installed Force.com IDE on Windows 2003 32 bit.


It runs fine for some time and gives Memory out error message.


The process takes the maximum of the system resources.


I have 4 GB of RAM 3.2 GHz processor.


Please help.


Thanks in advance..!



I have followed a progression.

1.  I built Lightning components on the developer console, and the documentation shows.

     In order to keep snapshots of my work as I went, I copied and pasted to emails that I sent to myself. 

2.  I attended Midwest Dreaming, and discovered that my compatriots worked in Sublime and Eclipse, and connected to Salesforce. 

     That would allow me to use git, as I'm used to.  

3.  I tried Sublime 3 with MavensMate.  I got a complaint that TLS 1.0 wasn't supported, only TLS 1.1. 

4.  I looked into using Eclipse with the Force.com IDE.  It's not clear that environment supports building Lightning components conveniently.

5.  I discovered that if you go to salesforce...devcenter/lightning, they talk about a plug-in for Sublime.  Not a MavensMate plug-in.  One made by Salesforce.

So my question is:  Where can I go for reliable, convenient development of Lightning components?
Hi All,

I am trying to work with Lightning Components in the Eclipse Force.com IDE. I loaded all the Lightning Components I made to Eclipse by adding the AuraDefinitionBundle type in the package.xml file. I'm able to see all the Lightning components I created in the SF developer console in the package explorer. 
Unfortunately, when I try to edit a component and save my changes, I get the following error:

Unable to perform save on all files: INVALID_CROSS_REFERENCE_KEY: No package named 'aura' found (Failed)

Did I miss something?
When trying to add or edit an account team in lightning my users are getting an error " insufficient access rights on cross-reference id ".  If they switch to the classic view they are able to add and edit account team members.  Is anyone else having this issue? 
Hi All,

Is it possible to run the scheduler class every one minute.............Because my req comes like only

Notifications need to send every 1 hr,2 hrs , 3 hr & 4 hrs
The record might be created at every minute in a hour.....
  • March 15, 2016
  • Like
  • 1
​Hello guys i have this requirement that i need help/suggestions on how to tackle them. Can this be achieved? if so how can this be acheived 

Thank you

  • create an Invite to one or more Recipients (Contacts) in the CRM, The Name of the Course,one or more Course Sessions
  • Couse Invites are received by Recipients via Outlook or suitable email client such that the client can accept and by doing so record the acceptace simultaneously in the recipients Outllook Calendar.

I'm trying to use OpenSpace in Salesforce with their given source:
<script type="text/javascript" src="http://www.openspace.ordnancesurvey.co.uk/osmapapi/openspace.js?key=BA08531D8339984EE0405F0AC86026A9"></script> 

but when I run the vf page gives me the following error:

"Mixed Content: The page at 'https://c.eu5.visual.force.com/apex/TestOSMaps' was loaded over HTTPS, but requested an insecure script 'http://openspace.ordnancesurvey.co.uk/osmapapi/openspace.js?key=BA08531D8339984EE0405F0AC86026A9'. This request has been blocked; the content must be served over HTTPS."

I've tried to change from http to https but it doesn't work.

Is there a way to solve this?

I am at a lost for some reason this code will not work and I don't understand why. I am trying to make a table on a visual force page.

Here is the class
public with sharing class stationController 
    public List<Account> accounts {get;set;}
    public stationController()
        accounts = [SELECT Id, Name, Customer_Num__c, Location_Number__c, Type  FROM account LIMIT 10];

and here is the page
<apex:page controller="stationController">
  <apex:pageBlock title="Stations">
      <apex:pageBlockTable value="{!accounts}>" var="account">
          <apex:column value="{!accounts.name}"/>

The class shows no problem but when I try to get the account name on the visual force page I get the string.name error but if I only call for the account I get teh account ID number just fine.

I have used the exact same code to get contact information and this error never appeared.

I am doing a simple search and displaying the result. I am getting the value of the input field by
String Name = Apexpages.currentPage().getParameters().get('Name'); 
    String Description= Apexpages.currentPage().getParameters().get('Description'); 
    String ProductType= Apexpages.currentPage().getParameters().get('ProductType');
Now, I want to clear the values on ProcessSelected() method
by using the code below:
Apexpages.currentPage().getParameters().put ('Name',null);

However, it does not update the value to blank on the visualforce page.

Any suggestions?

Hi, I am getting this error in console window.

Mixed Content: The page at 'https://c.ap1.visual.force.com/apex/weatherAndGoogleMap_v1?core.apexpages.devmode.url=1' was loaded over HTTPS, but requested an insecure script 'http://api.openweathermap.org/data/2.5/weather?q=London,uk&callback=test'. This request has been blocked; the content must be served over HTTPS.

how can i overcome this issue.
As the visualforcepage is in https and it is trying to call other url of type http.
so how to solve this issue.

I am calling 
an http 
I'm following the example shown on Peter Knolle's post here: https://developer.salesforce.com/blogs/developer-relations/2015/03/lightning-component-framework-custom-events.html

When creating the contactSearch Component, I'm getting the following error:

"Failed to save undefined: No CONTROLLER named apex://mynamespace.ContactSearchController found: Source"

I'm not sure what I've missing - any thoughts?
Hi All,

Can any one solve this issue .

trigger defaultpayment on Student__c (after insert) {
    Student__c student = trigger.new();
    Payment__c payment = new Payment(Student__c = student.Name,StudentId=student.Id,Amount = 200);
insert payment;

  • April 02, 2015
  • Like
  • 0
Could not fetch queued deployments for = undefined: FROM ContainerAsyncRequest WHERE MetadataContainerId='undefined' ^ ERROR at Row:1:Column:57 invalid ID field: undefined

Error in Developer console,

for this error I can not save changes to my classes in my sandbox!!!!
I have written a trigger (in Sandbox) to auto convert a lead when the Lead Source is  GetTimely Online. The test class has also been written for the same. However while running the test class I am getting the error mentioned below. I have searched a lot but am unable to fix the issue. Can anyone tell what could the issue be.

Trigger Error:
System.DmlException: Insert failed. First exception on row 0; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, AutoLeadConvert: execution of AfterInsert

caused by: System.DmlException: ConvertLead failed. First exception on row 0; first error: UNKNOWN_EXCEPTION, An unexpected error occurred. Please include this ErrorId if you contact support: 430269022-7994 (647855467): []

Trigger.AutoLeadConvert: line 7, column 1: []

My Trigger:-

trigger AutoLeadConvert on Lead (after insert) {
    for(Lead myLead: Trigger.new){
        if((myLead.isConverted==false) && (myLead.leadSource=='GetTimely Online')){
            Database.LeadConvert leadConvert = new database.LeadConvert();
            Database.LeadConvertResult leadConvertResult = Database.convertLead(leadConvert);
            catch(DmlException e){

Test Class:-

public class TestAutoLeadConvert{
    static testMethod void convertLead(){
        Lead lead = new Lead();
        lead.Company='Trigger Test';
        lead.Email='vandana.rattan1982@gmail.com' (mailto:lead.Email='vandana.rattan1982@gmail.com');
        lead.LeadSource='GetTimely Online';
        insert lead;

I have to autopopulate a picklist value when i create a custom object record.
That picklist value should be autopopulated when i click create new.Can i do this using trigger?

Hi all........

I have a requirement like there is one custom object by name 'Position'..... I need its data to be filled from web form. How to implement it.

Note: I am already using lead object so cant use it for this purpose.........

Hi is there any video tutorial which help us learning the set up of live agent


I created two methods in this class but when saved generates this error message. "Save Error: Entity is not org-accessible"


Is a test method. I'm using isTest(SeeAllData=true) annotation.


So happens when I try to add two more methods class.

Anyone know what can be?





Diego Moreira

Hi community,


I've tried to enable Sites in my Developer account two or three times, but when I log into my developer account and go through Setup--> Develop the option Sites does not appear.


As I'm using Firefox, I noticed an error in the activation form by having a look to the errors console.


I also read other messages in the community talking about the same issue.


Can someone help me?


Thanks in advance.



I get this error constantly while trying to deploy. Where the issue may be?

  • January 09, 2009
  • Like
  • 1

I am having an issue with displaying trigger error on a Visualforce page. In my trigger, I'm having the following piece of code to throw the error:

myCustomObjectInstance.addError('You are not allowed to do this...');

Again, on my VF page, I have added the following snippet:
The problem is that when I simulate the error condition, it does not display the error message on the VF page, but the same is visible in debug log as follows:
VF_PAGE_MESSAGE|You are not allowed to do this...

Anyone has any idea about it?