• rapura_acumen
  • 0 Points
  • Member since 2011

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 1



I'm trying to build a template that will have a modifiable top-right area for links.  Here's my code:



                        <div id="utilLinks"> 
                            <!-- top utility links -->
                            <div class="utilLink"><c:contentblock name="header-link-1"/></div>
                            <div class="utilDiv"></div>
                            <div class="utilLink"><c:contentblock name="header-link-2"/></div>
                            <div class="utilDiv"></div>
                            <div class="utilLink"><c:contentblock name="header-link-3"/></div>
                            <div class="utilDiv"></div>
                            <div class="utilLink"><c:contentblock name="header-link-4"/></div>
                            <div class="utilDiv"></div>
                            <div class="utilLink"><c:contentblock name="header-link-5"/></div>
Template comes out fine, but when I'm creating the actual page and then adding in a URL to, say, the "header-link-1" content block, CMSForce, adds <p> tags around the <a href>, therefore causing misalignment.
Has anyone, short of going into the Source Code and removing the <p> tag, found a way around this?  Unfortunately, it's not a great solution, since if that particular URL needs to be modified in the future, the Source Code will need to be modified everytime to remove the <p> tags.


I'm running into an error installing CMSForce for a client and saw that you're an active and knowledgable member of the boards so I thought to contact you directly. We were able to install and use CMSForce in the sandbox environment and then tried to install it in Production but ran into the issue of getting an Authentication Error when trying to view the Main Template within the CMSForce Console.


We uninstalled at this point since we were performing other migration tasks last night and this was holding us up.


This morning we went back in, tried to install CMSForce again, but then ran into the error that "CMSForce" Static Resource was already in the system. (This was brought in from our UI Designer last night as part of his migration of files). When we tried to delete the CMSForce Static Resource, we got the error that it was being referenced by a Component and Pages in the system. We went ahead an commented out any time the "Resource.CMSForce" was being called. At this point we were able to delete the CMSForce Static Resource.


We installed again and ignored the APEX test errors (it's a common error as you probably know). We followed the customization guide to a "T" and then tried to access the CMSForce App (top-right corner of SFDC). We got an error here as well, stating that there was a Duplicate Reference 3 error? At this point we don't know what to do and need to install this for the client today. ANY help would be more than appreciated!




I downloaded CRMForce 2 into my sandbox and have been trying to edit content boxes on a sample page.  I can type the content in, but when I click save, no changes appear on the page.  This is happening using the AppExchange Sample that was provided with the application.


Do you know why this would be happening?