• karriche hakim
  • 10 Points
  • Member since 2011
  • Salesforce.com Developer

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 5
I am building a custom component to show a list of Cases filtered by a certain criteria. I am using <lightning:dataTable> for this. One of the columns in the list is Record Type and I am unable to display the Name of the Record Type in my list component. It shows up as Id.
                             data="{! v.caseData}" 
                              columns="{! v.caseColumns}" 
                              keyField="Id" hideCheckboxColumn="true"/>

//Helper. JS
component.set('v.caseColumns', [
					{label: 'Case Number', fieldName: 'linkName', 
                     type: 'url', 
                     typeAttributes: {label: { fieldName: 'CaseNumber'},target: '_blank'}},
					{label: 'Status', fieldName: 'Status', type: 'text'},
					{label: 'Subject', fieldName: 'Subject', type: 'text'},
                    {label: 'Record Type', fieldName: 'RecordTypeId', type: 'text'},

//Controller code
listOfCases = [SELECT Id,
                          FROM Case WHERE xyz...];

In the helper, on the column attributes for Record Type fieldName, I have tried options other than 'RecordTypeId' but that do not show anything in the column. When I run the query in the Console I can see the developer name. What am I missing or doing incorrectly here.

User-added image
I keep getting the following error message, even after trying in 3 new playgrounds: 
Challenge Not yet complete... here's what's wrong: 
Some billing state names do not meet data quality standards, or the data import was unsuccessful.

I followed all of the instructions:
1. Installed unmanaged package in the new playground
2. Added Residential picklist type to Accounts
3. Cleaned up Account list:
a. Removed "Household" from Account name (this wasn't specified, but it didn't seem necessary)
b. Removed duplicate records
c. Changed accounts in ALL CAPS to only cap first letter of first and last name
d. Changed state name to 3 letter State code
e. Saved as .CSV file
4. Imported list using Import Wizard

I received an email confirming the import was successful with 11 rows processed and I see the accounts when I search up accounts in the playground. 

Thanks in advance for any help!
If anyone gets this error message: "The dashboard configuration that allows users to see only their own data is incorrect"...
error message

The solution is to check The Dashboard Viewer radio button in the dashboard settings--in the "View Dashboard As" section.
I keep getting the following error:
Challenge Not yet complete... here's what's wrong:
Could not find 'Jane Cando' as a territory member of a service territory named 'San Francisco Area'.
However, when you look at the Territory related list you see the following:
User-added image
Jane Candor is in the correct territory.


I am trying to complete the topic Creating a data model under the module 'Build a Conference Management App' in Trailhead. However, even after doing everything right with the speaker object. The challenge still throws an error. Did anyone else complete the challenge. 

Thank you,