• Pault.ax256
  • 80 Points
  • Member since 2006

  • Chatter
  • 1
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 19

I am creating a VF page that will allow users to enter information in a form that is related to a case. Once all relevant information is entered, users can also change the case owner (if required) before clicking Save and I have managed to do this successfully.


However, I would also like the form to be able to accept an optional "Internal Comment", so that all of the case updates can occur on one screen. However, I can't seem to find the relationship for this field. I tried multiple variations of <apex:inputfield value="{!Case.CaseComments__r.Comments}" />but without success. Can anyone help?



  • April 08, 2009
  • Like
  • 0
Hi All, 

We have developed IOS mobile app but facing loading issue if phone is idel for some time. The app is working once logout from apps and re login into app.  

ex: we are facing issue when search for account, new account creation etc. 

We have used javascript remote action to fetch the results .
please see sample code

        global static List<Account> fetchAccountDetails(String name) {
            // where Name LIKE \'%\''+name+'\'%\'
            String qry = 'Select Id,Name,BillingStreet,BillingCity,BillingCountry,BillingState,BillingPostalCode,FloraMobileApp__LGA_Name__c,FloraMobileApp__Stage__c,FloraMobileApp__Total_Order_Arrangements__c,FloraMobileApp__Trial_Arrangements__c,Industry,(Select Salutation,Name,Phone From Account.Contacts) From Account where Name LIKE \'%'+name+'%\' LIMIT 10 ';
            return database.query(qry);

Please help me.


Hi Techies,


I am getting some problem during SFDC Plural label creation.Actually some time this input plural label is display but sometime it disappear.


I don't know exact problem of appear and disappear of this input field. If plural label is disappear and your custom object will be create then Deployment time it will create problem and display some error like


"Must specify a non-empty plural label for the CustomObject "


Please help me why it appear/disappear. Even i have latest version of Salesforce/Force.com.


Thanks in Advance



Does any1 have any idea about limitations of the things that can be done from an action method in an apex:page tag

I have an action method in apex:page tag which redirects user to another VF page but its not working.

What I observed that the VF page redirected to other VF page only when the controller of the other VF page was different than its own but when I redirected to a VF page having the same controller its just dint do it!!


I also tried it by switching off the development mode but it dint work. Has nay1 faced any such kind of issue & if so how can some1 resolve it!!


Please check code here.

Can an inner class access an instance variable of its outer class?



I have a bit of code which, simplified, looks like this. In context, it produces the error " Method does not exist or incorrect signature" on line 8, but for some reason this simplified version produces the error "User-defined type not allowed here" on line 4.


The apex manual says "Inner classes can have instance member variables like outer classes, but there is no implicit pointer to an instance of the outer class (using the this

keyword)." (link)





1: public class MyClass {
2: public Map<String,Statistical_Datum__c> dataMap;
4: public class Datum {
5: Statistical_Datum__c datumObject;
7: public Datum( String statistic ) {
8: datumObject = dataMap.get( statistic );
9: }
10: }
11: }




Hi I was wondering whether this could be done.


I have a custom picklist on a task record, and based on what is selected there, it will update the picklist value on the account that the task associated to.  So everytime a new task is create for that account and the picklist value is selected, it will also update the picklist on the Account record. 


Any advise or suggestion?

Hi there,


 Can be VF page be deployed in a tabpanel ?

 I want to Access custom VF pages in tabs .


Is this possible ?


Please reply .....

Thanks in advance .


  • April 10, 2009
  • Like
  • 0

I have a long trigger with many "if" where I don't know how to test it. This is one of the "if" which I don't know how to test...

list_opp is a list of id of opportunity and work properly, the trigger before update save the custom field sex of opportunity into the custom field of contact




if (list_opp.get(0).sex__c <> null){ c.sesso__c = list_opp.get(0).sex__c;}



 I thinking to do this but doesn't work:



Account a = new account(name = 'Test ammin'); insert a; Contact c = new contact(lastname='test_last_name',accountid=a.id); insert c; Opportunity o = new Opportunity(name='Name test',sex = 'M'); insert o OpportunityContactRole z = new OpportunityContactRole(ContactId=c.id,OpportunityId=o.id,role='other',Isprimary=true); insert z; //now verify if sex is write properly Contact c2 = [select sex__c from contact where id=:c.id limit 1]; system.assertequals(o.sex__c,c2.sex__c);

 the test say me:


System.Exception: Assertion Failed: Expected: M, Actual: null  








I am new to SalesForce. We have a requirement to integrate our service with the salesforce.

In  in the Apex refrence pdf(salesforce_apex_language_reference.pdf), they tell to import the wsdl file & map the end point in Remote Setting.

Can any one please give me the sample wsdl with the end point. I tried wsdl like "AmazonWebServices.wsdl, AmazonS3.wsdl, GoogleSearch.wsdl,..."

Since those uses rpc which is not supoorted in salesforce I was not able to import it to generate Apex class.

Can any give me some inputs or some links for service end points which uses 'doucment' type instead of 'rpc'.




  • April 09, 2009
  • Like
  • 0



I am building a Visualforce page that is bound to the Case standard controller. This page is replacing the standard New Case page in Salesforce.com. I want to include an input that allows users to add an attachment to their Case when they are creating the record using my page. I already have a controller extension that this page is using to enhance the New Case process. I see that there was a new "apex:inputFile" component included in the Winter 09 release that allows me to do this. The documentation gives me the following usage example:


(from: http://www.salesforce.com/us/developer/docs/pages/Content/pages_compref_inputFile.htm)



<; Page: --><apex:page standardController="Document" extensions="documentExt"><-- Upload a file and put it in your personal documents folder--> <apex:messages /> <apex:form id="theForm"> <apex:pageBlock> <apex:pageBlockSection> <apex:inputFile value="{!document.body}" filename="{!document.name}"/> <apex:commandButton value="save" action="{!save}"/> </apex:pageBlockSection> </apex:pageBlock> </apex:form></apex:page> /*** Controller ***/public class documentExt { public documentExt(ApexPages.StandardController controller) { Document d = (Document) controller.getRecord(); d.folderid = UserInfo.getUserId(); //this puts it in My Personal Documents } }


However, this code assumes that the page is bound to the Document standard controller. Also, since the Case record is not yet created, I cannot specify the parent ID of the Case for my attachment since it does not exist yet (remember, this page replaces the standard New Case page.)


Can someone explain to me how I would modify my controller extension to make the "apex:inputFile" component work in this scenario? I'm planning on adding this to my Visualforce page:


<apex:pageBlockSectionItem> <apex:outputLabel value="Add attachment:" /> <apex:inputFile value="{!attachment.body}" filename="{!attachment.name}" /> <apex:commandButton value="save" action="{!save}" /></apex:pageBlockSectionItem>



 but I know that I will need to modify my controller extension to make this work. Also, if I use:


<apex:commandButton value="save" action="{!save}" />



how will it know to just save the attachment, and not the entire Case page?


Thanks for any help that you can provide. I'm pretty new to Visualforce/Apex development, so examples of how to make this work would be greatly appreciated! :)




-- Rob 


I am creating a VF page that will allow users to enter information in a form that is related to a case. Once all relevant information is entered, users can also change the case owner (if required) before clicking Save and I have managed to do this successfully.


However, I would also like the form to be able to accept an optional "Internal Comment", so that all of the case updates can occur on one screen. However, I can't seem to find the relationship for this field. I tried multiple variations of <apex:inputfield value="{!Case.CaseComments__r.Comments}" />but without success. Can anyone help?



  • April 08, 2009
  • Like
  • 0

Hi sfdc community,


I am new to web services and have been working with salesforce for about 4 months now so I hope you take that into consideration while you read my question :)


I have several web-services to create for an integration piece on a project I am working on.  As I have been reading, I found apex can easily create web-services from an apex-class by generating a wsdl for that class.


My question is, in my web-service I have defined an Object made up of arguments I expect to recieve from the other side of the integration.  So they will be calling my web-service and instantiating the object i defined in my web-service and then calling a method I made which takes that object as an input.  So do I create the logic for that newly recieved object in this web-service class? for some reason that does not seem right because then it would be captured in the 'generated' wsdl.


All they would need is object definition and method to call and that is that, they do not need the logic correct?


I can post the apex-class here if needed but it's fairly straight-forward, I just need to undersatnd how the procedure works, do i just give them the wsdl before I create the logic for the class so they have the method name and object definition or do they need the entire class itself?


thank you in advance for any help 

  • April 08, 2009
  • Like
  • 0

I have uploaded the document using examples given in the component ref. now I want to download that document using my custom VF page.Please guide me ..



Thanks In Advance,


Sandip Thakare

Related to this thread http://community.salesforce.com/sforce/board/message?board.id=Visualforce&message.id=8439#M8439

it seems that it does not respect the list views the user can see, per the developer guide that says:

" the apex:selectlist component is populated by {!listviewoptions}, which evaluates to the list views the user can see."


I have checked all the views and they are not accessible to Customer Portal Users. All of this to say the list views display all the list views thathave been created.

One of my users is getting an error when clicking on a button that uses an action and rerenders.  I assume this is something on his client browser.   Has anyone seen this error before?


a4j.AJAX is null or not an object


He is using IE

  • March 09, 2009
  • Like
  • 0
I notied an issue with the {!listviewoptions} available on a list view in VisualForce.  Related to this thread:


I defined a set of filters, and also defined permissions on those filters so that, say, half of them were for Customer Portal users and the other half were for System Administrators.  However, when you use {!listviewoptions} in VisualForce, a la

   <apex:selectList id="viewList" size="1" value="{!filterId}">
    <apex:actionSupport event="onchange" status="listStatus" rerender="aarList" />
     <apex:selectOptions value="{!listviewoptions}" /> 
     <!--<apex:selectOptions value="{!ViewSelectOptions}" /> -->

 Then you get the whole list, and it does not pre-filter the filters, so to speak, by the user's profile.  Maybe this is a bug, maybe it's intentional.  Either way, it is proving extremely difficult to elegantly get around this problem.   Is this a bug?  How would you solve it?  I've looked into a variety of solutions, and I'm trying to avoid building out a custom SetController extension just for this. 

Hi. This is the problem I'm having:

- I'm in the Connector.

- I select Sforce Table Query Wizard

- I select "Account":as the table to query

- The custom field I want to select for "Account" shows up twice

- Even if I only select it once in the wizard, the Connector adds it twice to my worksheet

- If I try to run the query with this custom field added twice, I get an error about dupicate fields (exception code 5077)

- If I don't use this custom field but rather any other native or custom fields, the Connector pulls the data without error

Does anyone know what the cause of this duplicate field in the wizard is? As far as I can tell, and I created it, it's a regular custom text field. One possible clue is that this custom field is visible in the wizard next to all of the other custom fields for Account as it should be. But the duplicate of this custom field is right underneath "Account ID" in the field list.

A second clue is that when I mouse over the cell with the column header for this custom field, its name has an underscore "c" appended to it - like so: "Identification_c." However, if I mouse over the other field names in the spreadsheet, it's only the field label (e.g., "Identification).

And this reminds me that I did do one unique thing to this custom field when I set it up that I didn't do to its brothers. I made it a required field in order to save the record.

Anyway, suggestions on how to include it in the query are appreciated because it is a critical field.

  • February 15, 2007
  • Like
  • 0
I try to install AppExchange toolkit inside Eclipse. I follow the steps according to the instructions in http://adnsandbox.com/appexchange/updates/.

When the Update Manager download the files. The following error occurs: "Update operation has failed". the log indicates the following error:

!ENTRY org.eclipse.update.core 4 0 2006-09-22 12:09:15.917
!MESSAGE Error retrieving "plugins/org.eclipse.team.extras_3.1.0.jar". [Server returned HTTP response code: "404 Not Found" for URL: http://adnsandbox.com/appexchange/updates/plugins/org.eclipse.team.extras_3.1.0.jar.]
org.eclipse.update.internal.core.FatalIOException: Server returned HTTP response code: "404 Not Found" for URL: http://adnsandbox.com/appexchange/updates/plugins/org.eclipse.team.extras_3.1.0.jar.
at org.eclipse.update.internal.core.UpdateManagerUtils.checkConnectionResult(UpdateManagerUtils.java:558)
at org.eclipse.update.core.ContentReference.getInputSize(ContentReference.java:202)
at org.eclipse.update.core.FeatureContentProvider.asLocalReference(FeatureContentProvider.java:228)
at org.eclipse.update.internal.core.FeaturePackagedContentProvider.retrieveLocalJar(FeaturePackagedContentProvider.java:191)
at org.eclipse.update.internal.core.FeaturePackagedContentProvider.getPluginEntryArchiveReferences(FeaturePackagedContentProvider.java:179)
at org.eclipse.update.internal.operations.UpdateUtils.downloadFeatureContent(UpdateUtils.java:627)
at org.eclipse.update.internal.ui.wizards.InstallWizard2.download(InstallWizard2.java:416)
at org.eclipse.update.internal.ui.wizards.InstallWizard2.access$3(InstallWizard2.java:398)
at org.eclipse.update.internal.ui.wizards.InstallWizard2$3.run(InstallWizard2.java:351)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

The org.eclipse.team.extras_3.1.0.jar isn´t in http://adnsandbox.com/appexchange/updates/plugins/. How can I find this file?


  • September 22, 2006
  • Like
  • 0