• ocortinas
  • 0 Points
  • Member since 2010

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 21



Can anyone of you please help me in resolving this issue.


When iam running a commandline dataloader to extract the Accounts iam getting the following error.


C:\Program Files\salesforce.com\Apex Data Loader 18.0\bin>process.bat "c:\progra
m files\salesforce.com\apex data loader 18.0\test\" csvAccountExtractProcess

Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-options] -jar jarfile [args...]
           (to execute a jar file)

where options include:
    -client       to select the "client" VM
    -server       to select the "server" VM
    -hotspot      is a synonym for the "client" VM  [deprecated]
                  The default VM is client.

    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A ; separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
                  set a system property
                  enable verbose output
    -version      print product version and exit
                  require the specified version to run
    -showversion  print product version and continue
    -jre-restrict-search | -jre-no-restrict-search
                  include/exclude user private JREs in the version search
    -? -help      print this help message
    -X            print help on non-standard options
                  enable assertions
                  disable assertions
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
                  load native agent library <libname>, e.g. -agentlib:hprof
                    see also, -agentlib:jdwp=help and -agentlib:hprof=help
                  load native agent library by full pathname
                  load Java programming language agent, see java.lang.instrument


Iam having Apex dataLoader of 18.0 version and JRE SE v1.4.2_19.

Can any one of you know how to resolve this issue.


Thankyou ..




I dont see the datepicker in the page, Am I missing something? javascript? Css?


My Component:


<apex:component controller="HRFormController">
<apex:panelGrid columns="2" cellpadding="0" cellspacing="0">

<apex:outputLabel value="FirstName:" for="firstname"/>	
<apex:inputText id="firstname" value="{!ControllerCase.HEAT_Firstaname__c}" styleclass="text"/>

<apex:outputLabel value="Surname:" for="surname"/>	
<apex:inputText id="surname" value="{!ControllerCase.HEAT_Surname__c}" styleclass="text"/>

<apex:outputLabel value="Start Date" for="joinerStartDate"/> <apex:inputField id="joinerStartDate" value="{!ControllerCase.HEAT_Start_Date__c}"/> 
<apex:outputLabel value="Start Date" for="joinerStartDate"/>
<apex:inputField id="joinerStartDate" value="{!ControllerCase.HEAT_Start_Date__c}"/> 




  • April 07, 2010
  • Like
  • 0

I have been trying all morning to get around an auto formatting issue when creating the HTML version of an email template. When I put in the signature lines, and click the mouse to save it, it autoformats the area and spreads the type out in a manner as shown below:


My namd

My tilte                                                                                     Company name

street address                                                                                                                                       part of ciyt state


I want this information to be stacked, with no luck.  It saves in this format.  When I click the mouse again, it goes back to the stacked version. When I click the mouse to save it, it reorganizes itself as above. Any ideas of how to get this to stop happening? Thanks.


The following line:



Account: <apex:outputText value="{!X360_Contract_Cycle__c.Account__c}" />

 Produces the following on my VisualForce page (rendered as pdf):



Prepared for: 001Q0000008olvcIAA


I tried changing this to outputField instead of outputText (example below):



Account: <apex:outputField value="{!X360_Contract_Cycle__c.Account__c}" />

This displays the account name correctly (not the record ID).  That is good....except it included the account name as a selectable link on the rendered PDF.  What is the best way to output the value, not as the record ID, and not include the value as a link?  So far running into a little bit of a catch 22.  Thanks in advance for the help! 



How do i order the Tab Position in salesforce.





I wanted to update a custom field in campaign, through my .net application.


I am doing it in this way.


retrive the campaign and update a custom field in it. then update the campaing like in following line of code.


 SaveResult[] saveResults = SfdcBinding.update(new sObject[] { updatedcampaign });


Now this return a sucessful transaction. It shows that the update was sucessful. But when i see in the campaign through salesforce IDE, i dont see the field updated.


Not sure whats going wrong.


Please help me!



I have a picklist called 'Account Type' which has 3 values :


1) Group

2) Account

3) Account Location


I dont want to have search functionality for records who may have Account Type value as Group or Account.  Those records should be hidden from the users.


Is there a way to do this?






After a record type is selected for an Opportunity, I would like to set some default field values by overriding the Continue button (i.e., modifying the URL).  Each Opportunity record type needs different default field values set.


How can I override the Continue button?



Barb R.

  • March 31, 2010
  • Like
  • 0

I need a simple record count to count total record of contacts in an Account object.





  • March 31, 2010
  • Like
  • 0

Hi everyone i have a list in my Apex class which has soql query result..


String query = 'SELECT  City,Latitude__c FROM Lead WHERE City LIKE \''+city+'%\'';
        leadrecords = Database.query(query);   


Eg :in the above line leadrecords is alist of lead type


    private List<Lead> leadrecords;


So now iam trying to pass this list to ajavascript variable so dat javascript variable should have query  output...but when i have done like this iam able to pass the list but when iam tryong to display that it is displaying the  ids  but i want to display the field city and latitude which are storesd in that list how to do it please someone help me with the solution... to javascript variable so how to pass this list to javascript variable


I am trying to use Apex Explorer and when I try to login, I am getting an error.  The error message window is titled "Partner Sample" and the message is "Login failed: Input string was not in a correct format."  


Any ideas on what to try?


Writing a c#.net program and I get this error on my server, but not my local machine. Any ideas on why its different?


Here is the line of code in question:


opp = (Quote)qr.records[i];



Hey guys,


I'm trying to add a number of days calculation in my Visualforce page, and this calculation is basically counting the number of days left to the end of a process.


I'm working with a date/time field, axns.Finish_date_time__c, so I use the ROUND() function to calculate the number of days only.


Here is the formula that I use to calculate the number of days left for my process:




This formula works well, but for some reason when it is equal to 10 days it shows the number in the following manner: 1E+1



Is there a way to display this number as 10?



Thank you,



  • March 17, 2010
  • Like
  • 0

I'm trying to add fields via a trigger to a picklist that has existing fields.


If I have cities and it already has chicago, but this trigger now says put New York, how would this be completed?


I tried doing += and it did not work.





I have simply copy and pasted this ajax code from the tutorial in a vf page yet it does not seem to be working. Help will be appreciated



<apex:page> <script type="text/javascript"> var __sfdcSessionId = '{!GETSESSIONID()}'; </script> <script src="../../soap/ajax/18.0/connection.js" type="text/javascript"></script> <script type="text/javascript"> window.onload = setupPage; alert("hi"); function log(message) { alert(message); } function setupPage() { //function contains all code to execute after page is rendered var state = { //state that you need when the callback is called output : document.getElementById("output"), startTime : new Date().getTime()}; var callback = { //call layoutResult if the request is successful onSuccess: layoutResults, //call queryFailed if the api request fails onFailure: queryFailed, source: state}; sforce.connection.query( "Select Id, Name, Industry From Account order by Industry", callback); } function queryFailed(error, source) { source.output.innerHTML = "An error has occurred: " + error; } /** * This method will be called when the toolkit receives a successful * response from the server. * @queryResult - result that server returned * @source - state passed into the query method call. */ function layoutResults(queryResult, source) { if (queryResult.size > 0) { var output = ""; The AJAX Toolkit Sample Visualforce Page Using the AJAX Toolkit //get the records array var records = queryResult.getArray('records'); //loop through the records and construct html string for (var i = 0; i < records.length; i++) { var account = records[i]; output += account.Id + " " + account.Name + " [Industry - " + account.Industry + "]<br>"; } //render the generated html string source.output.innerHTML = output; } } </script> <div id="output"> </div> </apex:page>


 I cannot see any output not even that alert("hi") message!!!


  • March 17, 2010
  • Like
  • 0



I have form that does a post to Salesforce using WebRequest and then does a response.redirect to itself with an appended query string. I find that the record gets inserted in Salesforce only when the optional Salesforce debugging elements are enabled. However, when I comment out the debug fields, it fails to be inserted in Salesforce. 


Any help would be greatly appreciated.


Thank you!

Message Edited by shirlz on 03-14-2010 04:52 PM
  • March 14, 2010
  • Like
  • 0

I used SOSL in my .net code to retrieve the records.


But the search is returning all the records which meet the criteria. Is there any way to filter based on the Userid / Sharing like we do in Apex?


Please advise...Thanks

  • March 11, 2010
  • Like
  • 0