• jhurst
  • 1165 Points
  • Member since 2004
  • VP, Product Management
  • salesforce.com

  • Chatter
  • 43
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 264

I am having web application developed in .net,which is integrated with SF using canvas app, which is not working in IE where as it is working in Chrome and FF, I also looked into the below forum which suggest to not to use frames,

so that I tried loading a simple page which contains a single text line , but still it was not working in IE. 

I tried all other settings as suggested in SalesForce help documents as well but still not working. For your refference when I opended developed option, it was throwing below error.

SCRIPT87: Invalid argument.

CanvasRendering.js, line 39 character 185


Please help asap

I created a canvas app, but when I open it in Chatter page, I got the following error message.


Load denied by X-Frame-Options: does not permit framing.


Has anyone heard if there are plans to extend Canvas Apps (http://blogs.developerforce.com/developer-relations/2012/09/create-force-com-apps-anywhere-with-force-com-canvas.html)  for deeper integration into force.com or if there is a way to do this today?


I'm looking at building an integration by building and distributing Visual Force Components.  The idea is to provide a new UI feature which force.com developers can easily snap into Visual Force pages.  But, one limitation I encountered is with outbound web requests, limited to 3MB, among other limitations.  For this reason, I'm led to see if I can host my features outside of Salesforce and then integrate as a Canvas App or using a similar iframe approach.


Canvas Apps look very interesting because (assuming I understand correctly) they allow me to develop on my own platform and hosting provider and at the same time providing users with a single sign-on experience.  The limits I would encouter developing Canvas Apps are those which apply to web services, which I have found to be much more relaxed.


However, Canvas Apps appear to be limited to presenting as a link from the Chatter page.  It would be great if I could leverage the goodness of Canvas Apps from inside a custom component.  


I've also thought about spinning my own, using OAuth + iFrame approach.  I think this approach could do the trick but wanted to first see if others have tried using the Canvas Apps goodness in other places such as Visual Force pages and components.

I am trying to write this validation rule



OR(AND($RecordType.Name ="Opportuntiy", ISPICKVAL( StageName , "Closed Won") ,ISBLANK(Revenue_Start_Date__c )))


This works but I need the Revenue Start date to be >= to close date thats on the Opportunity. 

how can I fix this rule to make it work. 


Thank you



I am trying to watch the spring 12 training modules and getting error saying it is not available.

Here is the link:



Any help appreciated.

  • March 26, 2012
  • Like
  • 0

Dear gurus:


How do I set up salesforce to bypass the choose case record type page when creating case on customer portal







i have quick question can we export the reports object data or name of all the report folders by using the data loader.


i want to have a excel sheet of all the folder names and reports under that folder in a excel sheet. OR else could you please suggest me any other way to do it.


i want this as they are many unwanted reports and reports folders are lying there. So want to do a clean up.


Thanks in adavance.



I can't get this to work and was hoping someone can help...  Any thoughts?


IF(BEGINS( Phone , "(804)"), "Richmond",
IF(BEGINS(Phone , "(757)"),"Virginia Beach - Norfolk",
IF(BEGINS(Phone , "(704):(980)"),"Raleigh",
IF(BEGINS(Phone , "(919)"),"Charlotte",
IF(BEGINS(Phone , "(813):(727):(941)"),"Tampa",
IF(BEGINS(Phone , "(321):(407)"),"Orlando",
IF(BEGINS(Phone , "(904)"),"Jacksonville",
IF(BEGINS(Phone , "(770):(678):(404)"),"Atlanta",
IF(BEGINS(Phone , "(914):(631):(516):(347):(718):(917):(212):(646):(862):(973):(201):(551)"),"NYC - Newark",
IF(BEGINS(Phone , "(484):(610):(835):(215):(267):(856):(609):(302)"),"Philadelphia",
IF(BEGINS( Phone , "(781):(857):(339):(617)"),"Boston",
IF(BEGINS(Phone , "(716):(858)"),"Buffalo",
IF(BEGINS(Phone , "(860)"),"Hartford",
IF(BEGINS(Phone , "(401)"),"Providence",
IF(BEGINS(Phone , "(305):(786):(954):(754)"),"Miami",
IF(BEGINS(Phone , "(412):(878)"),"Pittsburgh",
IF(BEGINS(Phone , "(513)"),"Cincinnati",
IF(BEGINS(Phone , "(216):(440)"),"Cleveland",
IF(BEGINS(Phone , "(614)"),"Columbus",
IF(BEGINS(Phone , "(571):(703):(202):(240):(301)"),"DC",
IF(BEGINS(Phone , "(410):(443)"),"Baltimore",

  • February 18, 2012
  • Like
  • 1

I currently have two working formulas:

Amount * IF(Proactive_Outreach_Allowed__c, 0.8, 0.37)

This formula multiplies the amount times .8 if the checkbox for proactive outreach allowed is checked, but it will multiply by .37 if the checkbox is not selected.

IF(ISPICKVAL(Product_Pitching__c, "Outplacement"), ROUND(Amount *0.8, 0), 0)

This formula multiplies the amount by .8 if the Product Pitching picklist value is Outplacement and rounds the answer to 0 decimal places. If the product pitching picklist value is not outplacement then the answer is 0.

I want to combine these formulas so that if the picklist value is outplacement AND proactive outreach allowed is selected then the amount is multiplied by .8, but if the picklist value is outplacement AND the proactive outreach allowed is not selected then the amount is multiplied by .37. If needed in this instance, if outplacement is not selected as the picklist value, then the answer can be 0. Basically I want a formula that is dependent on two factors.

Can you please provide any suggestions?

hi, is it possible to configure the Notes and Attachments, View All page to display the date a note or attachment was created? If not, has anyone got an example Visualforce page that lists the Notes and Attachments that I could customise? thanks.

Hi all,


I have one junction object EmpDepartment which link with Employee and Department object and on click of stranded delete button it will delete record from all three object (EmpDepartment, Employee ,Department ).



Can any one help me on this requirement.


Thanks in advance,




I am trying to add a Custom Field of URL type.  Using the Formula editor, I am building a URL.  I can't seem to figure out how to access a query string parameter.  In APEX, this will work: {$CurrentPage.parameters.exampleParm}


Is there an equivalent for this using the Formula Editor for a field? 


I added a column to the Search results native page and this is where this field will go.


Any help would be greatly appreciated.






I have to build a number of recurring tasks via Apex.  Most are straightforward.  However some are n-th *day of the month - like "2nd Tuesday of the Month".  These can be created in the interface, but i don't know how to create them in Apex.  My guess is:

1) RecurrenceType = Monthly

2) RecurrenceDayOfWeekMask = (approrpiate day-of-week value)

3) RecurrenceInterval = n (as in n-th Tuesday)


However this fails with the following runtime message:

INVALID_FIELD_FOR_INSERT_UPDATE, Day of week must be blank for type Recurs Monthly.: [RecurrenceDayOfWeekMask]


How can i say what day of the week it is if this field must be blank?




We have a tier discounting level for our dealers that depends on their sales.

My issue is, I want to create a field on our accounts called "Discount Level" and have it so that any time a product is added to a Opp, that it auto applies the discount level to the line item based on the account that is associated.

Any Suggestion?

How can I insert a link to the bottom of an email template so that an email recipient can unsubscribe to future emails? I am using the Professional version of SF. Thanks for your help!

 we are working on arequirement where it is required for us to create number of public calendar. before proceeding withis we want to confirm what is the number of public calendars we can create in our sandbox/production.


please reply if anyone knows about it as soon as possible.


Thank you


  • January 11, 2012
  • Like
  • 0



I want to remove some components from my Eclipse project - for example, some profiles. So I pull up "Add or remove Metadata components", untick the components I want to remove, and refresh the project from server. 


But the components remain there! The only way I can make them go away is by deleting and re-loading the whole project.


Is this a bug, or what am I doing wrong?



  • January 06, 2012
  • Like
  • 0

Hi There, 


I downlaoded the lexiloader to my macbook air at home but now that I  have come to work I cannot log in.  I am getting a similar error message to previous posters with the issue  "request to https://www.salesforce.com /services/soap/u/23.0 timed out. Time taken 60723.\


I have used my security token, ensured that the address in the settings is http://www.salesforce.com but it still wont work.  is it anything to do with the fact i downlaoded it from home? I wouldnt have thought so but it seems to wirk fine from there still...


Please help! 

Hi Guys,


I've an App developed using Developer Edition. Now I want to put it on AppExchange and also I want to demo application to my customers. I never done that before. So how can I do this. Please tell me the steps.




I am trying to create a test class for two trigger I have created.  This first trigger is:


trigger Update_ProviderTracking_01 on Task (after update)

{for (Task t:System.Trigger.new)
{if (t.Subject == 'Mail Provider Intro Letter' && t.IsClosed==True) {        

Provider_Facility__c PF = new Provider_Facility__c(ID=t.WhatId, Provider_Intro_Letter_Mailed__c = True);       

update PF;  }  }


The test class is:


@isTestclass MyTestClass001 {    static testMethod void myUnitTest() {        // TO DO: implement unit test       DateTime dT = System.now();Date myDate = date.newinstance(dT.year(), dT.month(), dT.day());
Task o = new Task();o.Subject = 'Mail Provider Intro Letter'; //set the required fieldso.WhatId=[select id from Provider_Facility__c limit 1].id;o.Status='Not Interested - Other';//o.priority='Normal';//o.ActivityDate=myDate;//o.assign='Todd Barry';insert o;
o.Status='Complete';update o;

{if (o.Subject == 'Mail Provider Intro Letter'&& o.IsClosed==True) {         Provider_Facility__c PF = new Provider_Facility__c(ID=o.WhatId, Provider_Intro_Letter_Mailed__c = True);        update PF;  }}


and I get 100% coverage


My Second trigger is exactly the same as the first, execpt I am testing for different Task subject:


trigger Update_ProviderTracking_02 on Task (after update)

{for (Task t:System.Trigger.new)
{if (t.Subject == 'Follow Up Call to Intro Letter' && t.IsClosed==True) {

       Provider_Facility__c PF = new Provider_Facility__c(ID=t.WhatId, Intro_Letter_Follow_Up_Call_Made__c=True);       

update PF;  }  }


and the test class is 


@isTestclass MyTestClass002 {    static testMethod void myUnitTest() {        // TO DO: implement unit test       


Task o = new

Task();o.Subject = 'Follow Up Call to Intro Letter';

o.WhatId=[select id from Provider_Facility__c limit 1].id;

o.Status='Not Interested - Rates';//o.priority='Normal';

insert o;



update o;

{if (o.Subject == 'Follow Up Call to Intro Letter' && o.IsClosed==True) {         Provider_Facility__c PF = new Provider_Facility__c(ID=o.WhatId, Intro_Letter_Follow_Up_Call_Made__c=True);        update PF;  }}


but this time I only get 50% coverage and it highlights the last line Provider_Facility__c PF = new Provider_Facility__c(ID=o.WhatId, Intro_Letter_Follow_Up_Call_Made__c=True);        update PF;   in red.


Any ideas why one get 100% and the other only 50%?

Hi All,

We believe we've hit a bug with the BULK API. When trying to perform a large query using PKChunking and an ORDER BY keyword the query fails.

Specifically, it appears that the BULK API is trying to submit multiple batches on different ranges (as it should), but since it's appending the range filter after the ORDER BY clause it's failing with the following error:

(msg=InvalidBatch : Failed to process query: MALFORMED_QUERY: Field_name FROM Account ORDER BY Id where Id >= '001150000yyyyyy' and ^ ERROR at Row:1:Column:xxxx unexpected token: 'where'), aborting

A sample SOQL query that will fail when Sforce-Enable-PKChunking header is set to True:

'SELECT Id,Name from Account ORDER BY Id'

Any suggestions/thoughts would be highly appreciated!

Thanks in advance,
The BulkAPI doc states "parent—Specifies the parent object when you’re enabling PK chunking for queries on sharing objects".

However when using the Parent for a custom object like Request__Share ( parent = Request__c)  the batch fails because the query tries to use Request__cId as the where clause field instead of ParentId.

Are custom object share tables not supported with PKChunking ?
We have a Canvas connected app that is using the Web Server OAuth flow.  This is working for all of our clients except for one who is in version winter 16 beta and Performance Edition in their sandbox.  We have “Admin approved users are pre-authorized”.  However for this client we are getting an error from the RemoteAccessAuthorizationPage.apexp (see the ConsoleLog.png), it is refusing to display because of the x-frame-options.  It is our understanding that with the pre-authorized OAuth setting, this page does not need to display, but simply redirect back to our Canvas app.  If we open the RemoteAccessAuthorizationPage in another window (outside the iframe), we see the see the page in the attached RequestingPermission.png image.  We are presuming this is the page users would see if the OAuth setting was “All users may self-authorize”.  After clickin “allow” on this page, our Canvas app authorizes and loads.  We want to help this customer use our app.  Can you tell us why this is not working and how to fix it?  Is there an additional setting needs to be tweak for this version?
User-added image 
User-added image
A second issue is that the request to our Canvas app from all installed instances comes from a URL host ending with “visual.force.com”.  From this customer the URL host is “cvent--pcopy.cs21.my.salesforce.com” which does not end with “visual.force.com”.  Why is that?
I'm getting an "Invalid Batch" error when upserting records via DBAmp that uses the native Salesforce Bulk API. We've had this failure several times and I believe that all permissions have been set appropriately. The last change made to the custom object was 2 new fields that the calling user has write access to.

Please help.
  • September 08, 2015
  • Like
  • 0
Jitterbit is throwing this error message, and I was wondering if anyone had any insight as to what Salesforce doesn't like about the operation?

Fatal Error:
Transformation failed.

Call to webservice at https://na25.salesforce.com/services/Soap/u/33.0/00Di0000000HoUP failed. Reported error: The webservice call failed. Failed to check for a SoapFault in the response: D:/Temp/jitterbit/OpId_551186_b683752b-91c9-4c26-b945-54faedbc4f5b/_t636876_target_res.xml Failed to check for Soap Fault in the response: Fatal SAX error: Invalid document structure XML file: D:/Temp/jitterbit/OpId_551186_b683752b-91c9-4c26-b945-54faedbc4f5b/_t636876_target_res.xml The response was: [{"channel":"/meta/subscribe","clientId":"i21moplv8c3qqiiu7gbzivbr0eg","error":"400::Cannot send messages with different client ids in the same request","successful":false}] <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns="urn:partner.soap.sforce.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Header><LimitInfoHeader><limitInfo><current>54795</current><limit>3710000</limit><type>API REQUESTS</type></limitInfo></LimitInfoHeader></soapenv:Header><soapenv:Body><queryResponse><result xsi:type="QueryResult"><done>true</done><queryLocator xsi:nil="true"/><size>0</size></result></queryResponse></soapenv:Body></soapenv:Envelope> (The posted soap envelope was: 'D:/Temp/jitterbit/OpId_551186_b683752b-91c9-4c26-b945-54faedbc4f5b/_t636876_target_req.xml'.) [CODE:10721] file: WebServiceHandler.cpp, line 857 [CODE:10104] file: TreeMapperWebService.cpp, line 141
My company has a stand-alone web-application external to Salesforce that provides SaaS tools for financial advisors. We would like to make our software capabilities available to financial-advisors from within their Salesforce accounts. Desired integration points include:

 * Allow Salesforce users to log-in to our software automatically from Salesforce - how would we consolidate the accounts? 
 * Allow advisors to run our SaaS tools against their leads (i.e. client profiles) that are held in Salesforce.
 * Embed our Web-UI within Salesforce - we have multiple tabs on our site. Is it possible to embed some of these in iframes on a user's Salesforce console? 
 * Make our software tools available as Salesforce applications - is there some kind of store for plugins? 
 * Manage paid-subscriptions for use of our software

Do I need to rewrite our web-application as a Salesforce app in order to integrate? 

I've not had much luck finding the right integration documentation or examples for what I'm trying to achieve. Hoping someone can point me in the right direction! 


I've developed a salesforce canvas application, and it uses signed requests and POSTs to request the page for the app. Now I've deployed the app and it's installed in a client's org. The issue is that the deployed pages are all requesting the canvas application's page using a GET request. I think it might have something to do with OAuth being used for authentication instead of signed requests in the client org, but I'm not sure. Any ideas as to what the issue is? I'd provide more info or code but I'm not really sure where to begin.

I am having web application developed in .net,which is integrated with SF using canvas app, which is not working in IE where as it is working in Chrome and FF, I also looked into the below forum which suggest to not to use frames,

so that I tried loading a simple page which contains a single text line , but still it was not working in IE. 

I tried all other settings as suggested in SalesForce help documents as well but still not working. For your refference when I opended developed option, it was throwing below error.

SCRIPT87: Invalid argument.

CanvasRendering.js, line 39 character 185


Please help asap

I have a VF page which is part of a Force.com Site. I refer this page using Canvas app. Now I'm trying establish a publish/subscribe model between the VF page in Salesforce and the Canvas app which show the Site page. The problem I'm having is a Javascript error. I don't know what script files I need to add to the VF page to initiate this communication. Attached my code along with this post. I get "Uncaught TypeError: Cannot call method 'publish' of undefined ". I'm showing the Canvas app(Site page) in a service console and the side panel as a another VF page. I'm trying to establish a connection between the VF Page shown by Canvas app and the right side panel Custom VF page?

Site VF page (Shown by the canvas app)

Sfdc.canvas(function() { var sr = {!sJson}; var key = "{!encodedSig}"; });
(function(global) {
var module = function() { function subscribe(event) { Sfdc.canvas.parent.subscribe(event) } function unsubscribe(event) { Sfdc.canvas.parent.unsubscribe(event) } function publish(event) { Sfdc.canvas.parent.publish(event) } function resize(size, target) { Sfdc.canvas.parent.resize(size, target) } return{subscribe:subscribe, unsubscribe:unsubscribe, publish:publish, resize:resize} }(); global.Sfdc = global.Sfdc || {}; global.Sfdc.canvas = global.Sfdc.canvas || {}; global.Sfdc.canvas.controller = module })(this);

var sr = "{!sJson}"; Sfdc.canvas(function() { console.log("in the call "); Sfdc.canvas.controller.subscribe(sr.client, {name : 'demo.testAction1', onData : function (data) { console.log("event received... "); console.log("published message received " + JSON.stringify(data));}} );
First name:
Last name:

Right Frame VF page:

<script type="text/javascript" src="{!URLFOR($Resource.CanvasJavascript,'/CanvasScripts/js/canvas-all.js')}"></script>
<script type="text/javascript" src="{!URLFOR($Resource.CanvasJavascript,'/CanvasScripts/js/canvas.js')}"></script>
<script type="text/javascript" src="{!$Resource.Json2}"></script>


    function testpayload (msg) {

         name: 'pnc.testAction',
         payload : {message:msg},
         target : {canvas : 'app1'}

var sr = "{!sJson}";

Sfdc.canvas(function() {
console.log("in the call sidebar ");
{name : 'demo.testAction1', onData : function (data) {
  console.log("event received sidebar... ");
  console.log("published message received sidebar" + JSON.stringify(data));}}
<apex:form >

    <apex:pageBlock title="Question" helpTitle="Custom Help Title" helpUrl="http://test/" mode="edit">
        <apex:pageBlockButtons >
            <apex:commandButton action="{!saveQuestion}" value="Save"/>
        <apex:pageBlockSection title="Group-1 Questions">
          <apex:repeat value="{!$ObjectType.Question_test__c.FieldSets.Group1}" var="field">
                <apex:inputField value="{!quest[field]}" />
        <apex:pageBlockSection title="Group-2 Questions">
          <apex:repeat value="{!$ObjectType.Question_test__c.FieldSets.Group2}" var="field">
                <apex:inputField value="{!quest[field]}" />

    <apex:commandLink onclick="testpayload('Open')" value="Open" reRender="TestPanel"/><br/>
    <apex:commandLink onclick="testpayload('Closed')" value="Closed" reRender="TestPanel"/>
    <apex:outputPanel id="TestPanel">

Can anyone help me how to get the communication going between the Canvas app's VF page and the VF page on the right frame?

Hi ,


I am trying to integrate an ruby app which  is deployed on Heroku with salesforce canvas . But I am facing lots of issues . Documentation that I found on net were only in context of integration of salesforce canvas with a java app . Can somebody has done sanvas and ruby integration?  If anyone have any link related to same it would be very helpful .

Thanks in advance .

Hi , 


I have tried to create a Connected App and used it in the visual force page with following code 


 <apex:canvasApp applicationName="Saba_Cloud" width="100%" canvasId="my_plan" scrolling="yes" containerId="container1" parameters="{param1:'value1',param2:'value2'}" />


my ConnectedApp is oAuth Enabled and uses oAuth WebFlow access 


Access Method OAuth Webflow (GET)


The issue is I am not getting parameters that I am passing at the time of oAuth or when hitting the sucess URL from salesforce. 


Can you please help my why parameters are not passed to my app. 

Hi there,


I've been developing a canvas app which connect with an external website even log in inside it . To do it I have been making use of Salesforce javascript library inorder to manage to get client and user info to show that website in a chatter tab. 


Everything works well in Chrome and Firefox nevertheless Internet Explorer gives me an javascript error that is from salesforce I think. See the error :


"presence: onFailure in event parser ={"status":-5,"statusText":""}page load happens value=true "


After that the client and user info is not able to be send to my canvas app so the result is a big fail because I have no information about who is logging in. I guess that error is due to crossdomain in internet explorer.


I opened a ticket on salesforce customer technical service but the only answer I had is to try to check my internet explorer settings, how is that possible?it means that I'll need to say it to all users who download the app from appexchange?


Thank you in advance




Diego Romera

Hey All, 


The fact that the canvas app url only provides one endpoint seems to be problematic for us.  We provide the application that is connected, and under the course of normal development would like to be able to put up test versions, etc, without breaking current production users and without having to change the canvas url in the managed package.  Updating the managed package to just change the url seems heavy handed, and problematic as it would need to manually changed back to the production endpoint before release.


Generally we have multiple endpoints for test, beta and prod.   And it seems logical that I wouldnt need to change the managed package based on whether its running in test or prod.  Any suggestions on how I can publish a managed package with the one url but have it target a different endpoint based on something?


Any thoughts would be appreciated.









Let's say we retrieve a specific account using



How to retrieve child records for this specific account? One entity can have 0..multiple child relationships.

e.g.something like following should retrieve Contacts or Cases for the account record...



I am sure this is a dumb question but could not find the answer in the docs. Also using REST explorer but can not figure out how to get child records?


Please help.